cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1145
Views
0
Helpful
19
Replies
Highlighted
Beginner

voice loss with the huge data sending through the phone

Hello, everybody!

 

need help!

 

I have CUCM 7.1

I have a lot of "phone+PC" sets where PS' cable inserted in a phone. and phone is going into the switch

 

I've discovered that when I put a big shunk of data from PC to anywhere the voice from me is degraded. the other side receive a lot of voice drops.

 

it repeats even if both the phones are on the same switch.

 

I looked into the "show interface". there is no drops in input queue of my interface.

 

maybe the built-in switch in the phone works not good...

 

please help :)

19 REPLIES 19
Highlighted
VIP Advisor

What is the load output of show interface during data transfer
Highlighted

5 minute input rate 37242000 bits/sec, 3133 packets/sec
5 minute output rate 1178000 bits/sec, 1933 packets/sec
Highlighted

sorry, the whole output
show interface f0/13
FastEthernet0/13 is up, line protocol is up (connected)
Hardware is Fast Ethernet, address is 64a0.e78c.258d (bia 64a0.e78c.258d)
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 4/255, rxload 114/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, media type is 10/100BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:06, output 00:00:02, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 11900
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 44760000 bits/sec, 3735 packets/sec
5 minute output rate 1575000 bits/sec, 2281 packets/sec
14452947 packets input, 9989017321 bytes, 0 no buffer
Received 418999 broadcasts (323997 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 323997 multicast, 0 pause input
0 input packets with dribble condition detected
319611417 packets output, 35052880059 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
Highlighted

Can you configure the command load-interval 60 on the interface, wait for 5
mins and post the same output.

The rx load seems to be high which seems that the utilization of the
100Mbps interface is high during your data transfer.

I will wait for your output but you need to start creating your l2 qos
template to protect voice traffic.
Highlighted

Hi Mohammed al Baqari 

 

I have already configurated qos on l2

 

sh mls qos input-queue
Queue     :       1       2
----------------------------------------------
buffers   :      66      34
bandwidth :      90      10
priority  :       0      10
threshold1:       8      34
threshold2:      18      66

 

sh mls qos maps
Policed-dscp map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 01 02 03 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

Dscp-cos map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 00 00 00 00 00 00 00 01 01
1 : 01 01 01 01 01 01 02 02 02 02
2 : 02 02 02 02 03 03 03 03 03 03
3 : 03 03 04 04 04 04 04 04 04 04
4 : 05 05 05 05 05 05 05 05 06 06
5 : 06 06 06 06 06 06 07 07 07 07
6 : 07 07 07 07

Cos-dscp map:
cos: 0 1 2 3 4 5 6 7
--------------------------------
dscp: 0 8 16 24 32 46 48 56

IpPrecedence-dscp map:
ipprec: 0 1 2 3 4 5 6 7
--------------------------------
dscp: 0 8 16 24 32 40 48 56

Dscp-outputq-threshold map:
d1 :d2 0 1 2 3 4 5 6 7 8 9
------------------------------------------------------------
0 : 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
1 : 02-01 02-01 02-01 02-01 02-01 02-01 03-01 03-01 03-01 03-01
2 : 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01
3 : 03-01 03-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
4 : 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 04-01 04-01
5 : 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
6 : 04-01 04-01 04-01 04-01

Dscp-inputq-threshold map:
d1 :d2 0 1 2 3 4 5 6 7 8 9
------------------------------------------------------------
0 : 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
1 : 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
2 : 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
3 : 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
4 : 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 01-01 01-01
5 : 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01
6 : 01-01 01-01 01-01 01-01

Cos-outputq-threshold map:
cos: 0 1 2 3 4 5 6 7
------------------------------------
queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1

Cos-inputq-threshold map:
cos: 0 1 2 3 4 5 6 7
------------------------------------
queue-threshold: 1-1 1-1 1-1 1-1 1-1 2-1 1-1 1-1


Dscp-dscp mutation map:
Default DSCP Mutation Map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 01 02 03 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

 

and

sh run int f0/13
Building configuration...

Current configuration : 312 bytes
!
interface FastEthernet0/13
switchport access vlan 44
switchport mode access
switchport voice vlan 555
mls qos trust device cisco-phone
storm-control broadcast level 10.00
storm-control multicast level 10.00
storm-control unicast level 80.00
spanning-tree portfast
spanning-tree bpdufilter enable
end

 

will try to make another experiment. and will write soon

Highlighted

hello again

 

the output is almost the same:

 

sh int f0/13
FastEthernet0/13 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 64a0.e78c.258d (bia 64a0.e78c.258d)
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 3/255, rxload 109/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:08, output 00:00:08, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 13118
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  1 minute input rate 43104000 bits/sec, 3586 packets/sec
  1 minute output rate 1568000 bits/sec, 2192 packets/sec
     17248421 packets input, 12858172353 bytes, 0 no buffer
     Received 445183 broadcasts (337823 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 337823 multicast, 0 pause input
     0 input packets with dribble condition detected
     325768933 packets output, 36549191731 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 pause output
     0 output buffer failures, 0 output buffers swapped out

Highlighted

You have the port configured to trust the qos markings but you don't have any qos policies applied. What type of switch is this and have you tried applying auto qos to the port. It may fix your issue.

Hope this helps.

Highlighted

I have 2960 switch.

here is a part of "show hardware" output

 

Switch Ports Model              SW Version            SW Image                 
------ ----- -----              ----------            ----------               
*    1 26    WS-C2960-24PC-L    15.0(2)SE             C2960-LANBASEK9-M       

Highlighted

Try using the following command under the interface:

auto qos voip cisco-phone

 

Highlighted

already test your advice

the same picture

drops in a voice from me

Highlighted

When you tested it, was with phones on the same switch with the command applied to all ports involved?

 

Also, just to be sure, you are using Cisco phones, correct?

Highlighted

the problem side consists of the cisco phone 9951 and PC connected to the phone.

the other side is the cisco phone 6921

both sides are connected to one switch.

I run "auto qos voip cisco-phone" only on the problem port

huge traffic is going out of switch from the PC connected to 9951

Highlighted

Suggest applying it to both ports just to be thorough.

Also, you may want to sniff the ports to ensure the packets are being marked correctly.

Highlighted

Hi,

Enable priorty queue command on the interface to make sure that voice is
going to 2nd queue. Also enable mls qos trust dscp and mls qos trust
cisco-device phone
This widget could not be displayed.