cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
731
Views
0
Helpful
3
Replies

VOIP DHCP Pool not proper-gating to IP Phones

nexusrouter
Beginner
Beginner

Hello There

Due to my haste I didn't post this discussion in the correct area, I originally posted in the Video over IP instead of this one, Apologies for this.

Hopefully I will get an answer now I am in the correct area

The IP Phones do not get their respective IP addresses from the DHCP pool, however the PC hosts managaes to get their IP addresses from the Data pool. I have written the entire configuration out for you. I have tried all kinds of variations including the IP-helper facility... to no joy.

On the CME Router

Sub-interfaces on fa0/0, too create a voice and data network.

int fa0/0.1

encapsulation dot1q  4

ip address 192.168.10.1 255.255.255.0

exit

int fa0/0.2

encapsulation dot1q 5

ip address 192.168.20.1 255.255.255.0

exit

ip dhcp exclude-address 192.168.10.1 192.168.20.1

ip dhcp pool Data

default-router 192.168.10.1

network 192.168.10.0 255.255.255.0

exit

ip dhcp pool VOIP

default-router 192.168.20.1

network 192.168.20.0 255.255.255.0

option 150 ip 192.168.20.1

exit

--------------------------------------------------------------------------------------------

On the switch...


Creation of Vlan 4 and Vlan 5 respectively

int vlan 4

int vlan 5

on all fa0/0 ports

switchport mode access

switchport access vlan 4

switchport voice vlan 5

exit

On the gigaport connecting to the Communication router

switchport mode trunk

--------------------------------------------------

IP Phones connecting to the switch are straight through as are the PC host's.

At this stage the IP phones should get their IP addresses but don't... however the PC host's manages to get their IP addresses. I also noticed that the IP Phones connected to the switch ports are navigated to the data vlan instead of the VOIP lan.

I am not included the telephony-services, ephone, mx-dn configuration,

telephony-services

ip source-address 192.168.20.1 port 2000

max-dn 10

max-ephone 10

ephone-dn 1

4001

ephone-dn 2

4002

etc etc......

The only configuration I have asertained in regards to the VOIP is below... this is not completed and in a very basic state, mainly due to not getting basic functionality with the DHCP VOIP Pool to the IP phones.

Can anyone please help????

This is all done in Packet Tracer.

3 Replies 3

rcrumm_2
Explorer
Explorer

HI,

Is cdp advertise-v2 turned on? It would need tis command to see the voice vlan.

HTH,

randall

Thank you for the suggestion,

This was one of the first things I checked, through experience I know not having the no cdp advertise-v2 turned on would cause havoc on vlan trunks carrying voice traffic and IP phone connectivity.

Still a head scratcher on this one !

Hi,

Can you try configuring a single port oln
the switch in to VLAN 5 only

!
int fa0/X
shut
switchport mode access
no switchport access vlan 4
no switchport voice vlan 5
switchport access vlan 5
no shut
exit
!

Then see if this phone gets an ip address from
the Voice pool

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers