cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2804
Views
0
Helpful
5
Replies

VoIP Dial Peer Destination Pattern

alan-zhan
Level 1
Level 1

Hi, I want to ask that I have two site which have telephony services.

At the Extension 1, when I press number 1000, it shows the message "To 1" and "Busy".

At the Extension 1000, when I press number 1, it shows "Unknown number".

So how can I configure the dial-peers or destination-pattern that can make phone call successfully between these two phones?

The part of the configuration of Extension 1000 Side

dial-peer voice 1 voip
destination-pattern [1-9]$
session target ipv4:10.0.0.1

The part of the configuration of Extension 1 Side

dial-peer voice 1 voip
destination-pattern 1[0-9][0-9][0-9]$
session target ipv4:10.0.0.2

2 Accepted Solutions

Accepted Solutions

Hi Alan,

Right now you have an overlapping dial plan (extension 1 has the same first leading digit as extension 1000).

In the first section of debug (where phone 1 tries to call 1000) we can see the following:

*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_ANSWER; Calling Number=1

*Mar 20 04:18:18.075: //-1/9B4D661082B8/DPM/dpMatchPeersCore:
Match Rule=DP_MATCH_DEST; Called Number=1

List of Matched Outgoing Dial-peer(s):
1: Dial-peer Tag=20001


When you tried to dial 1000 from the phone with the extension of 1, the CME matched "1" immediately and tried to route it to the DN on the phone with extension 1 (phone 1 is calling itself). Since phone 1 only has a single line DN, the call will ring busy.

To make it much easier I would suggest configuring the different sites with non-overlapping extensions, for example change phone 1 to extension 2000. That way, you will have no overlap between the sites and will be able to dial properly without being interrupted.

Please rate helpful posts.

View solution in original post

If you are using digit-by-digit dialing and not enbloc dialing, there is no really clean method for the topology you have created. There are ways you could "make it work" using translations or DNs with call forward all set, but the best design would be to assign non-overlapping extensions to your sites.

I am not sure if packet tracer supports it, but if you do an enbloc dial from phone 1 to phone 1000 it should work based on the dial-peers you have configured.

To perform an enbloc dial from phone 1, dial the number 1000 while the phone is on hook, and then press the dial button. Since the digits are sent all at once to the CME, it should not match dial-peer 20001.

Let us know if this helps.

View solution in original post

5 Replies 5

Manish Gogna
Cisco Employee
Cisco Employee

Add "incoming called-number ." under the dial peers. If the issue persists then share the complete config.

Manish

I add the incoming called-number . under the dial peers, but the problem still exist.

This is the configuration related to VoIP

(Extension 1 Side)

interface Tunnel0
ip address 10.0.0.1 255.255.0.0
no ip redirects
!
interface GigabitEthernet0/0
ip address 57.0.0.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 57.1.0.1 255.255.255.0
!
interface GigabitEthernet0/1.20
encapsulation dot1Q 20 native
ip address 57.1.1.1 255.255.255.0
ip helper-address 57.1.0.32

!
router eigrp 1
network 10.0.0.0 0.0.0.255
network 57.1.0.0 0.0.0.255
network 57.1.1.0 0.0.0.255
passive-interface GigabitEthernet0/1.10
passive-interface GigabitEthernet0/1.20
!

dial-peer voice 1 voip
destination-pattern 1[0-9][0-9][0-9]$
session target ipv4:10.0.0.2
incoming called-number .

!
!
gatekeeper
shutdown
!
!
telephony-service
max-ephones 5
max-dn 10
ip source-address 57.1.1.1 port 7000
auto assign 1 to 1
auto assign 1 to 5
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn 1
number 1
!
!
ephone-dn 2
number 2
!
!
ephone-dn 3
number 3
!
!
ephone-dn 4
number 4
!
!
ephone-dn 5
number 5
!
!
ephone 1
device-security-mode none
transfer max-length 4
mac-address 108C.CF75.9A1F
type 7962
button 1:1

(Extension 1000 Side)

interface Tunnel0
ip address 10.0.0.2 255.255.0.0
no ip redirects

!

interface GigabitEthernet0/0
ip address 57.0.0.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 57.2.0.1 255.255.255.0
ip helper-address 57.1.0.32
duplex auto
speed auto
!

router eigrp 1
network 10.0.0.0 0.0.0.255
network 57.2.0.0 0.0.0.255
passive-interface GigabitEthernet0/1
!

dial-peer voice 1 voip
destination-pattern [1-9]$
session target ipv4:10.0.0.1
incoming called-number .
!
!
!
!
gatekeeper
shutdown
!
!
telephony-service
max-ephones 5
max-dn 5
ip source-address 57.2.0.1 port 7000
auto assign 1 to 1
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn 1
number 1000
!
!
ephone 1
device-security-mode none
mac-address FCFB.FB11.B0D5
type 7962
button 1:1
!

I also enable debug voip dialpeer all and try to call extension 1000 from extension 1, it always hit to DIal-peer 20001 

This is the debug message from Extension 1 Site's Router.


*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Calling Number=1, Called Number=, Voice-Interface=0x3E9CC0A8,
Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_VOICE,
Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_ANSWER; Calling Number=1
*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
Is Incoming=TRUE, Number Expansion=FALSE
*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Dial String=, Expanded String=, Calling Number=1T
Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Result=-1
*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@7287
*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_ORIGINATE; Calling Number=1
*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
Is Incoming=TRUE, Number Expansion=FALSE
*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Dial String=, Expanded String=, Calling Number=1T
Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
Result=Success(0); Incoming Dial-peer=20001 Is Matched (2 digits)
*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@7287
*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=20001
*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerSPI:exit@7869
*Mar 20 04:18:18.075: //-1/9B4D661082B8/DPM/dpMatchPeersCore:
Calling Number=, Called Number=1, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 04:18:18.075: //-1/9B4D661082B8/DPM/dpMatchPeersCore:
Match Rule=DP_MATCH_DEST; Called Number=1
*Mar 20 04:18:18.075: //-1/9B4D661082B8/DPM/dpMatchCore:
Dial String=1, Expanded String=1, Calling Number=
Timeout=FALSE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 04:18:18.075: //-1/9B4D661082B8/DPM/MatchNextPeer:
Result=Success(0); Outgoing Dial-peer=20001 Is Matched (2 digits)
*Mar 20 04:18:18.075: //-1/9B4D661082B8/DPM/dpMatchPeersCore:
Result=Success(0) after DP_MATCH_DEST
*Mar 20 04:18:18.075: //-1/9B4D661082B8/DPM/dpMatchSafModulePlugin:
dialstring=1, saf_enabled=1, saf_dndb_lookup=0, dp_result=0
*Mar 20 04:18:18.075: //-1/9B4D661082B8/DPM/dpMatchPeersMoreArg:
Result=SUCCESS(0)
List of Matched Outgoing Dial-peer(s):
1: Dial-peer Tag=20001
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Calling Number=1, Called Number=, Voice-Interface=0x0,
Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_ANSWER; Calling Number=1
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
Is Incoming=TRUE, Number Expansion=FALSE
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Dial String=, Expanded String=, Calling Number=1T
Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Result=-1
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@7287
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_ORIGINATE; Calling Number=1
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
Is Incoming=TRUE, Number Expansion=FALSE
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Dial String=, Expanded String=, Calling Number=1T
Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
Result=Success(0); Incoming Dial-peer=20001 Is Matched (2 digits)
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@7287
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Result=NO_MATCH(-1) After All Match Rules Attempt
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1
*Mar 20 04:18:18.075: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeer:exit@7918
*Mar 20 04:18:18.075: //-1/9B4D661082B8/DPM/dpMatchPeersCore:
Calling Number=, Called Number=1, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 04:18:18.075: //-1/9B4D661082B8/DPM/dpMatchPeersCore:
Match Rule=DP_MATCH_DEST; Called Number=1
*Mar 20 04:18:18.075: //-1/9B4D661082B8/DPM/dpMatchCore:
Dial String=1, Expanded String=1, Calling Number=
Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH

And on the Extension 1000, I try to call extension 1 and it works, but I call extension 1002 it still transfer it to extension 1, the message on the IP phone shows "To 1". 

This is the debug info from Extension 1000 site's Router:

*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Calling Number=1000, Called Number=, Voice-Interface=0x230E10C8,
Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_VOICE,
Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_ANSWER; Calling Number=1000
*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
Is Incoming=TRUE, Number Expansion=FALSE
*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Dial String=, Expanded String=, Calling Number=1000T
Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Result=-1
*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@7287
*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_ORIGINATE; Calling Number=1000
*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
Is Incoming=TRUE, Number Expansion=FALSE
*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Dial String=, Expanded String=, Calling Number=1000T
Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
Result=Success(0); Incoming Dial-peer=20001 Is Matched (5 digits)
*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@7287
*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=20001
*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
*Mar 20 05:04:12.010: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerSPI:exit@7869
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchPeersCore:
Calling Number=, Called Number=2, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchPeersCore:
Match Rule=DP_MATCH_DEST; Called Number=2
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchCore:
Dial String=2, Expanded String=2, Calling Number=
Timeout=FALSE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/MatchNextPeer:
Result=Success(0); Outgoing Dial-peer=1 Is Matched (2 digits)
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchPeersCore:
Result=Success(0) after DP_MATCH_DEST
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchSafModulePlugin:
dialstring=2, saf_enabled=1, saf_dndb_lookup=0, dp_result=0
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchPeersMoreArg:
Result=SUCCESS(0)
List of Matched Outgoing Dial-peer(s):
1: Dial-peer Tag=1
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Calling Number=1000, Called Number=, Voice-Interface=0x0,
Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_ANSWER; Calling Number=1000
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
Is Incoming=TRUE, Number Expansion=FALSE
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Dial String=, Expanded String=, Calling Number=1000T
Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Result=-1
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@7287
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_ORIGINATE; Calling Number=1000
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
Is Incoming=TRUE, Number Expansion=FALSE
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Dial String=, Expanded String=, Calling Number=1000T
Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
Result=Success(0); Incoming Dial-peer=20001 Is Matched (5 digits)
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@7287
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Result=NO_MATCH(-1) After All Match Rules Attempt
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeer:exit@7918
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchPeersCore:
Calling Number=, Called Number=2, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchPeersCore:
Match Rule=DP_MATCH_DEST; Called Number=2
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchCore:
Dial String=2, Expanded String=2, Calling Number=
Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/MatchNextPeer:
Result=Success(0); Outgoing Dial-peer=1 Is Matched (2 digits)
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchPeersCore:
Result=Success(0) after DP_MATCH_DEST
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchSafModulePlugin:
dialstring=2, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchPeersMoreArg:
Result=SUCCESS(0)
List of Matched Outgoing Dial-peer(s):
1: Dial-peer Tag=1
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchPeersCore:
Calling Number=, Called Number=2, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchPeersCore:
Match Rule=DP_MATCH_DEST; Called Number=2
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchCore:
Dial String=2, Expanded String=2, Calling Number=
Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/MatchNextPeer:
Result=Success(0); Outgoing Dial-peer=1 Is Matched (2 digits)
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchPeersCore:
Result=Success(0) after DP_MATCH_DEST
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchSafModulePlugin:
dialstring=2, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
*Mar 20 05:04:12.430: //-1/0507552B8279/DPM/dpMatchPeersMoreArg:
Result=SUCCESS(0)
List of Matched Outgoing Dial-peer(s):
1: Dial-peer Tag=1
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
Calling Number=2, Called Number=2, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
Match Rule=DP_MATCH_DEST; Called Number=2
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Dial String=2, Expanded String=2, Calling Number=2T
Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
Result=Success(0); Outgoing Dial-peer=1 Is Matched (2 digits)
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
Result=Success(0) after DP_MATCH_DEST
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
dialstring=2, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
Result=SUCCESS(0)
List of Matched Outgoing Dial-peer(s):
1: Dial-peer Tag=1
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Calling Number=, Called Number=, Voice-Interface=0x0,
Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Result=NO_MATCH(-1) After All Match Rules Attempt
*Mar 20 05:04:12.430: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=-1
*Mar 20 05:04:12.430: //-1/xxxxxxCH
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Result=-1
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@7287
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_ORIGINATE; Calling Number=2
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:
Is Incoming=TRUE, Number Expansion=FALSE
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Dial String=, Expanded String=, Calling Number=2T
Timeout=TRUE, Is Incoming=TRUE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
Result=Success(0); Incoming Dial-peer=1 Is Matched (2 digits)
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpMatchPeertype:exit@7287
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=1
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
dialstring=NULL, saf_enabled=0, saf_dndb_lookup=0, dp_result=0
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeer:exit@7918
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
Calling Number=, Called Number=2, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
Match Rule=DP_MATCH_DEST; Called Number=2
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpMatchCore:
Dial String=2, Expanded String=2, Calling Number=
Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/MatchNextPeer:
Result=Success(0); Outgoing Dial-peer=1 Is Matched (2 digits)
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
Result=Success(0) after DP_MATCH_DEST
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpMatchSafModulePlugin:
dialstring=2, saf_enabled=0, saf_dndb_lookup=1, dp_result=0
*Mar 20 05:04:12.434: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
Result=SUCCESS(0)
List of Matched Outgoing Dial-peer(s):
1: Dial-peer Tag=1
*Mar 20 05:04:12.434: //-1/0507552B8279/DPM/dpMatchPeersCore:
Calling Number=, Called Number=2, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.434: //-1/0507552B8279/DPM/dpMatchPeersCore:
Match Rule=DP_MATCH_DEST; Called Number=2
*Mar 20 05:04:12.434: //-1/0507552B8279/DPM/dpMatchCore:
Dial String=2, Expanded String=2, Calling Number=
Timeout=TRUE, Is Incoming=FALSE, Peer Info Type=DIALPEER_INFO_SPEECH
*Mar 20 05:04:12.434: //-1/0507552B8279/DPM/MatchNextPeer:
Result=Success(0); Outgoing Dial-peer=1 Is Matched (2 digits)
*Mar 20 05:04:12.434: //-1/0507552B8279/DPM/dpMatchPeersCore:
Result=Success(0) after DP_MATCH_DEST
*Mar 20 05:04:12.434: //-1/0507552B8279/DPM/dpMatchSafModulePlugin:
dialstring=2, saf_enabled=1, saf_dndb_lookup=1, dp_result=0
*Mar 20 05:04:12.434: //-1/0507552B8279/DPM/dpMatchPeersMoreArg:
Result=SUCCESS(0)
List of Matched Outgoing Dial-peer(s):
1: Dial-peer Tag=1

Hi Alan,

Right now you have an overlapping dial plan (extension 1 has the same first leading digit as extension 1000).

In the first section of debug (where phone 1 tries to call 1000) we can see the following:

*Mar 20 04:18:17.651: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
Match Rule=DP_MATCH_ANSWER; Calling Number=1

*Mar 20 04:18:18.075: //-1/9B4D661082B8/DPM/dpMatchPeersCore:
Match Rule=DP_MATCH_DEST; Called Number=1

List of Matched Outgoing Dial-peer(s):
1: Dial-peer Tag=20001


When you tried to dial 1000 from the phone with the extension of 1, the CME matched "1" immediately and tried to route it to the DN on the phone with extension 1 (phone 1 is calling itself). Since phone 1 only has a single line DN, the call will ring busy.

To make it much easier I would suggest configuring the different sites with non-overlapping extensions, for example change phone 1 to extension 2000. That way, you will have no overlap between the sites and will be able to dial properly without being interrupted.

Please rate helpful posts.

Hi, Jonathan.

Thank you for your explanation!

But are there any ways to do it without changing extension?  For example, configure the voice translation-rule or something else.

If you are using digit-by-digit dialing and not enbloc dialing, there is no really clean method for the topology you have created. There are ways you could "make it work" using translations or DNs with call forward all set, but the best design would be to assign non-overlapping extensions to your sites.

I am not sure if packet tracer supports it, but if you do an enbloc dial from phone 1 to phone 1000 it should work based on the dial-peers you have configured.

To perform an enbloc dial from phone 1, dial the number 1000 while the phone is on hook, and then press the dial button. Since the digits are sent all at once to the CME, it should not match dial-peer 20001.

Let us know if this helps.