cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
193
Views
0
Helpful
6
Replies
Highlighted
Beginner

Wasn't Able to Make Inbound + Outbound Calls (CUCM 11.5 + 2900 ISR)

Hello there.

I already deploy CUCM 11.5 Publisher (76.76.76.151) and CUCM 11.5 Subscriber (76.76.76.154). I got my FXO card and PVDM installed on 2900 Router that act as voice gateway (76.76.76.152). I put my telco line on that FXO port 0 which had a PSTN number (This line is active and when i put it in an analog phone, it can be called) I also have my 3905 + 8865 NR IP phone which is already registered on the CUCM. I can make a call locally, DN to DN. But when i tried to call these extension from outside (from my cell phone to be precise), it won't work. Same as when I try to make the outbound call when I hit the pattern (i set this pattern on the route pattern 9[0]XXXXXXXXXXX). 

 

My question is...

To make the inbound and outbound call work, what am i missing? Thanks so much for your attention sir. I'm quite new to this voice thing

 

and here is my show run output on the gateway (76.76.76.152)

 

VoiceGateway#sho run
Building configuration...


Current configuration : 2522 bytes
!
! Last configuration change at 01:30:20 UTC Thu Nov 15 2018
! NVRAM config last updated at 07:22:07 UTC Fri Nov 16 2018
! NVRAM config last updated at 07:22:07 UTC Fri Nov 16 2018
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VoiceGateway
!
boot-start-marker
boot-end-marker
!
!
enable password xxxxx
!
no aaa new-model
!
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
h323
sip
no update-callerid
!
voice class codec 1
codec preference 1 g711alaw
!
voice class h323 1
h225 timeout tcp establish 5
h225 timeout setup 5
call preserve
!
!
!
!
!
!
license udi pid CISCO2921/K9 sn FGL173710FW
license boot module c2900 technology-package uck9
hw-module pvdm 0/0
!
!
!
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 76.76.76.152 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 76.76.76.1
!
!
!
!
control-plane
!
!
voice-port 0/0/0
connection plar 10002
caller-id enable
!
voice-port 0/0/1
connection plar 10002
caller-id enable
!
voice-port 0/0/2
!
voice-port 0/0/3
!
!
!
!
!
!
mgcp profile default
!
!
dial-peer voice 10 voip
description To Call Manager UNMUH
destination-pattern [1-5]...
session target ipv4:76.76.76.151
voice-class codec 1
voice-class h323 1
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 100 pots
description To PSTN Trunk
destination-pattern 9T
port 0/0/0
forward-digits all
!
!
!
!
gatekeeper
shutdown
!
!
alias exec c configure term
alias exec sib sh ip inter bri
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
password qwerty
login
transport input all
!
scheduler allocate 20000 1000
ntp server 76.76.76.101
!
end 

 

Everyone's tags (4)
6 REPLIES 6
VIP Advisor

Re: Wasn't Able to Make Inbound Outbound Calls (CUCM 11.5 2900 ISR)

run debug cch323 h225 and see if the outgoing call is coming from cucm to
gateway. If yes, post the debug in text file. If not coming then go to dna
in cucm and check call routing
Beginner

Re: Wasn't Able to Make Inbound Outbound Calls (CUCM 11.5 2900 ISR)

Hello Mohammed,

I just type that command and all i got is "h225 state machine tracing is enabled". No output afterward. I guess I should check my call routing in CUCM. It indicates that there's no route list can route my call from the cell phone. Is it right?

Beginner

Re: Wasn't Able to Make Inbound Outbound Calls (CUCM 11.5 2900 ISR)

Hi Edy,

As Robert said below, there is no incoming dial peer to accept your call. As an initial configuration, can you do below?

dial-peer voice 1 pots
incoming called-number .
direct-inward-dial

Then do the debug that Mohammed and Robert is asking.
Beginner

Re: Wasn't Able to Make Inbound Outbound Calls (CUCM 11.5 2900 ISR)

hi Flo
already add that config on my gateway, but i still can't call my internal extension. I run that debug command, but still, the output is none. What should i do? am i miss something on my CUCM?
Beginner

Re: Wasn't Able to Make Inbound + Outbound Calls (CUCM 11.5 + 2900 ISR)

Hi,

Firstly, you're missing an Inbound Dial-Peer.  So when you call the number from outside you don't have anything to accept it.  This will by default use a basic Dial-Peer 0.  You need to understand how the Telco is sending the numbers and then you may need to manipulate those digits to send them correctly to Call Manager.

Initially, let's run a test call with the following debugs running on your 2900.

debug voice ccapi inout

This will tell us what digits are coming in and if we need to manipulate them before sending to Call manager.

Thanks
Rob

Beginner

Re: Wasn't Able to Make Inbound + Outbound Calls (CUCM 11.5 + 2900 ISR)

thanks, Robert for the answer...as i post above, when i type that debug command, there's no output, just informing me that debug command is ON/active. And you mention about localization, right? is that a must do in call flow? is that a way that i don't do translation. My main goal is, i can make a call with my internal extension, and vice versa. Big thanks for everyone supporting me here. GBU
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards