cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1067
Views
0
Helpful
5
Replies
wsolanovi
Beginner

Mediasense reporting not active recording to API

Hello Folks,

I have a customer with two node setup of MediaSense 10.5 . Customer is using the MS API to add custom tags to active recordings. The problem is that sometimes MediaSense is telling the API that there are no active calls on the user's IP phone and we now there is an active call. As a result of MS not responding with the SessionID the process of adding the custom tag fails; by any chance you know what could be causing MS to fail to retrieve the sessionID for some calls?

We are using the getSessions method with parameters sessionStartDate, deviceRef (equals), sessionState (active).

Any help will be really appreciated

5 REPLIES 5
Anil Verma
Contributor

There could be a timing issue. MediaSense will show the recording only after the request has been received by MediaSense. It could also be an issue with the HA scenrios, are you checking for the Primary server, and potentially the recording is on the secondary. There might be timing issues there too.

Thank you Anil. We have a 15 seconds delay before the time that we know the UCCX agent answered the call until the time the API asks MS for the recording, if is taking longer that 15 seconds for MS to acknowledge is really unlikely IMO.

For the HA part we enabled Event Forwarding which should allow us to only contact one server and that server should be aware of the events happening in the HA pair from what we understand on the documentation