cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
527
Views
0
Helpful
1
Replies

6VPE on XRV9K(ping not working)

sachin30720041
Level 1
Level 1

Hello,

I have the following setup. int lo1 is under vrf1 on XRV9K1 and XRV9K2.

IPV4 and ipv6 routes are exchanged. Ping between the vpnv4 route works.

XRV9K1#ping vrf vrf1 22.22.22.22 source 11.11.11.11
Sat Sep 3 22:41:57.832 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 7/14/39 ms

But ping between the vpnv6 does not work.

XRV9K1#ping vrf vrf1 22::22 source 11::11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22::22, timeout is 2 seconds:
.UUUU
Success rate is 0 percent (0/5)

 

XRV9K1-----XRV9K2

Below is the configuration.

XRV1

---------------------------

vrf vrf1
address-family ipv4 unicast
export route-target 1:1
no import route-target 1:1
import route-target 2:2
exit
address-family ipv6 unicast
export route-target 1:1
no import route-target 1:1
import route-target 2:2
exit

int gi0/0/0/0
ipv4 address 100.10.20.1 255.255.255.0
ipv6 address 100:10:20::1/64
no sh

int lo0
ipv4 address 1.1.1.1 255.255.255.255
ipv6 address 1::1/128
exit

int lo1
vrf vrf1
ipv4 address 11.11.11.11 255.255.255.255
ipv6 address 11::11/128
exit

mpls ldp
exit

router isis 1
net 49.0001.1111.1111.1111.00
is-type level-2
address-family ipv4 unicast
mpls ldp auto-config
metric-style wide
exit
address-family ipv6 unicast
metric-style wide
exit
int gi0/0/0/0
address-family ipv4 unicast
exit
address-family ipv6 unicast
exit
int lo0
address-family ipv4 unicast
exit
address-family ipv6 unicast
exit

router bgp 12
address-family ipv4 unicast
exit
address-family vpnv4 unicast
exit
address-family vpnv6 unicast
exit
neighbor 2.2.2.2
remote-as 12
update-source lo0
address-family vpnv4 unicast
exit
neighbor 2::2
remote-as 12
update-source lo0
address-family vpnv6 unicast
exit
vrf vrf1
rd 1:1
address-family ipv4 unicast
network 11.11.11.11/32
exit
address-family ipv6 unicast
network 11::11/128
exit

XRV2
=============
vrf vrf1
address-family ipv4 unicast
export route-target 2:2
import route-target 1:1
exit
address-family ipv6 unicast
export route-target 2:2
import route-target 1:1
exit

int gi0/0/0/0
ipv4 address 100.10.20.2 255.255.255.0
ipv6 address 100:10:20::2/64
no sh

int lo0
ipv4 address 2.2.2.2 255.255.255.255
ipv6 address 2::2/128
exit

int lo1
vrf vrf1
ipv4 address 22.22.22.22 255.255.255.255
ipv6 address 22::22/128
exit

mpls ldp
exit

router isis 1
net 49.0002.2222.2222.2222.00
is-type level-2
address-family ipv4 unicast
mpls ldp auto-config
metric-style wide
exit
address-family ipv6 unicast
metric-style wide
exit
int gi0/0/0/0
address-family ipv4 unicast
exit
address-family ipv6 unicast
exit
int lo0
address-family ipv4 unicast
exit
address-family ipv6 unicast
exit
exit

router bgp 12
address-family ipv4 unicast
exit
address-family vpnv4 unicast
exit
address-family vpnv6 unicast
exit
neighbor 1.1.1.1
remote-as 12
update-source lo0
address-family vpnv4 unicast
exit
neighbor 1::1
remote-as 12
update-source lo0
address-family vpnv6 unicast
exit
vrf vrf1
rd 2:2
address-family ipv4 unicast
network 22.22.22.22/32
exit
address-family ipv6 unicast
network 22::22/128
exit

 

Thanks,

Sachin

 

1 Accepted Solution

Accepted Solutions

Harold Ritter
Cisco Employee
Cisco Employee

Hi @sachin30720041 ,

The issue is that you use the IPv6 neighbor (22::22) for the VPNv6 session. Since you have not configured LDPv6, there is no LSP to that IPv6 neighbor and therefore the recursive lookup will not work for the IPv6 prefixes in the VRF. There are two solutions to fix it:

1- configure address-family vpnv6 under the ipv4 neighbor (2.2.2.2)

router bgp 12

neighbor 2.2.2.2

address-family vpnv6 unicast

or

2- enable LDPv6

mpls ldp

address-family ipv6

interface gi0/0/0/0 address-family ipv6

Bear in mind that solution 1 is the one currently being used by most service providers deploying vpnv6, as they have ipv4 enable MPLS cores, and not necessarily an ipv6 enabled MPLS core.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

1 Reply 1

Harold Ritter
Cisco Employee
Cisco Employee

Hi @sachin30720041 ,

The issue is that you use the IPv6 neighbor (22::22) for the VPNv6 session. Since you have not configured LDPv6, there is no LSP to that IPv6 neighbor and therefore the recursive lookup will not work for the IPv6 prefixes in the VRF. There are two solutions to fix it:

1- configure address-family vpnv6 under the ipv4 neighbor (2.2.2.2)

router bgp 12

neighbor 2.2.2.2

address-family vpnv6 unicast

or

2- enable LDPv6

mpls ldp

address-family ipv6

interface gi0/0/0/0 address-family ipv6

Bear in mind that solution 1 is the one currently being used by most service providers deploying vpnv6, as they have ipv4 enable MPLS cores, and not necessarily an ipv6 enabled MPLS core.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México