09-16-2017 12:44 PM - edited 03-01-2019 03:14 PM
Dear Beloved engineers,
direct to my question without longer intro, I'm trying to establish a l2vpn between customer sites via Etherent over mpls. we want to connect the customer A site with vlan tagged and customer B site with untagged vlan.
We tried to configure one side with vc type 4 using vlan mode and other side with type 5 etherent type but VC never comes up. I did a research on cisco threads and i found this note qutoed as below
(
is that means we can't mix connection VC between type 4 and type 5. if no, can you please provide other alternatives to meet our needs.
Thanks in advanced.
Solved! Go to Solution.
09-17-2017 09:57 AM
09-16-2017 02:36 PM - edited 09-16-2017 02:43 PM
Hi
In order to show you the config, I've done a quick design that looks like yours:
On CE1:
!
interface Ethernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
duplex auto
no cdp enable
end
CE1(config-if)#do sh run int e0/0
Building configuration...
Current configuration : 93 bytes
!
interface Ethernet0/0
switchport access vlan 10
switchport mode access
duplex auto
end
On CE2:
!
interface Ethernet0/1
switchport access vlan 10
switchport mode access
duplex auto
no cdp enable
spanning-tree portfast
end
CE2#sh run int e0/0
Building configuration...
Current configuration : 93 bytes
!
interface Ethernet0/0
switchport access vlan 10
switchport mode access
duplex auto
end
On R1:
R1#sh run int e0/0
Building configuration...
Current configuration : 44 bytes
!
interface Ethernet0/0
no ip address
end
R1#sh run int e0/0.10
Building configuration...
Current configuration : 109 bytes
!
interface Ethernet0/0.10
encapsulation dot1Q 10
xconnect 3.3.3.3 1 encapsulation mpls pw-class MPLS
end
R1#sh run | sec pseudo
pseudowire-class MPLS
encapsulation mpls
R1#sh ip int bri | ex unas
Interface IP-Address OK? Method Status Protocol
Ethernet0/1 10.2.0.1 YES manual up up
Loopback0 1.1.1.1 YES manual up up
R1#sh mpls ldp bindings
lib entry: 1.1.1.1/32, rev 2
local binding: label: imp-null
remote binding: lsr: 2.2.2.2:0, label: 17
remote binding: lsr: 3.3.3.3:0, label: 18
lib entry: 2.2.2.2/32, rev 4
local binding: label: 16
remote binding: lsr: 2.2.2.2:0, label: imp-null
remote binding: lsr: 3.3.3.3:0, label: 16
lib entry: 3.3.3.3/32, rev 6
local binding: label: 17
remote binding: lsr: 2.2.2.2:0, label: 16
remote binding: lsr: 3.3.3.3:0, label: imp-null
lib entry: 10.2.0.0/24, rev 8
local binding: label: imp-null
remote binding: lsr: 2.2.2.2:0, label: imp-null
remote binding: lsr: 3.3.3.3:0, label: 17
lib entry: 10.2.1.0/24, rev 10
local binding: label: 18
remote binding: lsr: 2.2.2.2:0, label: imp-null
remote binding: lsr: 3.3.3.3:0, label: imp-null
R1#sh mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Et0/0.10 Eth VLAN 10 3.3.3.3 1 UP
R1#
On R2:
R2#sh run int e0/0
Building configuration...
Current configuration : 97 bytes
!
interface Ethernet0/0
no ip address
xconnect 1.1.1.1 1 encapsulation mpls pw-class MPLS
end
R2#sh ip int bri | ex unas
Interface IP-Address OK? Method Status Protocol
Ethernet0/1 10.2.1.3 YES manual up up
Loopback0 3.3.3.3 YES manual up up
R2#sh run | sec pseudo
pseudowire-class MPLS
encapsulation mpls
R2#sh mpls ldp bindings
lib entry: 1.1.1.1/32, rev 10
local binding: label: 18
remote binding: lsr: 2.2.2.2:0, label: 17
remote binding: lsr: 1.1.1.1:0, label: imp-null
lib entry: 2.2.2.2/32, rev 2
local binding: label: 16
remote binding: lsr: 2.2.2.2:0, label: imp-null
remote binding: lsr: 1.1.1.1:0, label: 16
lib entry: 3.3.3.3/32, rev 4
local binding: label: imp-null
remote binding: lsr: 2.2.2.2:0, label: 16
remote binding: lsr: 1.1.1.1:0, label: 17
lib entry: 10.2.0.0/24, rev 6
local binding: label: 17
remote binding: lsr: 2.2.2.2:0, label: imp-null
remote binding: lsr: 1.1.1.1:0, label: imp-null
lib entry: 10.2.1.0/24, rev 8
local binding: label: imp-null
remote binding: lsr: 2.2.2.2:0, label: imp-null
remote binding: lsr: 1.1.1.1:0, label: 18
R2#sh mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Et0/0 Ethernet 1.1.1.1 1 UP
R2#
As you can see both side have established connection negotiating vc type Ethernet:
On R1:
R1#sh mpls l2transport binding
Destination Address: 3.3.3.3,VC ID: 1
Local Label: 20
Cbit: 1, VC Type: Ethernet, GroupID: 0
MTU: 1500, Interface Desc: n/a
VCCV: CC Type: CW [1], RA [2]
CV Type: LSPV [2]
Remote Label: 22
Cbit: 1, VC Type: Ethernet, GroupID: 0
MTU: 1500, Interface Desc: n/a
VCCV: CC Type: CW [1], RA [2]
CV Type: LSPV [2]
R1#
On R2:
R2#sh mpls l2transport binding
Destination Address: 1.1.1.1,VC ID: 1
Local Label: 22
Cbit: 1, VC Type: Ethernet, GroupID: 0
MTU: 1500, Interface Desc: n/a
VCCV: CC Type: CW [1], RA [2]
CV Type: LSPV [2]
Remote Label: 20
Cbit: 1, VC Type: Ethernet, GroupID: 0
MTU: 1500, Interface Desc: n/a
VCCV: CC Type: CW [1], RA [2]
CV Type: LSPV [2]
I tried to reproduce your design by setuping 1 side using trunk and subinterface and on the other a simple access port without subinterfaces (untagged).
Is that what you tried to achieve?
Thanks
09-17-2017 05:10 AM
Dear Francesco,
I tried to do the same as you did but it didn't work.
The VC shows down as below
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa2/0.50 Eth VLAN 50 3.3.3.3 1 DOWN
Let's focuse on R1 and R2 configuration because CE doesn't play a role in esatblishing L2 vpn mpls circuit.
In R1, there is a vlan and subinterface configured and in R2, etherenet access port without vlan. this is exactly what I want but I keep trying no sucess even though the configuration doesn't seem much complex.
I noticed you configured Psudowire class which only establish virtual point to point connection and encapsulating Mpls packets. I guess using xconnect to create VC and encapsutalting mpls packets enough.
I'm looking forward to hear positive feed back from you,,
Thanks
09-17-2017 05:15 AM
09-17-2017 06:04 AM
I will list below configuration for PE1 and PE2.
PE1 configuration
PE1#sh run
Building configuration...
Current configuration : 1926 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
mpls label protocol ldp
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
pseudowire-class mpls
encapsulation mpls
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
xconnect 3.3.3.3 10 encapsulation mpls
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
xconnect 3.3.3.3 20 encapsulation mpls
!
interface FastEthernet0/0.30
encapsulation dot1Q 30
xconnect 3.3.3.3 30 encapsulation mpls
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
ip address 192.168.1.1 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
duplex auto
speed auto
xconnect 3.3.3.3 1 encapsulation mpls pw-class mpls
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 192.168.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
PE1#sh mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa2/0 Ethernet 3.3.3.3 1 DOWN
Fa0/0.10 Eth VLAN 10 3.3.3.3 10 UP
Fa0/0.20 Eth VLAN 20 3.3.3.3 20 UP
Fa0/0.30 Eth VLAN 30 3.3.3.3 30 UP
PE1#
PE2 Configuration
PE2#sh run
Building configuration...
Current configuration : 1981 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PE2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
mpls label protocol ldp
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
pseudowire-class mpls
encapsulation mpls
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
xconnect 1.1.1.1 10 encapsulation mpls
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
xconnect 1.1.1.1 20 encapsulation mpls
!
interface FastEthernet0/0.30
encapsulation dot1Q 30
xconnect 1.1.1.1 30 encapsulation mpls
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 192.168.2.1 255.255.255.0
mpls ip
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet2/0
no ip address
duplex auto
speed auto
!
interface FastEthernet2/0.50
encapsulation dot1Q 50
xconnect 1.1.1.1 1 encapsulation mpls pw-class mpls
!
router ospf 1
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 192.168.2.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
PE2#sh mpls l2transport vc
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Fa2/0.50 Eth VLAN 50 1.1.1.1 1 DOWN
Fa0/0.10 Eth VLAN 10 1.1.1.1 10 UP
Fa0/0.20 Eth VLAN 20 1.1.1.1 20 UP
Fa0/0.30 Eth VLAN 30 1.1.1.1 30 UP
PE2#
09-17-2017 06:08 AM
09-17-2017 06:39 AM
PE1#sh mpls l2transport vc detail
Local interface: Fa2/0 up, line protocol up, Ethernet up
Destination address: 3.3.3.3, VC ID: 1, VC status: down
Create time: 00:34:37, last status change time: 00:33:45
Signaling protocol: LDP, peer 3.3.3.3:0 up
MPLS VC labels: local 22, remote 22
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, seq error 0, send 0
Local interface: Fa0/0.10 up, line protocol up, Eth VLAN 10 up
Destination address: 3.3.3.3, VC ID: 10, VC status: up
Next hop: point2point
Output interface: Se1/1, imposed label stack {16 17}
Create time: 00:37:31, last status change time: 00:37:06
Signaling protocol: LDP, peer 3.3.3.3:0 up
MPLS VC labels: local 16, remote 17
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, seq error 0, send 0
Local interface: Fa0/0.20 up, line protocol up, Eth VLAN 20 up
Destination address: 3.3.3.3, VC ID: 20, VC status: up
Next hop: point2point
Output interface: Se1/1, imposed label stack {16 16}
Create time: 00:38:29, last status change time: 00:38:04
Signaling protocol: LDP, peer 3.3.3.3:0 up
MPLS VC labels: local 17, remote 16
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, seq error 0, send 0
Local interface: Fa0/0.30 up, line protocol up, Eth VLAN 30 up
Destination address: 3.3.3.3, VC ID: 30, VC status: up
Next hop: point2point
Output interface: Se1/1, imposed label stack {16 18}
Create time: 00:38:33, last status change time: 00:38:08
Signaling protocol: LDP, peer 3.3.3.3:0 up
MPLS VC labels: local 18, remote 18
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, seq error 0, send 0
PE1#
PE2#sh mpls l2transport vc detail
Local interface: Fa2/0.50 up, line protocol up, Eth VLAN 50 up
Destination address: 1.1.1.1, VC ID: 1, VC status: down
Create time: 00:39:17, last status change time: 00:39:17
Signaling protocol: LDP, peer 1.1.1.1:0 up
MPLS VC labels: local 22, remote 22
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, seq error 0, send 0
Local interface: Fa0/0.10 up, line protocol up, Eth VLAN 10 up
Destination address: 1.1.1.1, VC ID: 10, VC status: up
Next hop: point2point
Output interface: Se1/0, imposed label stack {17 16}
Create time: 00:43:01, last status change time: 00:42:37
Signaling protocol: LDP, peer 1.1.1.1:0 up
MPLS VC labels: local 17, remote 16
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, seq error 0, send 0
Local interface: Fa0/0.20 up, line protocol up, Eth VLAN 20 up
Destination address: 1.1.1.1, VC ID: 20, VC status: up
Next hop: point2point
Output interface: Se1/0, imposed label stack {17 17}
Create time: 00:43:11, last status change time: 00:42:48
Signaling protocol: LDP, peer 1.1.1.1:0 up
MPLS VC labels: local 16, remote 17
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, seq error 0, send 0
Local interface: Fa0/0.30 up, line protocol up, Eth VLAN 30 up
Destination address: 1.1.1.1, VC ID: 30, VC status: up
Next hop: point2point
Output interface: Se1/0, imposed label stack {17 18}
Create time: 00:43:11, last status change time: 00:42:48
Signaling protocol: LDP, peer 1.1.1.1:0 up
MPLS VC labels: local 18, remote 18
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, seq error 0, send 0
PE2#
09-17-2017 08:01 AM
09-17-2017 08:35 AM
09-17-2017 08:39 AM
09-17-2017 08:49 AM
09-17-2017 09:16 AM
09-17-2017 09:37 AM
heey
I tried to do some of your given commands but not found on the list maybe it's not in gns3 virtual routers. Anyway I listed what i could in txt file, please take a look.
By the way, I found something intersting when I enabled debuging mpls l2tran vc event
*Mar 1 00:10:08.271: AToM MGR [3.3.3.3, 1]: Local end up
*Mar 1 00:10:08.275: AToM MGR [3.3.3.3, 1]: Mismatch vc type in remote label binding, local 5, remote 4
*Mar 1 00:10:08.279: AToM MGR [3.3.3.3, 1]: Invalidate vc, deactivating data plane
*Mar 1 00:10:08.291: AToM LDP [3.3.3.3]: Sending label mapping msg
vc type 5, cbit 1, vc id 1, group id 0, vc label 19, status 0, mtu 1500
this output showed when I typed debug mpls l2transport vc event, if you check above it states there mismatch vc type. I believe this is the issue. but wait a minute how it worked with you !!
09-17-2017 09:57 AM
09-17-2017 10:17 AM
Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: