03-08-2016 04:16 AM
In GNS 3 lab i am tring to transport routes from R32 to R20. (both routers are PE in the MPLS)
In R32 I have a eBGP adjacency with R1 and learning many routes.
In router R32 the rutes adverticed from R1 is inserted in VRF INTERNET:
ip vrf INTERNET
rd 65010:100
import ipv4 unicast map UNICAST
route-target export 65010:100
route-target export 65010:3
route-target import 65010:100
route-target import 65010:3
access-list 50 permit any
!
route-map UNICAST permit 11
match ip address 50
This command used to verify is the rutes ares in VRF INTERNET:
R32#sh ip route vrf INTERNET
Routing Table: INTERNET
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is 10.20.0.34 to network 0.0.0.0
B* 0.0.0.0/0 [20/0] via 10.20.0.34, 00:17:11
2.0.0.0/32 is subnetted, 1 subnets
B 2.2.2.2 [20/0] via 10.20.0.34, 00:17:10
3.0.0.0/32 is subnetted, 1 subnets
B 3.3.3.3 [20/0] via 10.20.0.34, 00:17:10
4.0.0.0/32 is subnetted, 1 subnets
B 4.4.4.4 [20/0] via 10.20.0.34, 00:17:10
5.0.0.0/32 is subnetted, 1 subnets
B 5.5.5.5 [20/0] via 10.20.0.34, 00:17:10
6.0.0.0/32 is subnetted, 1 subnets
B 6.6.6.6 [20/0] via 10.20.0.34, 00:17:11
7.0.0.0/32 is subnetted, 1 subnets
B 7.7.7.7 [20/0] via 10.20.0.34, 00:17:11
8.0.0.0/32 is subnetted, 1 subnets
B 8.8.8.8 [20/0] via 10.20.0.34, 00:17:11
9.0.0.0/32 is subnetted, 1 subnets
B 9.9.9.9 [20/0] via 10.20.0.34, 00:17:11
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
B 10.10.10.10/32 [20/0] via 10.20.0.34, 00:17:11
B 10.20.0.16/30 [200/0] via 23.23.23.23, 00:17:11
B 10.20.0.28/30 [200/0] via 20.20.20.20, 00:17:11
11.0.0.0/32 is subnetted, 1 subnets
B 11.11.11.11 [20/0] via 10.20.0.34, 00:17:11
12.0.0.0/32 is subnetted, 1 subnets
B 12.12.12.12 [20/0] via 10.20.0.34, 00:17:11
13.0.0.0/32 is subnetted, 1 subnets
B 13.13.13.13 [20/0] via 10.20.0.34, 00:17:11
14.0.0.0/32 is subnetted, 1 subnets
B 14.14.14.14 [20/0] via 10.20.0.34, 00:17:11
32.0.0.0/32 is subnetted, 1 subnets
C 32.32.32.23 is directly connected, Loopback32
192.168.1.0/32 is subnetted, 1 subnets
B 192.168.1.97 [200/11] via 20.20.20.20, 00:17:11
192.168.2.0/32 is subnetted, 1 subnets
B 192.168.2.97 [200/11] via 23.23.23.23, 00:17:12
192.168.5.0/30 is subnetted, 4 subnets
B 192.168.5.0 [20/0] via 10.20.0.34, 00:17:12
B 192.168.5.4 [20/0] via 10.20.0.34, 00:17:12
B 192.168.5.8 [20/0] via 10.20.0.34, 00:17:12
B 192.168.5.12 [20/0] via 10.20.0.34, 00:17:12
192.168.12.0/30 is subnetted, 9 subnets
B 192.168.12.0 [20/0] via 10.20.0.34, 00:17:12
B 192.168.12.4 [20/0] via 10.20.0.34, 00:17:12
B 192.168.12.8 [20/0] via 10.20.0.34, 00:17:12
B 192.168.12.12 [20/0] via 10.20.0.34, 00:17:12
B 192.168.12.16 [20/0] via 10.20.0.34, 00:17:12
B 192.168.12.20 [20/0] via 10.20.0.34, 00:17:12
B 192.168.12.24 [20/0] via 10.20.0.34, 00:17:12
B 192.168.12.28 [20/0] via 10.20.0.34, 00:17:12
B 192.168.12.32 [20/0] via 10.20.0.34, 00:17:12
192.168.20.0/30 is subnetted, 4 subnets
B 192.168.20.0 [20/0] via 10.20.0.34, 00:17:12
B 192.168.20.4 [20/0] via 10.20.0.34, 00:17:12
B 192.168.20.8 [20/0] via 10.20.0.34, 00:17:12
B 192.168.20.12 [20/0] via 10.20.0.34, 00:17:12
212.9.64.0/30 is subnetted, 1 subnets
B 212.9.64.0 [20/0] via 10.20.0.34, 00:17:12
212.9.65.0/30 is subnetted, 1 subnets
B 212.9.65.0 [20/0] via 10.20.0.34, 00:17:12
R32#
All rutes are inserted in VRF INTERNET
Now I would like to transport this VRF Internet to another PE in this case R20.
This is my config in R32:
R32#sh run | sec router
router eigrp 100
network 10.0.0.36 0.0.0.3
network 32.32.32.32 0.0.0.0
passive-interface default
no passive-interface Ethernet1/3
eigrp router-id 32.32.32.32
router bgp 65010
bgp log-neighbor-changes
neighbor 10.20.0.34 remote-as 65201
neighbor 19.19.19.19 remote-as 65010
neighbor 19.19.19.19 update-source Loopback0
neighbor 20.20.20.20 remote-as 65010
neighbor 20.20.20.20 update-source Loopback0
neighbor 21.21.21.21 remote-as 65010
neighbor 21.21.21.21 update-source Loopback0
neighbor 22.22.22.22 remote-as 65010
neighbor 22.22.22.22 update-source Loopback0
neighbor 23.23.23.23 remote-as 65010
neighbor 23.23.23.23 update-source Loopback0
!
address-family ipv4
neighbor 10.20.0.34 activate
neighbor 10.20.0.34 soft-reconfiguration inbound
neighbor 19.19.19.19 activate
neighbor 20.20.20.20 activate
neighbor 21.21.21.21 activate
neighbor 22.22.22.22 activate
neighbor 23.23.23.23 activate
exit-address-family
!
address-family vpnv4
neighbor 19.19.19.19 activate
neighbor 19.19.19.19 send-community extended
neighbor 20.20.20.20 activate
neighbor 20.20.20.20 send-community extended
neighbor 21.21.21.21 activate
neighbor 21.21.21.21 send-community extended
neighbor 22.22.22.22 activate
neighbor 22.22.22.22 send-community extended
neighbor 23.23.23.23 activate
neighbor 23.23.23.23 send-community extended
exit-address-family
!
address-family ipv4 vrf INTERNET
exit-address-family
R32#
R32#sh ip bgp sum
BGP router identifier 32.32.32.32, local AS number 65010
BGP table version is 100, main routing table version 100
33 network entries using 4752 bytes of memory
33 path entries using 2640 bytes of memory
5/5 BGP path/bestpath attribute entries using 680 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
8 BGP extended community entries using 360 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 8528 total bytes of memory
BGP activity 1306/1220 prefixes, 1420/1334 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.20.0.34 4 65201 23 18 100 0 0 00:13:41 33
19.19.19.19 4 65010 16 26 100 0 0 00:11:05 0
20.20.20.20 4 65010 23 26 100 0 0 00:12:47 0
21.21.21.21 4 65010 20 26 100 0 0 00:11:05 0
22.22.22.22 4 65010 18 25 100 0 0 00:11:05 0
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
23.23.23.23 4 65010 14 26 100 0 0 00:11:04 0
R32#
-------------------------------------------------
this is the config in R20:
R20#sh run | sec router
router eigrp 100
network 10.0.0.16 0.0.0.3
network 20.20.20.20 0.0.0.0
passive-interface default
no passive-interface Ethernet2/0
eigrp router-id 20.20.20.20
router ospf 30 vrf CLIENTE_C
router-id 10.20.0.29
redistribute bgp 65010 subnets
router bgp 65010
bgp log-neighbor-changes
neighbor 19.19.19.19 remote-as 65010
neighbor 19.19.19.19 update-source Loopback0
neighbor 21.21.21.21 remote-as 65010
neighbor 21.21.21.21 update-source Loopback0
neighbor 22.22.22.22 remote-as 65010
neighbor 22.22.22.22 update-source Loopback0
neighbor 23.23.23.23 remote-as 65010
neighbor 23.23.23.23 update-source Loopback0
neighbor 32.32.32.32 remote-as 65010
neighbor 32.32.32.32 update-source Loopback0
!
address-family vpnv4
neighbor 19.19.19.19 activate
neighbor 19.19.19.19 send-community extended
neighbor 21.21.21.21 activate
neighbor 21.21.21.21 send-community extended
neighbor 22.22.22.22 activate
neighbor 22.22.22.22 send-community extended
neighbor 23.23.23.23 activate
neighbor 23.23.23.23 send-community extended
neighbor 32.32.32.32 activate
neighbor 32.32.32.32 send-community extended
exit-address-family
!
address-family ipv4 vrf CLIENTE_C
redistribute ospf 30
exit-address-family
R20#sh ip bgp sum
BGP router identifier 20.20.20.20, local AS number 65010
BGP table version is 100, main routing table version 100
33 network entries using 4752 bytes of memory
33 path entries using 2640 bytes of memory
5/0 BGP path/bestpath attribute entries using 680 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
8 BGP extended community entries using 360 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 8528 total bytes of memory
BGP activity 479/426 prefixes, 677/624 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
19.19.19.19 4 65010 129 182 100 0 0 02:42:02 0
21.21.21.21 4 65010 148 183 100 0 0 02:42:02 0
22.22.22.22 4 65010 150 183 100 0 0 02:42:01 0
23.23.23.23 4 65010 125 183 100 0 0 02:42:01 0
32.32.32.32 4 65010 26 24 100 0 0 00:13:41 33
R20#sh ip vrf INTERNET
Name Default RD Interfaces
INTERNET 65010:100 Lo10
R20#sh ip route vrf INTERNET
Routing Table: INTERNET
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
B 10.20.0.16/30 [200/0] via 23.23.23.23, 02:41:09
B 10.20.0.28/30
is directly connected (CLIENTE_C), 02:41:09, Ethernet2/7
L 10.20.0.29/32 is directly connected, Ethernet2/7
20.0.0.0/32 is subnetted, 1 subnets
C 20.20.20.21 is directly connected, Loopback10
192.168.1.0/32 is subnetted, 1 subnets
B 192.168.1.97
[20/11] via 10.20.0.30 (CLIENTE_C), 02:41:09, Ethernet2/7
192.168.2.0/32 is subnetted, 1 subnets
B 192.168.2.97 [200/11] via 23.23.23.23, 02:41:09
R20#
I am not receiving the rutes and I don´t know why.
Some suggestions?
Thank you.
If need any other config I will post all information.
03-08-2016 04:17 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide