cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1767
Views
0
Helpful
3
Replies

L2VPN Pseudowire Redundancy arquitecture

cjurado77
Beginner
Beginner

Hi,

I'm trying to configure L2VPN Pseudowire Redundancy. I've found some documentation in the link below:

http://www.cisco.com/en/US/docs/ios/12_0s/feature/guide/fspseudo.html

But my scenario is quite different from the one explained at this document. I have the following scenario:

2011-08-02_135500.jpg

So I need to create a L2VPN between CE-A and CE-B. I need to establish the main xconnect between PE-A1 and PE-B1, and the backup between PE-A2 and PE-B2, and I would like the CE to be able to switch between one circuit or the other automatically.

How can I do it? Anybody can help me, please??

Regards,


Cristina

3 Replies 3

yashfaqu
Beginner
Beginner

Well as per SP Both circuits wll be up, and for CE you need to configure routing protocol to either load balance or failover.

What I need is a layer 2 vpn over the MPLS, so configuring layer 3 routing protocol is not suitable for me.

Maybe it is important to say that I am the SP, so I manage either PE and CE equipment.

Actually, I've read that QinQ can solve my problem, but I'm trying implementing QinQ in this way and it doesn't have the behaviour I expect:

CE-A:

interface GigabitEthernet1/19

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 300-301

switchport mode trunk

end

interface GigabitEthernet1/20

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 300-301

switchport mode trunk

end

PE-A1:

pseudowire-class TEST-L2VPN-REDUN1

encapsulation mpls

preferred-path interface Tunnel11 disable-fallback    (Tunnel11 is a tunnel to PE-B1)

interface GigabitEthernet2/15

description test l2vpn redundancy

switchport

switchport access vlan 500

switchport mode dot1q-tunnel

speed 1000

l2protocol-tunnel cdp

l2protocol-tunnel vtp

no cdp enable

spanning-tree bpdufilter enable

interface Vlan500

description l2vpn redundancy

no ip address

xconnect 1.1.1.1 101 pw-class TEST-L2VPN-REDUN1   (1.1.1.1 is PE-B1 RouterID)

PE-A2:

pseudowire-class TEST-L2VPN-REDUN2

encapsulation mpls

preferred-path interface Tunnel12 disable-fallback    (Tunnel12 is a tunnel to PE-B2)

interface GigabitEthernet2/15

description test l2vpn redundancy

switchport

switchport access vlan 500

switchport mode dot1q-tunnel

speed 1000

l2protocol-tunnel cdp

l2protocol-tunnel vtp

no cdp enable

spanning-tree bpdufilter enable

interface Vlan500

description l2vpn redundancy

no ip address

xconnect 2.2.2.2 102 pw-class TEST-L2VPN-REDUN1   (2.2.2.2 is PE-B2 RouterID)

CE-B:

interface GigabitEthernet1/1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 300-301

switchport mode trunk

end

interface GigabitEthernet1/2

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 300-301

switchport mode trunk

end

PE-B1:

pseudowire-class TEST-L2VPN-REDUN1

encapsulation mpls

preferred-path interface Tunnel13 disable-fallback    (Tunnel13 is a tunnel to PE-A1)

interface GigabitEthernet2/15

description prova l2vpn redundancy

switchport

switchport access vlan 500

switchport mode dot1q-tunnel

speed 1000

l2protocol-tunnel cdp

l2protocol-tunnel vtp

no cdp enable

spanning-tree bpdufilter enable

interface Vlan500

description l2vpn redundancy

no ip address

xconnect 3.3.3.3 101 pw-class TEST-L2VPN-REDUN1     (3.3.3.3 is PE-A1 routerID)

PE-A2:

pseudowire-class TEST-L2VPN-REDUN2

encapsulation mpls

preferred-path interface Tunnel14 disable-fallback    (Tunnel14 is a tunnel to PE-A2)

interface GigabitEthernet2/15

description prova l2vpn redundancy

switchport

switchport access vlan 500

switchport mode dot1q-tunnel

speed 1000

l2protocol-tunnel cdp

l2protocol-tunnel vtp

no cdp enable

spanning-tree bpdufilter enable

interface Vlan500

description l2vpn redundancy

no ip address

xconnect 4.4.4.4 102 pw-class TEST-L2VPN-REDUN2    (4.4.4.4 is PE-A2 routerID)

The result of applying this configuration is VC 101 established and with layer 2 connectivity ok, but VC 102 down and interface Gi2/15 of PE-A2 in err-disable state. The behaviour I expected is that STP protocol acts and put the the ports of the second layer 2 paths in blocking state.

Any idea??

Thanks.

Did you try to configure port-channel (From CE) with simple p2p xconnects(From SP) ? I am not sure but i remember i did some testings for Port-channel and it worked.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: