cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
458
Views
0
Helpful
1
Replies

L3VPN issue in XR

Anand Solgama
Level 1
Level 1

Hi,

 

my below config of L3vpn not working. Please help me.

 

XR:

RP/0/0/CPU0:ios#sh run

Fri Feb  6 23:53:18.968 UTC

Building configuration...

!! IOS XR Configuration 5.1.1

!! Last configuration change at Fri Feb  6 23:43:56 2015 by anand

!

vrf ABC

address-family ipv4 unicast

  import route-target

   100:1

  !

  export route-target

   100:1

  !

!

!

interface Loopback0

ipv4 address 2.2.2.2 255.255.255.255

!

interface MgmtEth0/0/CPU0/0

shutdown

!

interface GigabitEthernet0/0/0/0

vrf ABC

ipv4 address 192.168.1.2 255.255.255.0

!

interface GigabitEthernet0/0/0/1

ipv4 address 200.200.200.1 255.255.255.0

!

interface GigabitEthernet0/0/0/2

!

interface GigabitEthernet0/0/0/3

!

interface GigabitEthernet0/0/0/4

shutdown

!

rd-set 1:100

  1:100

end-set

!

route-policy PASS

  pass

end-policy

!

router bgp 1000

bgp router-id 2.2.2.2

address-family ipv4 unicast

  network 2.2.2.2/32

!

address-family vpnv4 unicast

!

neighbor 3.3.3.3

  remote-as 1000

  update-source Loopback0

  address-family ipv4 unicast

   route-policy PASS in

   route-policy PASS out

  !

!

vrf ABC

  rd 1:100

  address-family ipv4 unicast

   redistribute eigrp 10

  !

!

!

mpls ldp

router-id 2.2.2.2

interface GigabitEthernet0/0/0/1

!

!

router rip

interface Loopback0

!

interface GigabitEthernet0/0/0/1

!

!

router eigrp 10

vrf ABC

  address-family ipv4

   autonomous-system 10

   redistribute bgp 1000

   interface Loopback0

   !

   interface GigabitEthernet0/0/0/0

   !

  !

!

!

end

**********************************************************************************************************************************
3600:
 
R3#sh run
Building configuration...
 
Current configuration : 2135 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip vrf ABC
rd 1:100
route-target export 100:1
route-target import 100:1
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Ethernet1/0
ip vrf forwarding ABC
ip address 192.168.2.2 255.255.255.0
half-duplex
!
interface Ethernet1/1
ip address 200.200.200.2 255.255.255.0
half-duplex
mpls ip
!
interface Ethernet1/2
no ip address
shutdown
half-duplex
!
interface Ethernet1/3
no ip address
shutdown
half-duplex
!
!
router eigrp 20
auto-summary
!
address-family ipv4 vrf ABC
redistribute bgp 1000 metric 30000 1 255 255 1500
network 3.3.3.3 0.0.0.0
network 192.168.2.0
auto-summary
autonomous-system 20
exit-address-family
!
router rip
version 2
network 3.0.0.0
network 200.200.200.0
!
router bgp 1000
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 1000
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 route-map PASS in
neighbor 2.2.2.2 route-map PASS out
no auto-summary
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf ABC
redistribute eigrp 20 metric 1
no synchronization
exit-address-family
!
no ip http server
no ip http secure-server
!
!
!
!
ip prefix-list PASS seq 5 permit 0.0.0.0/0 le 32
no cdp log mismatch duplex
!
route-map PASS permit 10
match ip address prefix-list PASS
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
******************************************************************************************************************

 

RP/0/0/CPU0:ios#sh run
Fri Feb  6 23:53:18.968 UTC
Building configuration...
!! IOS XR Configuration 5.1.1
!! Last configuration change at Fri Feb  6 23:43:56 2015 by anand
!
vrf ABC
address-family ipv4 unicast
  import route-target
   100:1
  !
  export route-target
   100:1
  !
!
!
interface Loopback0
ipv4 address 2.2.2.2 255.255.255.255
!
interface MgmtEth0/0/CPU0/0
shutdown
!
interface GigabitEthernet0/0/0/0
vrf ABC
ipv4 address 192.168.1.2 255.255.255.0
!
interface GigabitEthernet0/0/0/1
ipv4 address 200.200.200.1 255.255.255.0
!
interface GigabitEthernet0/0/0/2
!
interface GigabitEthernet0/0/0/3
!
interface GigabitEthernet0/0/0/4
shutdown
!
rd-set 1:100
  1:100
end-set
!
route-policy PASS
  pass
end-policy
!
router bgp 1000
bgp router-id 2.2.2.2
address-family ipv4 unicast
  network 2.2.2.2/32
!
address-family vpnv4 unicast
!
neighbor 3.3.3.3
  remote-as 1000
  update-source Loopback0
  address-family ipv4 unicast
   route-policy PASS in
   route-policy PASS out
  !
!
vrf ABC
  rd 1:100
  address-family ipv4 unicast
   redistribute eigrp 10
  !
!
!
mpls ldp
router-id 2.2.2.2
interface GigabitEthernet0/0/0/1
!
!
router rip
interface Loopback0
!
interface GigabitEthernet0/0/0/1
!
!
router eigrp 10
vrf ABC
  address-family ipv4
   autonomous-system 10
   redistribute bgp 1000
   interface Loopback0
   !
   interface GigabitEthernet0/0/0/0
   !
  !
!
!
end
 

 

 

ROUTER ARE NOT PINGING EACH OTHER CUSTOMER 

Thanks in advance....

1 Accepted Solution

Accepted Solutions

pedersen
Level 1
Level 1

Your BGP session between the XR and the ME is only running IPv4 unicast, not M-BGPv4, you can see that in the Neighbor capabilities list doing a show BGP neighbor on ME, where you will see that:

Address family VPNv4 Unicast: advertised

But you have not recieved it, you're missing the following on the XR:

router bgp 1000

 neighbor 3.3.3.3 address-family vpnv4 unicast

commit

 

The clear the BGP session, and let them nengotiate the capabilities, and you should be good then.

BTW you only need a RPL attached for e-bgp neighbors, not for ibgp.

 

/Anders

View solution in original post

1 Reply 1

pedersen
Level 1
Level 1

Your BGP session between the XR and the ME is only running IPv4 unicast, not M-BGPv4, you can see that in the Neighbor capabilities list doing a show BGP neighbor on ME, where you will see that:

Address family VPNv4 Unicast: advertised

But you have not recieved it, you're missing the following on the XR:

router bgp 1000

 neighbor 3.3.3.3 address-family vpnv4 unicast

commit

 

The clear the BGP session, and let them nengotiate the capabilities, and you should be good then.

BTW you only need a RPL attached for e-bgp neighbors, not for ibgp.

 

/Anders

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: