cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
255
Views
5
Helpful
4
Replies

MPLS VPLS VC and PW Up but no end to end connectivity

Hi,

Capture.PNG

 

I am doing a MPLS VPLS lab on eve-ng. Both VC and PW seems to be up but end to end connectivity is not there. Also I am seeing some errors in debug. All details are below:

XRV Left:

interface Loopback0
ipv4 address 1.1.1.1 255.255.255.255
!
interface MgmtEth0/0/CPU0/0
shutdown
!
interface GigabitEthernet0/0/0/0
ipv4 address 10.0.0.1 255.255.255.252
!
interface GigabitEthernet0/0/0/1
speed 100
!
interface GigabitEthernet0/0/0/1.1414 l2transport
encapsulation dot1q 1414
mtu 1514
!
interface GigabitEthernet0/0/0/2
shutdown
!
router ospf 10
area 0
interface Loopback0
!
interface GigabitEthernet0/0/0/0
network point-to-point
!
!
!
l2vpn
pw-class VPLS_CLASS
encapsulation mpls
transport-mode ethernet
!
!
bridge group VPLS_GROUP
bridge-domain 1414
interface GigabitEthernet0/0/0/1.1414
!
vfi 1414
neighbor 2.2.2.2 pw-id 1414
pw-class VPLS_CLASS
!
!
!
!
!
mpls ldp
interface GigabitEthernet0/0/0/0
!
!
mpls static
!
end

XRV Right:

interface Loopback0
ipv4 address 2.2.2.2 255.255.255.255
!
interface MgmtEth0/0/CPU0/0
shutdown
!
interface GigabitEthernet0/0/0/0
ipv4 address 10.0.0.6 255.255.255.252
!
interface GigabitEthernet0/0/0/1
mtu 1514
speed 100
!
interface GigabitEthernet0/0/0/1.1414 l2transport
encapsulation dot1q 1414
mtu 1514
!
interface GigabitEthernet0/0/0/2
shutdown
!
router ospf 10
area 0
interface Loopback0
!
interface GigabitEthernet0/0/0/0
network point-to-point
!
!
!
l2vpn
pw-class VPLS_CLASS
encapsulation mpls
transport-mode ethernet
!
!
bridge group VPLS_GROUP
bridge-domain 1414
interface GigabitEthernet0/0/0/1.1414
!
vfi 1414
neighbor 1.1.1.1 pw-id 1414
pw-class VPLS_CLASS
!
!
!
!
!
mpls ldp
interface GigabitEthernet0/0/0/0
!
!
mpls static
!
end

Show l2vpn bridge-domain detail Output:

Number of groups: 1, bridge-domains: 1, Up: 1, Shutdown: 0, Partially-
programmed: 0
Default: 1, pbb-edge: 0, pbb-core: 0
Number of ACs: 1 Up: 1, Down: 0, Partially-programmed: 0
Number of PWs: 1 Up: 1, Down: 0, Standby: 0, Partially-programmed: 0
Number of P2MP PWs: 0, Up: 0, Down: 0, other-state: 0
Number of VNIs: 0, Up: 0, Down: 0, Unresolved: 0
RP/0/0/CPU0:ios#show l2vpn bridge-domain detail
Fri May 24 09:53:35.934 UTC
Legend: pp = Partially Programmed.
Bridge group: VPLS_GROUP, bridge-domain: 1414, id: 0, state: up, ShgId: 0, MSTi: 0
Coupled state: disabled
MAC learning: enabled
MAC withdraw: enabled
MAC withdraw for Access PW: enabled
MAC withdraw sent on: bridge port up
MAC withdraw relaying (access to access): disabled
Flooding:
Broadcast & Multicast: enabled
Unknown unicast: enabled
MAC aging time: 300 s, Type: inactivity
MAC limit: 4000, Action: none, Notification: syslog
MAC limit reached: no
MAC port down flush: enabled
MAC Secure: disabled, Logging: disabled
Split Horizon Group: none
Dynamic ARP Inspection: disabled, Logging: disabled
IP Source Guard: disabled, Logging: disabled
DHCPv4 snooping: disabled
IGMP Snooping: enabled
IGMP Snooping profile: none
MLD Snooping profile: none
Storm Control: disabled
Bridge MTU: 1500
MIB cvplsConfigIndex: 1
Filter MAC addresses:
P2MP PW: disabled
Create time: 24/05/2019 06:28:59 (03:24:36 ago)
No status change since creation
ACs: 1 (1 up), VFIs: 1, PWs: 1 (1 up), PBBs: 0 (0 up)
List of ACs:
AC: GigabitEthernet0/0/0/1.1414, state is up
Type VLAN; Num Ranges: 1
VLAN ranges: [1414, 1414]
MTU 1500; XC ID 0x1; interworking none
MAC learning: enabled
Flooding:
Broadcast & Multicast: enabled
Unknown unicast: enabled
MAC aging time: 300 s, Type: inactivity
MAC limit: 4000, Action: none, Notification: syslog
MAC limit reached: no
MAC port down flush: enabled
MAC Secure: disabled, Logging: disabled
Split Horizon Group: none
Dynamic ARP Inspection: disabled, Logging: disabled
IP Source Guard: disabled, Logging: disabled
DHCPv4 snooping: disabled
IGMP Snooping: enabled
IGMP Snooping profile: none
MLD Snooping profile: none
Storm Control: bridge-domain policer
Static MAC addresses:
Statistics:
packets: received 0, sent 0
bytes: received 0, sent 0
Storm control drop counters:
packets: broadcast 0, multicast 0, unknown unicast 0
bytes: broadcast 0, multicast 0, unknown unicast 0
Dynamic ARP inspection drop counters:
packets: 0, bytes: 0
IP source guard drop counters:
packets: 0, bytes: 0
List of Access PWs:
List of VFIs:
VFI 1414 (up)
PW: neighbor 2.2.2.2, PW ID 1414, state is up ( established )
PW class VPLS_CLASS, XC ID 0xff000001
Encapsulation MPLS, protocol LDP
Source address 1.1.1.1
PW type Ethernet, control word disabled, interworking none
Sequencing not set

PW Status TLV in use
MPLS Local Remote
------------ ------------------------------ -------------------------
Label 24000 24000
Group ID 0x0 0x0
Interface 1414 1414
MTU 1500 1500
Control word disabled disabled
PW type Ethernet Ethernet
VCCV CV type 0x2 0x2
(LSP ping verification) (LSP ping verification)
VCCV CC type 0x6 0x6
(router alert label) (router alert label)
(TTL expiry) (TTL expiry)
------------ ------------------------------ -------------------------
Incoming Status (PW Status TLV):
Status code: 0x0 (Up) in Notification message
MIB cpwVcIndex: 4278190081
Create time: 24/05/2019 06:28:59 (03:24:36 ago)
Last time status changed: 24/05/2019 06:38:30 (03:15:05 ago)
MAC withdraw messages: sent 0, received 0
Static MAC addresses:
Statistics:
packets: received 0, sent 0
bytes: received 0, sent 0
Storm control drop counters:
packets: broadcast 0, multicast 0, unknown unicast 0
bytes: broadcast 0, multicast 0, unknown unicast 0
DHCPv4 snooping: disabled
IGMP Snooping profile: none
MLD Snooping profile: none
VFI Statistics:
drops: illegal VLAN 0, illegal length 0

 

Debug Messages:

 

RP/0/0/CPU0:May 24 09:53:25.435 : parser[321]: tunl_gre_get_platform_capability: calling...
RP/0/0/CPU0:May 24 09:53:29.065 : parser[321]: tunl_gre_get_platform_capability: calling...
RP/0/0/CPU0:May 24 09:53:29.725 : parser[321]: tunl_gre_get_platform_capability: calling...
RP/0/0/CPU0:May 24 09:53:29.785 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_get_bridge_summary:10940, get_bridge_summary
RP/0/0/CPU0:May 24 09:53:29.785 : l2vpn_mgr[1175]: DBG-ALL: get_atom_segment_state:444, No redundancy role, state 1
RP/0/0/CPU0:May 24 09:53:29.785 : l2vpn_mgr[1175]: DBG-ALL: get_atom_segment_state:444, No redundancy role, state 1
RP/0/0/CPU0:May 24 09:53:32.214 : l2fib[278]: DBG-ALL: l2fib_notif_flush_retry:1328, Flushing the queue
RP/0/0/CPU0:May 24 09:53:32.214 : l2fib[278]: DBG-ALL: l2fib_program_xc:1606, XC(0x1): XC Flags 0x2c110, active XC flags 0x2c110, parent bound 1, child bound 1
RP/0/0/CPU0:May 24 09:53:32.214 : l2fib[278]: DBG-ALL: l2fib_program_xc:1635, XC(0x1): Sending create
RP/0/0/CPU0:May 24 09:53:32.214 : l2fib[278]: DBG-ALL: l2fib_program_ac:1146, XC(0x1) IF(Gi0/0/0/1.1414[0x102]): plat upd ac entered
RP/0/0/CPU0:May 24 09:53:32.214 : l2fib[278]: DBG-ALL: l2fib_access_field_ac:229, XID(0x1) : Accessor XCID = 1
RP/0/0/CPU0:May 24 09:53:32.214 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_platform_update_wrapper:611, platform update failed obj:3, action:0: Operation not permitted
RP/0/0/CPU0:May 24 09:53:32.214 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_program_ac:1233, CREATE: AC: XC(0x1) IF(GigabitEthernet0/0/0/1.1414[0x102]) failed: Operation not permitted
RP/0/0/CPU0:May 24 09:53:32.214 : l2fib[278]: DBG-ALL: l2fib_program_xc:1606, XC(0xff000001): XC Flags 0x2c110, active XC flags 0x2c110, parent bound 1, child bound 1
RP/0/0/CPU0:May 24 09:53:32.214 : l2fib[278]: DBG-ALL: l2fib_program_xc:1635, XC(0xff000001): Sending create
RP/0/0/CPU0:May 24 09:53:32.214 : l2fib[278]: DBG-ALL: l2fib_access_field_atom:714, XID(0xff000001) : xcon addr 0xa14ee8b4, seg1_plat_addr 0xa14eebfc
RP/0/0/CPU0:May 24 09:53:32.214 : l2fib[278]: DBG-ALL: l2fib_access_field_atom:688, xcon addr 0xa14ee8b4, seg1_plat_addr 0xa14eebfc
RP/0/0/CPU0:May 24 09:53:32.214 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_platform_update_wrapper:611, platform update failed obj:4, action:0: Operation not permitted
RP/0/0/CPU0:May 24 09:53:32.214 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_program_pw:1027, CREATE: XC(0xff000001) PW(2.2.2.2:1414) 1 1 failed: Operation not permitted
RP/0/0/CPU0:May 24 09:53:35.534 : parser[321]: tunl_gre_get_platform_capability: calling...
RP/0/0/CPU0:May 24 09:53:35.934 : parser[321]: tunl_gre_get_platform_capability: calling...
RP/0/0/CPU0:May 24 09:53:35.984 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd:11745, l2vpn_edm_datalist_bd 11745
RP/0/0/CPU0:May 24 09:53:35.984 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd:11774, BD datalist
RP/0/0/CPU0:May 24 09:53:35.984 : l2vpn_mgr[1175]: DBG-ALL: set_filter_bridge:11227, Filter flags are 0x0
RP/0/0/CPU0:May 24 09:53:35.984 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd:11822, Now working on BD 1414
RP/0/0/CPU0:May 24 09:53:35.984 : l2vpn_mgr[1175]: DBG-ALL: fill_bridge_bag:10199, fill_bridge_bag 10199
RP/0/0/CPU0:May 24 09:53:35.984 : l2vpn_mgr[1175]: DBG-ALL: fill_bridge_bag:10200, Adding to bag bridge name = 1414
RP/0/0/CPU0:May 24 09:53:35.984 : l2vpn_mgr[1175]: DBG-ALL: fill_bridge_bag:10237, Time BD created 24/05/2019 06:28:59
RP/0/0/CPU0:May 24 09:53:35.984 : l2vpn_mgr[1175]: DBG-ALL: fill_bridge_bag:10278, Time BD last status change
RP/0/0/CPU0:May 24 09:53:35.984 : l2vpn_mgr[1175]: DBG-ALL: get_atom_segment_state:444, No redundancy role, state 1
RP/0/0/CPU0:May 24 09:53:35.984 : l2vpn_mgr[1175]: DBG-ALL: get_atom_segment_state:444, No redundancy role, state 1
RP/0/0/CPU0:May 24 09:53:35.984 : l2vpn_mgr[1175]: DBG-ALL: get_atom_segment_state:444, No redundancy role, state 1
RP/0/0/CPU0:May 24 09:53:35.984 : l2vpn_mgr[1175]: DBG-ALL: get_atom_segment_state:444, No redundancy role, state 1
RP/0/0/CPU0:May 24 09:53:35.984 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd:11838, 1414: NumAcs=1, NumPws=1
RP/0/0/CPU0:May 24 09:53:36.024 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_ac:12473, l2vpn_edm_datalist_bd_ac 12473
RP/0/0/CPU0:May 24 09:53:36.024 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_ac:12494, bd ac public
RP/0/0/CPU0:May 24 09:53:36.024 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_ac:12510, receive request with l2vpn_ident_bd_ac_filter_bd
RP/0/0/CPU0:May 24 09:53:36.024 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_ac:12515, filtering on bridge name VPLS_GROUP:1414
RP/0/0/CPU0:May 24 09:53:36.024 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_ac:12520, bgen arg filter_bd_name is: 1414
RP/0/0/CPU0:May 24 09:53:36.024 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_ac:12582, processsing ac bridge port GigabitEthernet0_0_0_1.1414
RP/0/0/CPU0:May 24 09:53:36.024 : l2vpn_mgr[1175]: DBG-ALL: fill_ac_bag:2034, acmgr_lookup_context_by_ifname(GigabitEthernet0_0_0_1.1414) OK
RP/0/0/CPU0:May 24 09:53:36.024 : l2vpn_mgr[1175]: DBG-ALL: get_segment_state:1229, get_segment_state from 1
RP/0/0/CPU0:May 24 09:53:36.024 : l2vpn_mgr[1175]: DBG-ALL: fill_ac_bag:2043, AC signal_info.state=1, bag State=1
RP/0/0/CPU0:May 24 09:53:36.024 : l2vpn_mgr[1175]: DBG-ALL: fill_ac_bag:2136, AC nodeId=0x0,statsNodeId=0x0,xconId=0x1
RP/0/0/CPU0:May 24 09:53:36.024 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_ac:12645, 1 acs left
RP/0/0/CPU0:May 24 09:53:36.024 : l2vpn_mgr[1175]: DBG-ALL: add_bd_ac_datalist_stats:12399, Collecting AC Datalist Stats!
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL|FWD-ERR: l2fib_get_stats_bag_forwarding_array:981, latest/id/1/l2f_stats/l2f_fn0 failed: 'sysdb' detected the 'warning' condition 'A verifier or EDM callback function returned: 'not found''
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: l2fib_get_stats_bag_forwarding_array:1030, Got 0/1 stats
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_get_ac_stats_array:564, get 1 fwd stats = [No error]
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: add_bd_ac_datalist_stats:12447, got 1 stats OK
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_access_pw:13988, l2vpn_edm_datalist_bd_access_pw 13988
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_access_pw:14000, BD PW public
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_access_pw:14022, BGEN ARG filter_bd_name = 1414
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_pw:13461, l2vpn_edm_datalist_bd_pw 13461
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_pw:13473, BD PW public
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_pw:13486, info->subtree_name = bdpw-vfi-name/1414
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_pw:13528, BGEN ARG vfi_name = 1414
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_pw:13648, Now working on PW bridge port 2.2.2.2, 1414
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: get_atom_segment_state:444, No redundancy role, state 1
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: get_atom_segment_state:444, No redundancy role, state 1
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: fill_atom_bag_from_vc:798, Dynamic PW over MPLS (AToM)
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: get_atom_pw_state:522, vc->state = 5
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: fill_atom_bag_from_vc:801, PW local binding is set
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: fill_atom_bag_from_vc:823, PW remote binding is set
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: fill_atom_bag_from_vc:1097, Time PW created 24/05/2019 06:28:59
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: fill_atom_bag_from_vc:1153, Time PW last status change 24/05/2019 06:38:30
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: fill_pw_bag:3439, Fill the mpls preferred-path info
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_edm_datalist_bd_pw:13739, 1 pws left
RP/0/0/CPU0:May 24 09:53:36.034 : l2vpn_mgr[1175]: DBG-ALL|FWD-ERR: l2fib_get_stats_bag_forwarding_array:981, latest/id/ff000001/l2f_stats/l2f_fwd failed: 'sysdb' detected the 'warning' condition 'A verifier or EDM callback function returned: 'not found''
RP/0/0/CPU0:May 24 09:53:36.044 : l2vpn_mgr[1175]: DBG-ALL: l2fib_get_stats_bag_forwarding_array:1030, Got 0/1 stats
RP/0/0/CPU0:May 24 09:53:36.044 : l2vpn_mgr[1175]: DBG-ALL: l2vpn_get_pw_stats_array:405, get 1 fwd stats = [No error]
RP/0/0/CPU0:May 24 09:53:36.044 : l2vpn_mgr[1175]: DBG-ALL: add_bd_pw_datalist_stats:13427, got 1 stats OK
RP/0/0/CPU0:May 24 09:53:45.893 : l2fib[278]: DBG-ALL: l2fib_notif_flush_retry:1328, Flushing the queue
RP/0/0/CPU0:May 24 09:53:45.893 : l2fib[278]: DBG-ALL: l2fib_program_xc:1606, XC(0x1): XC Flags 0x2c110, active XC flags 0x2c110, parent bound 1, child bound 1
RP/0/0/CPU0:May 24 09:53:45.893 : l2fib[278]: DBG-ALL: l2fib_program_xc:1635, XC(0x1): Sending create
RP/0/0/CPU0:May 24 09:53:45.893 : l2fib[278]: DBG-ALL: l2fib_program_ac:1146, XC(0x1) IF(Gi0/0/0/1.1414[0x102]): plat upd ac entered
RP/0/0/CPU0:May 24 09:53:45.893 : l2fib[278]: DBG-ALL: l2fib_access_field_ac:229, XID(0x1) : Accessor XCID = 1
RP/0/0/CPU0:May 24 09:53:45.893 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_platform_update_wrapper:611, platform update failed obj:3, action:0: Operation not permitted
RP/0/0/CPU0:May 24 09:53:45.893 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_program_ac:1233, CREATE: AC: XC(0x1) IF(GigabitEthernet0/0/0/1.1414[0x102]) failed: Operation not permitted
RP/0/0/CPU0:May 24 09:53:45.893 : l2fib[278]: DBG-ALL: l2fib_program_xc:1606, XC(0xff000001): XC Flags 0x2c110, active XC flags 0x2c110, parent bound 1, child bound 1
RP/0/0/CPU0:May 24 09:53:45.893 : l2fib[278]: DBG-ALL: l2fib_program_xc:1635, XC(0xff000001): Sending create
RP/0/0/CPU0:May 24 09:53:45.893 : l2fib[278]: DBG-ALL: l2fib_access_field_atom:714, XID(0xff000001) : xcon addr 0xa14ee8b4, seg1_plat_addr 0xa14eebfc
RP/0/0/CPU0:May 24 09:53:45.893 : l2fib[278]: DBG-ALL: l2fib_access_field_atom:688, xcon addr 0xa14ee8b4, seg1_plat_addr 0xa14eebfc
RP/0/0/CPU0:May 24 09:53:45.893 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_platform_update_wrapper:611, platform update failed obj:4, action:0: Operation not permitted
RP/0/0/CPU0:May 24 09:53:45.893 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_program_pw:1027, CREATE: XC(0xff000001) PW(2.2.2.2:1414) 1 1 failed: Operation not permitted
RP/0/0/CPU0:May 24 09:53:59.653 : l2vpn_mgr[1175]: DBG-ALL: ctxmap_create:225, Enter
RP/0/0/CPU0:May 24 09:53:59.653 : l2vpn_mgr[1175]: DBG-ALL: ctxmap_create:274, Creating 1 SNMP Contexts and Mappings
RP/0/0/CPU0:May 24 09:53:59.653 : l2vpn_mgr[1175]: DBG-ALL: ctxmap_create:290, VPLS CTXMAP Debug Error RC='SNMP' detected the 'warning' condition 'try again': Resource temporarily unavaila at line 290
RP/0/0/CPU0:May 24 09:53:59.653 : l2vpn_mgr[1175]: DBG-ALL: ctxmap_create:302, VPLS CTXMAP Debug Error RC='SNMP' detected the 'warning' condition 'try again': Resource temporarily unavaila at line 302
RP/0/0/CPU0:May 24 09:53:59.653 : l2vpn_mgr[1175]: DBG-ALL: vpls_snmp_ctx_generic_fn:383, ctxmap_create() failed, 1087181835
RP/0/0/CPU0:May 24 09:53:59.653 : l2vpn_mgr[1175]: DBG-ALL: ctxmap_restart_timer:45, Restart timer; stopped = False. Expires in 60s
RP/0/0/CPU0:May 24 09:53:59.723 : l2fib[278]: DBG-ALL: l2fib_notif_flush_retry:1328, Flushing the queue
RP/0/0/CPU0:May 24 09:53:59.723 : l2fib[278]: DBG-ALL: l2fib_program_xc:1606, XC(0x1): XC Flags 0x2c110, active XC flags 0x2c110, parent bound 1, child bound 1
RP/0/0/CPU0:May 24 09:53:59.723 : l2fib[278]: DBG-ALL: l2fib_program_xc:1635, XC(0x1): Sending create
RP/0/0/CPU0:May 24 09:53:59.723 : l2fib[278]: DBG-ALL: l2fib_program_ac:1146, XC(0x1) IF(Gi0/0/0/1.1414[0x102]): plat upd ac entered
RP/0/0/CPU0:May 24 09:53:59.723 : l2fib[278]: DBG-ALL: l2fib_access_field_ac:229, XID(0x1) : Accessor XCID = 1
RP/0/0/CPU0:May 24 09:53:59.723 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_platform_update_wrapper:611, platform update failed obj:3, action:0: Operation not permitted
RP/0/0/CPU0:May 24 09:53:59.723 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_program_ac:1233, CREATE: AC: XC(0x1) IF(GigabitEthernet0/0/0/1.1414[0x102]) failed: Operation not permitted
RP/0/0/CPU0:May 24 09:53:59.723 : l2fib[278]: DBG-ALL: l2fib_program_xc:1606, XC(0xff000001): XC Flags 0x2c110, active XC flags 0x2c110, parent bound 1, child bound 1
RP/0/0/CPU0:May 24 09:53:59.723 : l2fib[278]: DBG-ALL: l2fib_program_xc:1635, XC(0xff000001): Sending create
RP/0/0/CPU0:May 24 09:53:59.723 : l2fib[278]: DBG-ALL: l2fib_access_field_atom:714, XID(0xff000001) : xcon addr 0xa14ee8b4, seg1_plat_addr 0xa14eebfc
RP/0/0/CPU0:May 24 09:53:59.723 : l2fib[278]: DBG-ALL: l2fib_access_field_atom:688, xcon addr 0xa14ee8b4, seg1_plat_addr 0xa14eebfc
RP/0/0/CPU0:May 24 09:53:59.723 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_platform_update_wrapper:611, platform update failed obj:4, action:0: Operation not permitted
RP/0/0/CPU0:May 24 09:53:59.723 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_program_pw:1027, CREATE: XC(0xff000001) PW(2.2.2.2:1414) 1 1 failed: Operation not permitted
RP/0/0/CPU0:May 24 09:54:06.232 : parser[321]: tunl_gre_get_platform_capability: calling...
RP/0/0/CPU0:May 24 09:54:14.142 : l2fib[278]: DBG-ALL: l2fib_notif_flush_retry:1328, Flushing the queue
RP/0/0/CPU0:May 24 09:54:14.142 : l2fib[278]: DBG-ALL: l2fib_program_xc:1606, XC(0x1): XC Flags 0x2c110, active XC flags 0x2c110, parent bound 1, child bound 1
RP/0/0/CPU0:May 24 09:54:14.142 : l2fib[278]: DBG-ALL: l2fib_program_xc:1635, XC(0x1): Sending create
RP/0/0/CPU0:May 24 09:54:14.142 : l2fib[278]: DBG-ALL: l2fib_program_ac:1146, XC(0x1) IF(Gi0/0/0/1.1414[0x102]): plat upd ac entered
RP/0/0/CPU0:May 24 09:54:14.142 : l2fib[278]: DBG-ALL: l2fib_access_field_ac:229, XID(0x1) : Accessor XCID = 1
RP/0/0/CPU0:May 24 09:54:14.142 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_platform_update_wrapper:611, platform update failed obj:3, action:0: Operation not permitted
RP/0/0/CPU0:May 24 09:54:14.142 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_program_ac:1233, CREATE: AC: XC(0x1) IF(GigabitEthernet0/0/0/1.1414[0x102]) failed: Operation not permitted
RP/0/0/CPU0:May 24 09:54:14.142 : l2fib[278]: DBG-ALL: l2fib_program_xc:1606, XC(0xff000001): XC Flags 0x2c110, active XC flags 0x2c110, parent bound 1, child bound 1
RP/0/0/CPU0:May 24 09:54:14.142 : l2fib[278]: DBG-ALL: l2fib_program_xc:1635, XC(0xff000001): Sending create
RP/0/0/CPU0:May 24 09:54:14.142 : l2fib[278]: DBG-ALL: l2fib_access_field_atom:714, XID(0xff000001) : xcon addr 0xa14ee8b4, seg1_plat_addr 0xa14eebfc
RP/0/0/CPU0:May 24 09:54:14.142 : l2fib[278]: DBG-ALL: l2fib_access_field_atom:688, xcon addr 0xa14ee8b4, seg1_plat_addr 0xa14eebfc
RP/0/0/CPU0:May 24 09:54:14.142 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_platform_update_wrapper:611, platform update failed obj:4, action:0: Operation not permitted
RP/0/0/CPU0:May 24 09:54:14.142 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_program_pw:1027, CREATE: XC(0xff000001) PW(2.2.2.2:1414) 1 1 failed: Operation not permitted
RP/0/0/CPU0:May 24 09:54:28.061 : l2fib[278]: DBG-ALL: l2fib_notif_flush_retry:1328, Flushing the queue
RP/0/0/CPU0:May 24 09:54:28.061 : l2fib[278]: DBG-ALL: l2fib_program_xc:1606, XC(0x1): XC Flags 0x2c110, active XC flags 0x2c110, parent bound 1, child bound 1
RP/0/0/CPU0:May 24 09:54:28.061 : l2fib[278]: DBG-ALL: l2fib_program_xc:1635, XC(0x1): Sending create
RP/0/0/CPU0:May 24 09:54:28.061 : l2fib[278]: DBG-ALL: l2fib_program_ac:1146, XC(0x1) IF(Gi0/0/0/1.1414[0x102]): plat upd ac entered
RP/0/0/CPU0:May 24 09:54:28.061 : l2fib[278]: DBG-ALL: l2fib_access_field_ac:229, XID(0x1) : Accessor XCID = 1
RP/0/0/CPU0:May 24 09:54:28.061 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_platform_update_wrapper:611, platform update failed obj:3, action:0: Operation not permitted
RP/0/0/CPU0:May 24 09:54:28.061 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_program_ac:1233, CREATE: AC: XC(0x1) IF(GigabitEthernet0/0/0/1.1414[0x102]) failed: Operation not permitted
RP/0/0/CPU0:May 24 09:54:28.061 : l2fib[278]: DBG-ALL: l2fib_program_xc:1606, XC(0xff000001): XC Flags 0x2c110, active XC flags 0x2c110, parent bound 1, child bound 1
RP/0/0/CPU0:May 24 09:54:28.061 : l2fib[278]: DBG-ALL: l2fib_program_xc:1635, XC(0xff000001): Sending create
RP/0/0/CPU0:May 24 09:54:28.061 : l2fib[278]: DBG-ALL: l2fib_access_field_atom:714, XID(0xff000001) : xcon addr 0xa14ee8b4, seg1_plat_addr 0xa14eebfc
RP/0/0/CPU0:May 24 09:54:28.061 : l2fib[278]: DBG-ALL: l2fib_access_field_atom:688, xcon addr 0xa14ee8b4, seg1_plat_addr 0xa14eebfc
RP/0/0/CPU0:May 24 09:54:28.061 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_platform_update_wrapper:611, platform update failed obj:4, action:0: Operation not permitted
RP/0/0/CPU0:May 24 09:54:28.061 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_program_pw:1027, CREATE: XC(0xff000001) PW(2.2.2.2:1414) 1 1 failed: Operation not permitted
RP/0/0/CPU0:May 24 09:54:42.090 : l2fib[278]: DBG-ALL: l2fib_notif_flush_retry:1328, Flushing the queue
RP/0/0/CPU0:May 24 09:54:42.090 : l2fib[278]: DBG-ALL: l2fib_program_xc:1606, XC(0x1): XC Flags 0x2c110, active XC flags 0x2c110, parent bound 1, child bound 1
RP/0/0/CPU0:May 24 09:54:42.090 : l2fib[278]: DBG-ALL: l2fib_program_xc:1635, XC(0x1): Sending create
RP/0/0/CPU0:May 24 09:54:42.090 : l2fib[278]: DBG-ALL: l2fib_program_ac:1146, XC(0x1) IF(Gi0/0/0/1.1414[0x102]): plat upd ac entered
RP/0/0/CPU0:May 24 09:54:42.090 : l2fib[278]: DBG-ALL: l2fib_access_field_ac:229, XID(0x1) : Accessor XCID = 1
RP/0/0/CPU0:May 24 09:54:42.090 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_platform_update_wrapper:611, platform update failed obj:3, action:0: Operation not permitted
RP/0/0/CPU0:May 24 09:54:42.090 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_program_ac:1233, CREATE: AC: XC(0x1) IF(GigabitEthernet0/0/0/1.1414[0x102]) failed: Operation not permitted
RP/0/0/CPU0:May 24 09:54:42.090 : l2fib[278]: DBG-ALL: l2fib_program_xc:1606, XC(0xff000001): XC Flags 0x2c110, active XC flags 0x2c110, parent bound 1, child bound 1
RP/0/0/CPU0:May 24 09:54:42.090 : l2fib[278]: DBG-ALL: l2fib_program_xc:1635, XC(0xff000001): Sending create
RP/0/0/CPU0:May 24 09:54:42.090 : l2fib[278]: DBG-ALL: l2fib_access_field_atom:714, XID(0xff000001) : xcon addr 0xa14ee8b4, seg1_plat_addr 0xa14eebfc
RP/0/0/CPU0:May 24 09:54:42.090 : l2fib[278]: DBG-ALL: l2fib_access_field_atom:688, xcon addr 0xa14ee8b4, seg1_plat_addr 0xa14eebfc
RP/0/0/CPU0:May 24 09:54:42.090 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_platform_update_wrapper:611, platform update failed obj:4, action:0: Operation not permitted
RP/0/0/CPU0:May 24 09:54:42.090 : l2fib[278]: DBG-ALL|FWD-ERR: l2fib_program_pw:1027, CREATE: XC(0xff000001) PW(2.2.2.2:1414) 1 1 failed: Operation not permitted

Everyone's tags (3)
4 REPLIES 4
Cisco Employee

Re: MPLS VPLS VC and PW Up but no end to end connectivity

Hi Muhammad,

 

This data plane functionality is not supported on XRv. Only the control plane works, hence you seeing the VC coming up.

 

Regards,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Re: MPLS VPLS VC and PW Up but no end to end connectivity

Hi Harold,

Should I assume that the data plane would not work? For this I need to have an IOS XR Router to get it working?

Cisco Employee

Re: MPLS VPLS VC and PW Up but no end to end connectivity

That is correct. VPLS is not supported on the XRv platform. The fact that control plane works is just a coincidence. You definitely need a HW based image to get VPLS working in XR.

 

Regards,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Highlighted

Re: MPLS VPLS VC and PW Up but no end to end connectivity

If you must do this on Virtual infrastucture... you should make it in CSR100V (IOS XE)  and VPLS is working fine.

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards