10-30-2010 06:33 PM
hi all
I built a small topology on MPLS VPNS over GRE
my topology consist of 2 CE routers 2 PE routers and 2 P routers it is a flat topology where in P-P is running GRE TUNNEL and MPLS is running in PE1-P1 and P2- PE2
the running configs are as below
for PE1
.......................
hostname SE1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ip vrf CUS
rd 100:1
route-target export 1:100
route-target import 1:100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip vrf forwarding CUS
ip address 192.168.4.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
auto-summary
!
address-family ipv4 vrf CUS
redistribute bgp 1 metric 20000 120 255 255 15000
network 192.168.4.0
no auto-summary
autonomous-system 100
exit-address-family
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf CUS
redistribute eigrp 100
no synchronization
exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
for p1
................
hostname P1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel0
ip address 10.1.1.1 255.255.255.0
ip ospf cost 10
ip ospf 1 area 0
mpls ip
tunnel source FastEthernet0/1
tunnel destination 192.168.2.2
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
for P2
.................
hostname P2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel0
ip address 10.1.1.2 255.255.255.0
ip ospf cost 10
ip ospf 1 area 0
mpls ip
tunnel source FastEthernet0/1
tunnel destination 192.168.2.1
!
interface FastEthernet0/0
ip address 192.168.3.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 192.168.2.2 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 192.168.3.0 0.0.0.255 area 0
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
for PE2
............
hostname SE2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
ip vrf CUS
rd 100:1
route-target export 1:100
route-target import 1:100
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
ip ospf network point-to-point
!
interface FastEthernet0/0
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip vrf forwarding CUS
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
auto-summary
!
address-family ipv4 vrf CUS
redistribute bgp 1 metric 20000 120 255 255 15000
network 192.168.5.0
no auto-summary
autonomous-system 100
exit-address-family
!
router ospf 1
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CUS
redistribute eigrp 100
no synchronization
exit-address-family
!
ip http server
no ip http secure-server
!
!
!
!
!
mpls ldp router-id Loopback0
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
for CE1
..............
hostname CE1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.4.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 100
network 3.0.0.0
network 192.168.4.0
no auto-summary
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
for CE2
..............
hostname CE2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.5.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 100
network 4.0.0.0
network 192.168.5.0
no auto-summary
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
CE1 is attached to PE1 and CE2 is attached with PE2
my problem is when i try to ping from CE1 to CE2 my pings are getting failed but in the routing table i can see the routes of each other
I think their is a problem in My P routers
can any one help me in understanding and correct solution for this topology
Solved! Go to Solution.
10-30-2010 08:39 PM
Hello Sai,
Weel I have tried the same and it is working with same topology..please see
CE2#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 188/264/348 ms
CE1#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 208/244/284 ms
Can you post output of below commands from different routers
PE1#sh mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or VC or Tunnel Id Switched interface
16 No Label 3.3.3.0/24[V] 2280 Gi1/0 192.168.4.2
17 No Label 192.168.4.0/24[V] 1140 aggregate/CUS
18 Pop Label 10.1.1.0/24 0 Gi2/0 192.168.1.2
19 18 192.168.3.0/24 0 Gi2/0 192.168.1.2
20 19 2.2.2.0/24 0 Gi2/0 192.168.1.2
P1#sh mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or VC or Tunnel Id Switched interface
16 Pop Label 1.1.1.0/24 6035 Gi1/0 192.168.1.1
18 Pop Label 192.168.3.0/24 0 Tu0 point2point
19 19 2.2.2.0/24 0 Tu0 point2point
P2#sh mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or VC or Tunnel Id Switched interface
16 16 1.1.1.0/24 0 Tu0 point2point
17 Pop Label 192.168.1.0/24 0 Tu0 point2point
19 Pop Label 2.2.2.0/24 6781 Gi2/0 192.168.3.1
PE2#sh mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or VC or Tunnel Id Switched interface
16 Pop Label 10.1.1.0/24 0 Gi1/0 192.168.3.2
17 16 1.1.1.0/24 0 Gi1/0 192.168.3.2
18 17 192.168.1.0/24 0 Gi1/0 192.168.3.2
19 No Label 192.168.5.0/24[V] 2280 aggregate/CUS
20 No Label 4.4.4.0/24[V] 1710 Gi2/0 192.168.5.2
Regards
Mahesh
10-30-2010 09:37 PM
Hi sai,
I am using c7200-adventerprisek9-mz.124-24.T4.bin IOS
Please find config attached. Also you can post output of the commands may be i can help you.
Regards
Mahesh
10-30-2010 08:39 PM
Hello Sai,
Weel I have tried the same and it is working with same topology..please see
CE2#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 188/264/348 ms
CE1#ping 4.4.4.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 208/244/284 ms
Can you post output of below commands from different routers
PE1#sh mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or VC or Tunnel Id Switched interface
16 No Label 3.3.3.0/24[V] 2280 Gi1/0 192.168.4.2
17 No Label 192.168.4.0/24[V] 1140 aggregate/CUS
18 Pop Label 10.1.1.0/24 0 Gi2/0 192.168.1.2
19 18 192.168.3.0/24 0 Gi2/0 192.168.1.2
20 19 2.2.2.0/24 0 Gi2/0 192.168.1.2
P1#sh mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or VC or Tunnel Id Switched interface
16 Pop Label 1.1.1.0/24 6035 Gi1/0 192.168.1.1
18 Pop Label 192.168.3.0/24 0 Tu0 point2point
19 19 2.2.2.0/24 0 Tu0 point2point
P2#sh mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or VC or Tunnel Id Switched interface
16 16 1.1.1.0/24 0 Tu0 point2point
17 Pop Label 192.168.1.0/24 0 Tu0 point2point
19 Pop Label 2.2.2.0/24 6781 Gi2/0 192.168.3.1
PE2#sh mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or VC or Tunnel Id Switched interface
16 Pop Label 10.1.1.0/24 0 Gi1/0 192.168.3.2
17 16 1.1.1.0/24 0 Gi1/0 192.168.3.2
18 17 192.168.1.0/24 0 Gi1/0 192.168.3.2
19 No Label 192.168.5.0/24[V] 2280 aggregate/CUS
20 No Label 4.4.4.0/24[V] 1710 Gi2/0 192.168.5.2
Regards
Mahesh
10-30-2010 09:18 PM
Thank You Mahesh for your time can you please tell me which ios version you have used for this because i was using 3660 router and my pings dint worked can you please post your running configs as well so that it will be much helpfull for me thank you in advance
cheers,
Sai
10-30-2010 09:37 PM
10-31-2010 01:35 PM
Thank you mahesh it worked for me will be back with another problem
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide