05-08-2012 01:18 AM
Hi all,
I am having some problem with my topo MPLS VPN over TE
This is my topo. I built a MPLS vpn between R5 and R4. This VPN is ok, R4 and R5 can ping each other. After that, i creat a TE tunnel to route traffic start in R1, which have destination in R3 go through R2 ( path: R1-R2-R3 ); TE tunnel up and operation nomally but R4 and R5 can't ping each other anymore.
And this is my configuration:
hostname R1 ip vrf os rd 1:1 route-target export 1:1 route-target import 1:1 bgp next-hop Loopback11 mpls traffic-eng tunnels interface Tunnel1 ip unnumbered Loopback1 mpls ip tunnel destination 33.33.33.33 tunnel mode mpls traffic-eng tunnel mpls traffic-eng autoroute announce tunnel mpls traffic-eng priority 1 1 tunnel mpls traffic-eng bandwidth 100 tunnel mpls traffic-eng path-option 1 explicit name LSP no routing dynamic ! interface Tunnel2 ip unnumbered Loopback2 tunnel destination 22.22.22.22 tunnel mode mpls traffic-eng tunnel mpls traffic-eng autoroute announce tunnel mpls traffic-eng priority 1 1 tunnel mpls traffic-eng bandwidth 100 tunnel mpls traffic-eng path-option 1 explicit name LSP1 no routing dynamic ! interface Loopback1 ip address 1.1.1.1 255.255.255.0 ip ospf network point-to-point ! interface Loopback2 ip address 12.12.12.12 255.255.255.0 ip ospf 1 area 0 ! interface Loopback11 ip address 11.11.11.11 255.255.255.0 ip ospf network point-to-point ! interface FastEthernet1/0 ip vrf forwarding os ip address 10.1.15.1 255.255.255.0 duplex auto speed auto ! interface FastEthernet1/1 ip address 10.1.12.1 255.255.255.0 ip ospf cost 10 duplex auto speed auto mpls ip mpls mtu 1512 mpls traffic-eng tunnels ip rsvp bandwidth 256 256 ! interface FastEthernet2/0 ip address 10.1.13.1 255.255.255.0 duplex auto speed auto mpls ip mpls mtu 1512 mpls traffic-eng tunnels ip rsvp bandwidth 256 256 ! router ospf 1 mpls traffic-eng router-id Loopback11 mpls traffic-eng area 0 router-id 1.1.1.1 log-adjacency-changes network 0.0.0.0 255.255.255.255 area 0 ! router bgp 1 no synchronization bgp log-neighbor-changes neighbor 3.3.3.3 remote-as 1 neighbor 3.3.3.3 update-source Loopback1 no auto-summary ! address-family vpnv4 neighbor 3.3.3.3 activate neighbor 3.3.3.3 send-community extended exit-address-family ! address-family ipv4 vrf os redistribute connected redistribute static no auto-summary no synchronization exit-address-family ! ip classless ip route 33.33.33.0 255.255.255.0 Tunnel1 ip route vrf os 5.5.5.0 255.255.255.0 10.1.15.5 ip explicit-path name LSP enable next-address 10.1.12.2 next-address 10.1.23.3 next-address 3.3.3.3 ! ip explicit-path name LSP1 enable next-address 10.1.12.2 next-address 2.2.2.2 ! | hostname R3 ip vrf os rd 1:1 route-target export 1:1 route-target import 1:1 bgp next-hop Loopback33 ! no ip domain lookup no ip ips deny-action ips-interface ! mpls traffic-eng tunnels interface Loopback3 ip address 3.3.3.3 255.255.255.0 ip ospf network point-to-point ! interface Loopback33 ip address 33.33.33.33 255.255.255.0 ip ospf network point-to-point ! interface FastEthernet0/0 no ip address shutdown duplex half ! interface FastEthernet1/0 ip address 10.1.13.3 255.255.255.0 duplex auto speed auto mpls ip mpls mtu 1512 mpls traffic-eng tunnels ip rsvp bandwidth 256 256 ! interface FastEthernet1/1 ip address 10.1.23.3 255.255.255.0 duplex auto speed auto mpls ip mpls mtu 1512 mpls traffic-eng tunnels ip rsvp bandwidth 256 256 ! interface FastEthernet2/0 ip vrf forwarding os ip address 10.1.34.3 255.255.255.0 duplex auto speed auto ! ! router ospf 1 mpls traffic-eng router-id Loopback33 mpls traffic-eng area 0 router-id 3.3.3.3 log-adjacency-changes network 0.0.0.0 255.255.255.255 area 0 ! router bgp 1 no synchronization bgp log-neighbor-changes neighbor 1.1.1.1 remote-as 1 neighbor 1.1.1.1 update-source Loopback3 no auto-summary ! address-family vpnv4 neighbor 1.1.1.1 activate neighbor 1.1.1.1 send-community extended exit-address-family ! address-family ipv4 vrf os redistribute connected redistribute static no auto-summary no synchronization exit-address-family ip route vrf os 4.4.4.0 255.255.255.0 10.1.34.4 |
hostname R2 mpls traffic-eng tunnels interface Loopback2 ip address 2.2.2.2 255.255.255.0 ip ospf network point-to-point ! interface Loopback22 ip address 22.22.22.22 255.255.255.0 ip ospf network point-to-point interface FastEthernet1/0 ip address 10.1.12.2 255.255.255.0 duplex auto speed auto mpls ip mpls mtu 1512 mpls traffic-eng tunnels ip rsvp bandwidth 256 256 ! interface FastEthernet1/1 ip address 10.1.23.2 255.255.255.0 duplex auto speed auto mpls ip mpls mtu 1512 mpls traffic-eng tunnels ip rsvp bandwidth 256 256 ! router ospf 1 mpls traffic-eng router-id Loopback22 mpls traffic-eng area 0 router-id 2.2.2.2 log-adjacency-changes network 0.0.0.0 255.255.255.255 area 0 | |
hostname R5 interface Loopback5 ip address 5.5.5.5 255.255.255.0 ip ospf network point-to-point ! ! interface FastEthernet1/0 ip address 10.1.15.5 255.255.255.0 duplex auto speed auto ! ip classless ip route 4.4.4.0 255.255.255.0 FastEthernet1/0 ip route 10.1.34.0 255.255.255.0 FastEthernet1/0 | hostname R4 interface Loopback4 ip address 4.4.4.4 255.255.255.0 ip ospf network point-to-point interface FastEthernet1/0 ip address 10.1.34.4 255.255.255.0 duplex auto speed auto ip route 5.5.5.0 255.255.255.0 FastEthernet1/0 ip route 10.1.15.0 255.255.255.0 FastEthernet1/0 |
please, tell me how to fix that !!!
05-08-2012 05:20 AM
Add the folllowing Configuration on Router-1 and Router-3 Respectively:
R1 Configuration:
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 3.3.3.3 remote-as 1
neighbor 3.3.3.3 update-source Loopback1
neigbor 33.33.33.33 remote-as 1
neighbor 33.33.33.33 update-source loopback11
no auto-summary
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
neigbor 33.33.33.33 activate
neigbor 33.33.33.33 send-community extended
exit-address-family
!
address-family ipv4 vrf os
redistribute connected
redistribute static
no auto-summary
no synchronization
exit-address-family
|
|
ip vrf os
rd 1:1
route-target export 1:1
route-target import 1:1
bgp next-hop 33.33.33.33
R3 Configuration:
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 update-source Loopback3
neighbor 11.11.11.11 remote-as 1
neighbor 11.11.11.11 update-source Loopback33
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
neigbor 11.11.11.11 activate
neighbor 11.11.11.11 send-community extended
exit-address-family
!
address-family ipv4 vrf os
redistribute connected
redistribute static
no auto-summary
no synchronization
exit-address-family
ip vrf os
rd 1:1
route-target export 1:1
route-target import 1:1
bgp next-hop 11.11.11.11
This Way, all your VPN Traffic Sourced from R5 Will transit the path of the TE tunnel to reach R4.
Regards,
Mohamed
05-10-2012 08:14 PM
Dear Mohamed,
It still not work
05-12-2012 02:08 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide