04-18-2016 01:58 PM
I have a router config at a client site where this is the relevant config
interface GigabitEthernet0/0.3005
encapsulation dot1Q 3005
ip address 10.250.0.34 255.255.255.252
!
interface GigabitEthernet0/0.3005998
encapsulation dot1Q 3005 second-dot1q 998
ip address 10.252.0.2 255.255.255.252
!
interface GigabitEthernet0/0.3005999
encapsulation dot1Q 3005 second-dot1q 999
ip vrf forwarding Public
ip address XX.XX.XX.142 255.255.255.252
When you are dealing with a 6509- where these circuits come into an NNI (Trunk with multiple VLANS)- and VLAN virtual interfaces- how do you do the config on that side?
Thanks
Greg
04-19-2016 01:23 AM
So you have already de-encapsulated it, so it will come in as an already tagged packet.
Did you want to terminate it as a layer 3 interface, or as a simpler layer 2 VLAN?
04-19-2016 07:16 AM
Bring in to an NNI- then doing virtual interfaces:
interface GigabitEthernet2/7
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1598-1600,3000,3002-3008,3010-3016,3018-3020
switchport mode trunk
interface Vlan3005
ip address 10.252.0.1 255.255.255.252
no ip redirects
no ip unreachables
04-19-2016 01:28 PM
Your config above looks perfect to me. What isn't working?
04-19-2016 03:23 PM
Coming back the other way- vlan 999 doesnt know to go back through vlan3005 to get to the other side (.141 cant see .142- but 10.250.0.33 can see 10.250.0.34 and vice versa):
interface GigabitEthernet3/1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 999,3005
switchport mode trunk
interface Vlan999
description guest wireless
ip address XX.XX.XX.141 255.255.255.252
!
interface Vlan3005
description Regular WAN
ip vrf forwarding Customer
ip address 10.250.0.33 255.255.255.252
!
04-19-2016 03:30 PM
I see. I think what you want on your site is a dot1q tunnel, to tunnel all VLANs at the customer site, rather than just VLAN 3005.
Check out "switchport mode dot1q-tunnel". I found this great example:
https://networklessons.com/switching/802-1q-tunneling-q-q-configuration-example/
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide