Showing results for 
Search instead for 
Did you mean: 

Cisco Prime flash RSL error


After intallation of cisco prime 2.0 i get to following error when i'm tryng to open some web pages in the server:

RSL Error 2 of 7, error # 2032


any ideas ?


Cisco Employee

Hi ,

Seems to be hitting the below BUG:

CSCuj39571    PI 2.0 - Monitor template deploy generates RSL #2032 error

CSCuj41410    PI 2.0 FCS shows RSL error #2032 in multiple pages

Conatct TAC for further assistance.



[Do rate the useful post]

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

When I view the configuration Archive with Mozilla Firefox and an incorrect Flashversion i also get this error.

However when i use Chrome with Flash i dont get the error but the archive is empty

When i login with SSH i can see the backuped configuration files in the localdisk/tftp folder.


The reason for the Configuration Archive being empty was probably because Prime uses SSH or Telnet to retrieve the information not SNMP or TFTP.

Telnet was disabled on the controllers after i configured Prime and the controllers to use SSH the jobs run succesfull.


I got exact the same problem.

Is there any roadmap for patch to solve this?

If there is INTERNET connection on PI server, will this problem disapear?




I have experience the same problem under different tools in PI. I did notice it first under “Deploy>Monitoring deployment>Interface Health template>deploy and I get the 2032 error.

I have learn that this occurs when you use a client with no internet connection and you try to start above deployment tools.

What happens is that when you try to open such page in PI web interface, the flash player starts and try to get some files on the PI but the URL it get from the PI application points to a library that do not contains the file (Bug in PI?). The files the flash player looks for is called something like framework_4.5.1.21328.swz and spark_4.5.1.21328.swz and so on. The url from PI looks like https://PI_Server/webacs/applications/SAMDeployTemplate/js/framework_4.5.1.21328.swz but the file is missing.

The flash player have a backup way to get the xxxxxx.swz files it needs. If it can’t find the files in the application, it try to get it from Adobe . But in my case my client can’t access internet so I get the error 2032.

I have another installation at another site that allows internet access everything works fine. The flash player can load the files it needs and store them locally on the client PC. Then I can take that PC back to the another site with no internet access where I did get the 2032 error and now It works fine because the flash player have the files it needs to handle the PI application.

I have a case open but it has not been solved yet.



Well, here's the solution based on the case i've opened:

1-Login to PI as root

2-Navigate to the following directory /opt/CSCOlumos/apache-tomcat 7.0.40/webapps/webacs/applications/common/flex/treetable

3-Copy the files inside attachment to the above directory.






4-Restart the PI services

ncs stop

ncs start

FTP Procedure

You need to put files on  FTP server and then from PI connect to that FTP server and  put files on PI.

For root account you need to enable root patch first then login with root account.

------To enable root patch here is the steps :

PI12-1/admin# root_enable

Password :

Password Again :

Root patch enabled

Then you can login as root :


PI12-1/admin# root

Starting root bash shell ...

ade #

cd  /opt/CSCOlumos/apache-tomcat-7.0.40/webapps/webacs/applications/common/flex/treetable

-Then you need to connect to ftp server and get files.

Example from my local lab :

ade # ftp

ftp> binary

ftp> cd NMS

ftp> get mx_4.5.0.21746.swz

And then you will found it directly under  /opt/CSCOlumos/apache-tomcat-7.0.40/webapps/webacs/applications/common/flex/treetable

To confirm file location  use command “locate mx_4.5.0.21746.swz”

I have tried the same solution but I did get a new error. Now I get RSL Error 2 of 7. Error # 2046.

And when I use a Developer Flash Player I get some explanation as “Error # 2046: The loaded file did not have a valid signature”. This is when I try to load the “Operate>Configuration Archives” Page.

Still get “RSL Error 1 of 7” on the “Deploy>Monitoring Deployment>Interface Monitoring Deployment” page. And this is only when I use a client PC that never had any Internet connection.

When I use my Laptop that I had used with other PI installation on sites with Internet access everything works fine. But my customer will never allow internet connection in there closed environment so from their local management station they can’t get it to work.


I have exactely the same pb.

Error: " RSN 2 of 7" when I go to Operate>Configuration Archive.

I have this pb with IE8 or Chrome

The PC has flashplayer

This PC can not acces PI and internet simulaneously.

So what can I do.

Michel Misonne

2046 is likely related to an incorrect FTP (Not using Binary mode).  Use "bin" keyword when FTP'ing otherwise it will default to ASCII mode and possibly the files were corrupted.

Log into your Prime server


Cd to /opt/CSCOlumos/apache-tomcat-7.0.40/webapps/webacs/applications/common/flex/treetable .

Issue the commands :

md5sum  framework_4.5.0.21746.swz

md5sum  mx_4.5.0.21746.swz

md5sum  spark_4.5.0.21746.swz

Compare the MD5's to below

[Path] / filename                              MD5 sum


mx_4.5.0.21746.swz                              20e9863c8997ba1f7231e326f348fb79

spark_4.5.0.21746.swz                         8a9c6a836f9dc0aaccfdccc33668f92d

framework_4.5.0.21746.swz              fa5da6e65212622e33a9a1a41fc1acea

If they don't match, that's the reason for your signature failure 2046.

To fix

Login to PI as root

Navigate to the following directory /opt/CSCOlumos/apache-tomcat7.0.40/webapps/webacs/applications/common/flex/treetable

Delete the current files.

Copy the files again using correct method above (Binary mode)

Restart the PI services

ncs stop

ncs start

Of course, you all could save yourself some trouble and give the PC access to the internet to download the correct Adobe files rather than using the Prime server to do system updates.