10-04-2020 12:31 PM
I have a router 2811, and PC connected to fa0/1. It cannot receive ip address from router. It should receive from pool 50 (vlan50).
Patg#sh run Building configuration... Current configuration : 1693 bytes ! version 12.4 no service timestamps log datetime msec no service timestamps debug datetime msec no service password-encryption ! hostname Patg ! ! ! enable secret 5 $1$mERr$/jJFQNiaJSPg5O/2VYM/n777 enable password asdfghj ! ! ! ip dhcp pool 10 network 192.168.50.0 255.255.255.192 ip dhcp pool 20 network 192.168.50.64 255.255.255.192 ip dhcp pool 30 network 192.168.50.128 255.255.255.192 ip dhcp pool 40 network 192.168.50.192 255.255.255.192 ip dhcp pool 50 network 192.150.50.0 255.255.255.192 ! ! ! no ip cef no ipv6 cef ! ! ! ! ! ! ! ! ! ! ip name-server 192.168.50.100 ! ! spanning-tree mode pvst ! ! ! ! ! ! interface FastEthernet0/0 no ip address duplex auto speed auto ! interface FastEthernet0/0.1 encapsulation dot1Q 10 native ip address 192.168.50.1 255.255.255.192 ! interface FastEthernet0/0.2 encapsulation dot1Q 20 ip address 192.168.50.65 255.255.255.192 ! interface FastEthernet0/0.3 encapsulation dot1Q 30 ip address 192.168.50.129 255.255.255.192 ! interface FastEthernet0/0.4 encapsulation dot1Q 40 ip address 192.168.50.193 255.255.255.192 ! interface FastEthernet0/1 no ip address duplex auto speed auto ! interface FastEthernet0/1.1 encapsulation dot1Q 50 ip address 192.150.50.99 255.255.255.192 ! interface Serial1/0 no ip address clock rate 2000000 shutdown ! interface Serial1/1 no ip address clock rate 2000000 shutdown ! interface Serial1/2 no ip address clock rate 2000000 shutdown ! interface Serial1/3 no ip address clock rate 2000000 shutdown ! interface Vlan1 no ip address shutdown ! ip classless ! ip flow-export version 9 ! ! ! ! ! ! ! ! line con 0 ! line aux 0 ! line vty 0 4 password asdfghj login ! ! ! end
10-04-2020 12:42 PM
Hi there,
you have created a sub-interface on fa0/1 and tagging the frames with the VLAN 50 ID. it is very likely that the PC connected to this interface will not be configured for tagged frames and will drop them.
The solution is to configure the interface without the VLAN tags:
! no interface FastEthernet0/1.1 ! interface FastEthernet0/1 ip address 192.150.50.99 255.255.255.192 !
However the more scalable solution would be to connect a Layer2 switch to Fa0/1 and configure a trunk port connected back to Fa0/1. Then create an access port on the switch for VLAN 50 and connect the PC to it.
cheers,
Seb.
10-04-2020 12:50 PM - edited 10-04-2020 12:52 PM
Actually this was done on port fa0/0. Fa0/0 has connected Cisco switch. But the dhcp OFFER only passes to trunk and not vlan10 on switch, where the PC is connected.
I mean there is another PC connected to switch, which has trunk to router f0/0 port.
10-04-2020 01:05 PM
you need to configure on router respected port as Trunk port
router example :
interface fa 0/0
switchport trunk encapsulation dot1q
switchport trunk allowed vlan all (if you want only 50 you can add only 50)
On the Switch side : ( VLAN 50 create)
interface fas 0/0 -- change here respected interface.
switchport trunk encapsulation dot1q
switchport trunk allowed vlan all (if you want only 50 you can add only 50)
Pc connected port
interface fas 0/2 -- change the real port
switchport mode access
switchport access vlan 50
no shutdown all ports and check all ports up and running.
test and advise.
10-04-2020 02:34 PM
Router interface has no ability to be switchport interface. It should have subinterfaces an be a router on a stick.
10-04-2020 04:05 PM
Hi Mate,
Seems like the Interface is not in the same IP subnet as the pool...
Take a look at that
Ciao
JC
10-23-2020 12:23 PM - edited 10-23-2020 12:40 PM
I changed and router cfg looks
router:
ip dhcp pool 50 network 192.150.50.0 255.255.255.192
Computer is on interface:
interface FastEthernet0/1.1 encapsulation dot1Q 50 ip address 192.150.50.32 255.255.255.192
But still not getting ip
10-25-2020 07:35 PM
Hello
From this original configuration, the switchport connecting to this rtr fa0/0 interface need to be a trunk and have it native vlan set to 10.
RTR
no interface FastEthernet0/1.1
default interface FastEthernet0/1
interface FastEthernet0/0.5
encapsulation dot1Q 50
ip address 192.150.50.99 255.255.255.192
ip dhcp pool 10
default-router 192.168.50.1
lease 0 8
ip dhcp pool 20
default-router 192.168.50.65
lease 0 8
ip dhcp pool 30
default-router 192.168.50.129
lease 0 8
ip dhcp pool 40
default-router 192.168.50.193
lease 0 8
ip dhcp pool 50
default-router 192.150.50.99
lease 0 8
Switch
no ip routing
int x/x
description facing rtr
switchport mode trunk
switchport trunk native vlan 10
exit
vlan10-50
exit
int x/x
description pc
switchport host
switchport access vlan 50
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide