02-15-2023 10:54 AM
I wanted to configure Frame Relay. I have 3 networks.
192.168.1.0 network and 192.168.3.0 network can communicate each other but 192.168.1.0 network and 192.168.5.0 network can not communicate each other.
They could communicate in my last try. I do not know what changed.
The configuration of Router0
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX152430AA-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0/0.100 point-to-point
ip address 10.11.1.1 255.255.0.0
frame-relay interface-dlci 100
clock rate 2000000
!
interface Serial0/0/0.101 point-to-point
ip address 10.10.1.1 255.255.0.0
frame-relay interface-dlci 101
clock rate 2000000
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.5.0 255.255.255.0 10.11.1.2
ip route 192.168.3.0 255.255.255.0 10.10.1.2
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
The configuration of Router1
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524K7OH-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.5.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 10.11.1.2 255.255.0.0
encapsulation frame-relay
frame-relay interface-dlci 102
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.1.0 255.255.255.0 10.11.1.1
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
The configuration of Router2
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15244E52-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.3.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 10.10.1.2 255.255.0.0
encapsulation frame-relay
frame-relay interface-dlci 103
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.1.0 255.255.255.0 10.10.1.1
!
ip flow-export version 9
!
!
!
no cdp run
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Solved! Go to Solution.
02-15-2023 03:28 PM
make sure the interface up, and post the below output :
show frame-relay pvc
show frame-relay route
show frame-relay map
02-16-2023 02:22 AM
On the router1 is the Gig0/0 interface up ?
From PC are you able to ping 192.168.5.2 ( from router 1 are you able to ping PC IP 192.168.5.1)
check any firewall in the PC ?
02-16-2023 02:38 AM
02-16-2023 02:46 AM
thats all right, can we mark this as resolved, if all is good.
02-15-2023 03:28 PM
make sure the interface up, and post the below output :
show frame-relay pvc
show frame-relay route
show frame-relay map
02-16-2023 02:03 AM - edited 02-16-2023 02:04 AM
I tried pinging from 10.11.1.2 to 10.11.1.1. They can ping each other.
Router0
Router#sh frame-relay pvc
PVC Statistics for interface Serial0/0/0 (Frame Relay DTE)
DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0/0.100
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
DLCI = 101, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0/0.101
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
Router#sh frame-relay map
Serial0/0/0.100 (up): point-to-point dlci, dlci 100, broadcast, status defined, active
Serial0/0/0.101 (up): point-to-point dlci, dlci 101, broadcast, status defined, active
Router1
Router#sh frame-relay pvc
PVC Statistics for interface Serial0/0/0 (Frame Relay DTE)
DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0/0
input pkts 14055 output pkts 32795 in bytes 1096228
out bytes 6216155 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 32795 out bcast bytes 6216155
Router#sh frame-relay map
Serial0/0/0 (up): ip 10.11.1.1 dlci 102, dynamic,
broadcast,
CISCO, status defined, active
02-16-2023 02:22 AM
On the router1 is the Gig0/0 interface up ?
From PC are you able to ping 192.168.5.2 ( from router 1 are you able to ping PC IP 192.168.5.1)
check any firewall in the PC ?
02-16-2023 02:38 AM
I forgot to give pc1 an ip address.
I apologize, i wasted your time.
02-16-2023 02:46 AM
thats all right, can we mark this as resolved, if all is good.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide