cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1656
Views
0
Helpful
10
Replies
PNI-ITRNP
Beginner

Multiple Switches same VLAN

Here is my scenario:

 

I have a main switch in a remote office, I added two 9200 (48 Port) switches stacked to a second suite at this remote site.

VLAN1 is the default on all switches, no other VLANs yet.

 

We have port 24 trunked on the main switch, and on the stacked switch we have port 1 trunked. 

 

For now, we only have 1 VLAN (the default).

 

On the main switch, we have VLAN1 Interface IP 1.2. On the stacked switch I added VLAN1 Interface 1.3.

 

I can ping the main switch (1.2) from the firewall (1.1) and my laptop (1.60). However, I cannot ping the stacked switch (1.3) from my laptop (1.60), but I can from the firewall (1.1).

 

Am I missing something?

 

Also from the stacked switch, I can ping multiple devices, such as the firewall and other PCs, but I cannot ping the main switch (1.2).

 

I'm not sure what else to look at, so just looking for some advice on what I may be doing wrong or just completely overlooked.

 

Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions
PNI-ITRNP
Beginner

Hi Everyone, I truly appreciate the input everyone provided.

 

At one point we did want to have multiple VLANs but after discussing it internally we have abandoned that idea for the site, and it will remain a single VLAN.

 

In that the port on the main switch (1.2) was not a TRUNK (as @okkudrna765 pointed out), I reconfigured the stack trunk port to simply be an access-port (taking @Richard Burts advice). The VLAN Interface IP remained as 1.3, but this did not correct the issue.

 

I also performed the cdp neighbor and arp command and everything checked out as it should. There was no reason why I should not be able to access the switch on the local network via the vlan interface.

 

With no other steps I could take, I restarted the stack at the close of business, and after the restart, everything started working normally on the stacked switch. I was then able to access the stack via the interface IP of 1.3, and because I had the default-gateway on the VLAN Interface set I was also able to access the switch via the site-to-site VPN.

 

Put simply a restart of the stack corrected the issue – go figure!

 

Again, I greatly appreciate the input provided as it helped troubleshoot the issue, and ultimately helped resolve the problem.

View solution in original post

10 REPLIES 10
balaji.bandi
VIP Expert

You PC got what Gateway 1.2 ? or 1.1 ? or 1.3 ?

 

If new switch is layer 2 only you need to add default-gateway to 1.2

 

or share both the device config or show ip route to understand

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

PC has a gateway of 1.1 (Firewall).

 

The main switch (1.2) has the IP default-gateway of 1.1 as well since we need to access the management of that switch from a remote VPN Network.

The switch stack also has the IP default-gateway of 1.1.

 

I'll attach configs. Basic configs as of right now, the only issue is the management for the stack.

 

Thanks.

Almost forgot the configs.

you haven't enable switchport mode trunk on gi 1/0/24 on switch 2

 

also make sure that you do not have duplex mismatch (show cdp neighbor detail)

That is correct, I just checked and the tech that told me he configured gi 1/0/24 as a trunk is not configured as a trunk. It just has a description. Good find!

 

Here is another question, for now, would it be better to configure the ports 'switchport mode access' on both gi 1/0/24 and gi 2/0/1 between the two switches since it is only 1 vlan?

You have been clear that the current environment is a single vlan (vlan 1). It is not clear what your plans might be for the future of the network. If the network will continue to be a single vlan then I would say that it would be better for all interfaces to be configured as access ports. If the future of the network might be multiple vlans then I would say that it is better for all interfaces that provide connectivity between switches to be configured as trunk.

 

Having said that I do not believe that the current situation where one switch is configured as access and the other switch is configured as trunk should cause any problem. But I would suggest that as a matter of Best Practice that both switches should be configured in a similar way.

 

I wonder if the output of the commands sh cdp neighbor and of show arp from both switches might shed some light on the issue?

 

I wonder if the problem with ping to 1.3 is related to the ccp policy you have configured on the stack?

HTH

Rick
okkudrna765
Beginner

 

 

At the moment at the local site, it's really a flat network.

On the same subnet, I cannot access 1.3 from 1.2 or my laptop of 1.60.

 

Why would I need ip route for the same subnet access?

You wouldn't I misread the questioning earlier, thought you were talking about static routing. 

 

PNI-ITRNP
Beginner

Hi Everyone, I truly appreciate the input everyone provided.

 

At one point we did want to have multiple VLANs but after discussing it internally we have abandoned that idea for the site, and it will remain a single VLAN.

 

In that the port on the main switch (1.2) was not a TRUNK (as @okkudrna765 pointed out), I reconfigured the stack trunk port to simply be an access-port (taking @Richard Burts advice). The VLAN Interface IP remained as 1.3, but this did not correct the issue.

 

I also performed the cdp neighbor and arp command and everything checked out as it should. There was no reason why I should not be able to access the switch on the local network via the vlan interface.

 

With no other steps I could take, I restarted the stack at the close of business, and after the restart, everything started working normally on the stacked switch. I was then able to access the stack via the interface IP of 1.3, and because I had the default-gateway on the VLAN Interface set I was also able to access the switch via the site-to-site VPN.

 

Put simply a restart of the stack corrected the issue – go figure!

 

Again, I greatly appreciate the input provided as it helped troubleshoot the issue, and ultimately helped resolve the problem.

View solution in original post