cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
239
Views
0
Helpful
10
Replies
Beginner

Port status on Cisc 9300 when Etherchannel

Hi all

Last week, I configured EtherChannel port between 2 Cisco 9300, network diagram:

 

       Cisco 9300 (Office)=====Leaseline ======= Cicso 9300 (DataCenter ISP)

 

In 9300 (Office):

Catalyst L3 Switch Software (CAT9K_IOSXE), Version 16.6.5

 

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
93 Po93(SU) LACP Gi1/0/1(P) Gi1/0/8(P)

 

CoreSW_TV#show interfaces g1/0/8 stat
GigabitEthernet1/0/8
Switching path Pkts In Chars In Pkts Out Chars Out
Processor 0 0 28075 3281940
Route cache 0 0 0 0
Distributed cache 0 0 0 0
Total 0 0 28075 3281940

 

CoreSW_TV#show interfaces g1/0/1 stat
GigabitEthernet1/0/1
Switching path Pkts In Chars In Pkts Out Chars Out
Processor 0 0 2393477 277463956
Route cache 0 0 0 0
Distributed cache 0 0 0 0
Total 0 0 2393477 277463956

 

But led status in port G1/0/8 is amber. It's not green. Please explain and help me to fix this issue.

 

Thanks,

Giang Le

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Advisor

Re: Port status on Cisc 9300 when Etherchannel

change this one as below and let us know, how it goes.

 

interface GigabitEthernet1/0/1
switchport access vlan 93
switchport mode access
channel-group 93 mode active
end

 

Office_SW#show run int g1/0/8
Building configuration...

Current configuration : 120 bytes
!
interface GigabitEthernet1/0/8
switchport access vlan 93
switchport mode access
channel-group 93 mode active
end

 

BB
*** Rate All Helpful Responses ***

View solution in original post

10 REPLIES 10
Highlighted
VIP Collaborator

Re: Port status on Cisc 9300 when Etherchannel

 

 - Issue the command show logging when the port get's connected ; check if there is more info.

   M.

Highlighted
Beginner

Re: Port status on Cisc 9300 when Etherchannel

Hi marce1000.

This is a log from log server in Cisco 9300 (office)

 

%ETC-5-L3DONTBNDL2: Gi1/0/8 suspended: LACP currently not enabled on the remote port.

 

 

Highlighted
VIP Advisor

Re: Port status on Cisc 9300 when Etherchannel

Can you post both the side configuration related to that port-channel?

 

%ETC-5-L3DONTBNDL2: Gi1/0/8 suspended: LACP currently not enabled on the remote port.

 

above errors show far end not configured.

 

BB
*** Rate All Helpful Responses ***
Highlighted
Beginner

Re: Port status on Cisc 9300 when Etherchannel

Hi,

This is my configure at far end:

 

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
93 Po93(SU) LACP Gi1/0/6(P) Gi2/0/6(P)

 

In far end, we use stack 9300 and use G1/0/6 for Stack-SW-01, G2/0/6 for Stack-SW-02. connection from Data Center to Office via ISP lease line.

 

Regards,

Giang Le

Highlighted
VIP Advisor

Re: Port status on Cisc 9300 when Etherchannel

That is not a configuration that is the output of EtherChannel output.

 

post below information : (given example, post both the side).

 

 

show run interface gi 1/0/1

show run interface gi 1/0/8

show run inter port-channel 93

 

 

show run interface gi 1/0/6

show run interface gi 2/0/6

show run inter port-channel 93

BB
*** Rate All Helpful Responses ***
Highlighted
Beginner

Re: Port status on Cisc 9300 when Etherchannel

Hi balaji.bandi.

I sent you my configre in both side:

----------------------------------------------

Data Center ISP:

CoreSW#show run int g1/0/6
Building configuration...

Current configuration : 158 bytes
!
interface GigabitEthernet1/0/6
switchport access vlan 93
switchport mode access
channel-group 93 mode active
end

 

CoreSW#show run int g2/0/6
Building configuration...

Current configuration : 158 bytes
!
interface GigabitEthernet2/0/6
switchport access vlan 93
switchport mode access
channel-group 93 mode active
end

 

CoreSW#show run int port-channel 93
Building configuration...

Current configuration : 83 bytes
!
interface Port-channel93
switchport access vlan 93
switchport mode access
end

----------------------------------------------

Office:

Office_SW#show run int g1/0/1
Building configuration...

Current configuration : 150 bytes
!
interface GigabitEthernet1/0/1
switchport access vlan 93
switchport mode access
channel-group 93 mode passive
end

 

Office_SW#show run int g1/0/8
Building configuration...

Current configuration : 120 bytes
!
interface GigabitEthernet1/0/8
switchport access vlan 93
switchport mode access
channel-group 93 mode passive
end

 

Office_SW#show run int port-channel 93
Building configuration...

Current configuration : 83 bytes
!
interface Port-channel93
switchport access vlan 93
switchport mode access
end

 

----------------------------------------------

Output result:

Office:

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
93 Po93(SU) LACP Gi1/0/1(P) Gi1/0/8(P)

 

DataCenter ISP:

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
14 Po14(SU) LACP Gi1/0/21(P) Gi2/0/21(P)
15 Po15(SU) LACP Gi1/0/22(P) Gi2/0/22(P)
93 Po93(SU) LACP Gi1/0/6(P) Gi2/0/6(P)

 

REgards

Giang 

Highlighted
VIP Advisor

Re: Port status on Cisc 9300 when Etherchannel

change this one as below and let us know, how it goes.

 

interface GigabitEthernet1/0/1
switchport access vlan 93
switchport mode access
channel-group 93 mode active
end

 

Office_SW#show run int g1/0/8
Building configuration...

Current configuration : 120 bytes
!
interface GigabitEthernet1/0/8
switchport access vlan 93
switchport mode access
channel-group 93 mode active
end

 

BB
*** Rate All Helpful Responses ***

View solution in original post

Highlighted
Beginner

Re: Port status on Cisc 9300 when Etherchannel

Hi balaji.bandi,
It worked with your configuration.
I have a question. At local office, I was running with Active/Passive configuration. But between office - Data Center ISP, this mode didn't work. I wonder what's difference on this except Active sent out LACP packet.

Regards,
Giang Le
Highlighted
VIP Advisor

Re: Port status on Cisc 9300 when Etherchannel

LACP always Active initiate the connection and Passive listens ( passive do not have capabilities to initiate)

 

If both set ACTIVE, anyone can initiate the connection. no need to wait for a partner to initiate the connection, your side shut and unshut should form the port-channel.

 

Maybe your Case Passive and Active should work. ( if you like to try After Passive side up and running, Active side shut and un shut to form the port-channel).

 

But i would prefer to have Active/Active, so you have both the side control.

 

make sense?

 

 

 

 

BB
*** Rate All Helpful Responses ***
Highlighted
Beginner

Re: Port status on Cisc 9300 when Etherchannel

OK, clearly. Thanks so much
Ticket can solve.
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards