cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1673
Views
0
Helpful
21
Replies
aringanisation
Beginner

Problem with connecting to ANIserver6.0

hi;

when I try to open the topology services I recieve the error Cannot connect to the ANIserver .... even when I am on the server itself .

I've found out it is due to my DNS problem, here is the scenario;

I installed the LMS on the server just before I joined it to the domain, after that I changed the name of the server and I joined it to the domain.

I was facing with the problem disabling to connect to ANIServer , so that I run the name change script on the server , even after that the problem

persists, as I click on CISCOWORKS shortcut on the desktop it is trying to open the wrong URL which is http://win-fktcprvq4r6:1741/ instead of the name which is the name of the server . attached is my pdshow and the snapshot of my desktop showing the wrong URL .

1 ACCEPTED SOLUTION

Accepted Solutions

this looks ok, assuming lms-forsat is still the hostname of your server.

Could you please again describe the steps you do to access the page that throws the error and illustrate it with screenshots so that we can get a clear picture of the failure.

View solution in original post

21 REPLIES 21
Michel Hegeraat
Rising star

It is indeed a pitty that many errors in LMS just produce a broad  list of possible issues, not related at all to the current situation.

It might as well just say 'fault'

Where in this case there is no issue whatsoever to say something like:

  • Can't resolve hostname:'win-fktcprvq4r6' to an IP addres.
  • Can't connect to ANIServer on 'win-fktcprvq4r6'  on TCP port '43242'.
  • etc...

Cheers,

Michel

Martin Ermel
Collaborator

the hostname in shortcut will not be changed from the changehostname.pl script, you have to do it manually.

You have to create your own shortcut.

Right-click on the Desktop > new > shortcut

    location: http://new-lmsServer:1741

    name: Cisco Prime (or CiscoWorks)

finish

right-click on the new shortcut, open Properties

open the tab: Webdocument

    change icon > Browse

        point to: NMSROOT\MDC\etc\ciscoWorks.ico

with NMSROOT beining your installation path of LMS (e.g. C:\Progra~1\CSCOpx)

Dear martin;

Even if I change that I dont think if my problem solved , cause my problem is; when I try to open topology services in Campus Manager, I got that error .

thank you .

sorry I didn't understood correctly;

on the LMS server, what does

    NMSROOT\bin\resolver.pl newLMSServer_Name

    NMSROOT\bin\resolver.pl LMSserver_IP

gives back?

I have changed the name of the server again and run the changehostname script, the problem sloved !!!

but when I run the two commands you have mentionedm,the results are nothing.

From another pc, can you connect to the aniserver where using the current name of the server?

If not goto java control panel, Advanced tab. Enable logging and show console.

Post the log from the console here.

On the server itself,  can you connect to the aniserver where using the current name of the server?

In IE create a bookmark, delete the ciscoworks icon from the desktop, drag the ciscoworks from your favourites to the desktop

Cheers,

Michel

As I just replyed to Martin the problem solved but I dont know why should I have to change the name again !!

but to answer you I have to say that the problem was either on client and the server itself

thank you all guys ;-)

Dear Michel;

Now I have new problem, I can start  the topology services from the server itself, but I just couldn't open from other servers or client , I can't stand recieving this kind of problem. I have attached the error

From that pc can you ping 'forsat'?

Can you enable java debug as I described earlier and post that log here?

Cheers

Michel

sure I can ping forsat,

I have attached the java log file ,

thank you .

Ali

For now it doesn't work because the servername is main-cs-1 not forsat

I think if you create a hosts file entry on your pc with the IP of forsat and the name  main-cs-1 the connection should be possible.

*********************************************

initializeSwing...

ClientModule.installAllModules...

performAniLogin...

Session id is alpha-numeric, Exception:For input string: "515A559F12E0E53BD43D386F47BFB88B"

_Orb=org.jacorb.orb.ORB@18a8ae7

org.omg.CORBA.TRANSIENT: Retries exceeded, couldn't reconnect to main-cs-1:42342

    at org.jacorb.orb.iiop.ClientIIOPConnection.connect(ClientIIOPConnection.java:232)

    at org.jacorb.orb.giop.GIOPConnection.sendMessage(GIOPConnection.java:934)

    at org.jacorb.orb.giop.GIOPConnection.sendRequest(GIOPConnection.java:900)

    at org.jacorb.orb.giop.ClientConnection.sendRequest(ClientConnection.java:323)

Cheers,

Michel

thank you,

As I mentioned earlier I have changed the name of the server and I ran the

changehostname script, on that . I wonder if there is a way to change that name too and not to relate the IP with the previous hostname.

thank you very much

I have to say that I don't understand that the server is looking for its old name after you run the changehostname script......

Could it be some processes remained running after you did a net stop crmdmgtd? Make sure all lms services are on manual startup except crmdmgtd, syslog, tftp and RCP service.

You may want to put the crmdmgtd to manual as well and reboot the server to make sure no files are looked when you run the changehostname script.

Cheers,

Michel

I dont have the service you've mentioned: "crmdmgtd" . in the services .

where can I find that ?