cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1548
Views
10
Helpful
11
Replies

switching and routing

ghassen6121996
Level 1
Level 1

Hi guys, I'm trying to connect 3 networks using 1 one router 1841.

Is the use of the 2 network, LAN port and for the third one WAN port 

The first network is  4 PC connected through switch which is connected to the router by interface vlan 9.

The second network is connected through another switch which is connected to the router by interface vlan 8.

My main objective is to ping the volume 9 and 8 to the third network.. 

but is not happening 

there is my router configuration  :

 

interface FastEthernet0/0

ip address 10.22.143.70 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet0/0/0

switchport access vlan 9

switchport mode access

switchport nonegotiate

!

interface FastEthernet0/0/1

switchport access vlan 8

switchport mode access

switchport nonegotiate

!

interface FastEthernet0/0/2

switchport mode access

switchport nonegotiate

!

interface FastEthernet0/0/3

switchport mode access

switchport nonegotiate

!

interface Vlan1

no ip address

shutdown

!

interface Vlan8

ip address 10.10.8.1 255.255.255.0

!

interface Vlan9

ip address 10.10.9.1 255.255.255.0

!

ip classless

ip route 10.22.143.0 255.255.255.0 FastEthernet0/0

!

ip flow-export version 9

!

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

 

 

 

 

 

switcher 1 with vlan 9 :

spanning-tree mode pvst

spanning-tree extend system-id

!

interface FastEthernet0/1

switchport access vlan 9

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 9

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 9

switchport mode access

!

interface FastEthernet0/4

switchport access vlan 9

switchport mode access

!

interface FastEthernet0/5

switchport access vlan 9

switchport mode access

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan9

mac-address 000a.f39d.d9c9

ip address 10.10.9.11 255.255.255.0

!

ip default-gateway 10.10.9.1

!

!

!

!

line con 0

!

line vty 0 4

login

line vty 5 15

 

 

 

switch 2 vlan 8

 

interface FastEthernet0/1

switchport access vlan 8

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 8

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 8

switchport mode access

!

interface FastEthernet0/4

switchport access vlan 8

switchport mode access

!

interface FastEthernet0/5

switchport access vlan 8

switchport mode access

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan8

mac-address 0005.5e69.e610

ip address 10.10.8.11 255.255.255.0

!

ip default-gateway 10.10.8.1

 

 

 

third newtrok that i like to ping

 

 

 

1 Accepted Solution

Accepted Solutions

Hello,

 

if you want to block traffic between Vlan 8 and Vlan 9, you need this:

 

access-list 101 deny ip 10.10.8.0 0.0.0.255 10.10.9.0 0.0.0.255
access-list 101 permit ip 10.10.8.0 0.0.0.255 any

!
interface Vlan8
ip access-group 101 in

 

With one router, indeed you do not need any routing (static or dynamic).

View solution in original post

11 Replies 11

balaji.bandi
Hall of Fame
Hall of Fame

Do you have network diagram how these connected also is this lab or real kit ?

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

this is a lab i will upload it now 

i want to ping the sw 10.22.143.0 255.255.255.0 from vlan 8 and vlan 9 

 

Hello,

 

if this is a Packet Tracer  project, post your zipped project (.pkt) file...

hi my brothers 

this is a lab 

and u can extract this file 

i dont know why but the vlan 8 ping vlan 9 

and it should ping the third network 10.22.143.0 255.255.255.0 

Hello, 

 

I can ping e.g. 10.22.143.43 from anywhere in Vlan 8 and 9. What source and destination IP addresses exactly can you not reach ? From where (source IP) to where (destination IP) can you not oing ?

Hi yeah

yeah i was wrong my because i thought that i changed the default gateway .

the problem with my project is if u remove the static route (ip route x.x.x.x ...) from the router u will still reach the 10.22.143.0 netwrok why ? 

try it by your self if u want how we can ping the third  newtork without routing 

the second problem that i can ping beetween VLAN 8 and 9 but in the normal case this is not right the 2 vlan should not communicate .

why the vlan 8 and 9 can communicate 

Hello,

 

you have three directly connected networks, they will communicate without any routing (static or dynamic). Why should both Vlans not be able to communicate ? There is nothing (e.g. access list) blocking the traffic...

Mr georg i know that i'm a beginner man with routing and switching so i will ask you some question..

if want to make the vlan 8 cannot ping vlan 9 ? what i should do ? use access list and deny??? 

and when i use the routing just when i have more than one router ? so here i don't need routing ? 

Hello,

 

if you want to block traffic between Vlan 8 and Vlan 9, you need this:

 

access-list 101 deny ip 10.10.8.0 0.0.0.255 10.10.9.0 0.0.0.255
access-list 101 permit ip 10.10.8.0 0.0.0.255 any

!
interface Vlan8
ip access-group 101 in

 

With one router, indeed you do not need any routing (static or dynamic).

Thaank u very much

Review Cisco Networking for a $25 gift card