cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6751
Views
35
Helpful
24
Replies

Topology Services Java issue

David Niemann
Participant
Participant

Just upgraded from LMS3.1 to LMS3.2.  Having issue with java when launching Topology Services.  I have completely removed java and let it reinstall using the version that it required but still get the attached error message everytime I try to launch the app.  Topology services worked fine previously with LMS3.1 and the java I had installed.

24 Replies 24

which browser are you using?

what is the exact error you get on the client when you try to start Topology services?

Try to set the LMS Server as a trusted site. Do you get a pop-up with jnlp file?

I have tried IE 7, and Firefox 3.0. I get the same message that this thread was started about

"jacorb-sing-1-3.jar, avalon-framework-4.1.5-sign-1-3.jar, logkit-1.2-sign-1-3.jar install successfully.  Please launch Campus Applications again to work properly.  Click OK to exit from the plugin."

from the client, try to telnet to these ports on the LMS server: 42342 and 43242.

This must be possible for topology services to run. If it is not, then some kind of firewall or access list is blocking the connection.

Also when you are logged in to LMS try to chang the URL to the following:

http://YOUR-LMS-SERVER:1741/JSP/CAMPUS/campus/campusws.jsp?app=Topology_Services&WSInstalled=true

if it does not auto-launch, you should at least be prompted to open "Topology_Services.jnlp" with "Java(TM) Web Start Launcher".

I have instaled java from LMS 3.2, but my ASDM 615 stoped working...

may be ther is a version of java, that suuported both whith LMS3.2 and ASDM???

Joe Clarke
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

Not sure what ASDM supports, but LMS 3.2 supports JPI 1.6.0_11 or higher (of 1.6, that is).  So you can install up to 1.6.0_20, and that will work with LMS.

Have there been any other fixes or workarounds for this issue?  I'm having the same exact problem on my client machine and have tried pretty much everything on this page.  We're using LMS 4.0.1.  We just installed it and I've been having loads of trouble with it.  I had trouble getting LMS to discover devices.  I got that figured out.  I'm still having trouble with the other modules seeing the devices but I'm still trying to figure that out on my own.  This is the main issue I have now and it started when my IT department gave me a new desktop with Win 7 on it.  I'm kinda figuring it's a client issue since it worked on my XP machine.  It's working on another machine that we have running Win 7 Ultimate but not on mine running Enterprise. 

Any help would be greatly appreciated.

Joe

I'm experiencing the same issue as Mr. Carlton, except I'm still on LMS 4.0.  Topology Services worked great with XP and IE7 or 8 , but not with Win7 and IE9.  I'm currently using an XP vm as a work around to this issue, but it would be much nicer to have it work on my primary OS.  Please let me know if there are any settings I need to change in IE9 or if I need to use a differnt browser like Firefox.

Thanks,

Ben

Joe Clarke
Hall of Fame Cisco Employee Hall of Fame Cisco Employee
Hall of Fame Cisco Employee

You need to use Firefox.  IE 9.0 is not supported in your version of LMS.

You need to make the endorsed directory Writable for  "Users" on that machine.

C:\Program Files\Java\jre6\lib\endorsed

The problem is that you are not administrator and the java weblaucher wants to write into that directory.

Cheers,

Michel

Mike,

I went in and changed the permissions on this folder to allow "Users" full control and now it works!

Joe,

I just realized that your 5th entry on this discussion would have worked for me too.

Thank you both for the help,

Ben

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: