cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
376
Views
5
Helpful
1
Replies
Highlighted

ncs issue using nso 4.6

Hi,

 

  I use ncs with nso 4.6 and my following code failed, any advise ? thx

 

with ncs.maapi.Maapi() as m:
     with ncs.maapi.Session(m, "admin", "CONTEXT_NAME"):
        with m.start_write_trans() as t:
            print root

Error: Bad protocol usage or unexpected retval (21): Library protocol version (67) is not compatible with ConfD protocol version (66)

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

You are using NSO 4.6, but the application you're building is compiled with NSO 4.7. Make sure your build toolchain is from the same NSO release as the running NSO server.

View solution in original post

1 REPLY 1
Highlighted
Cisco Employee

You are using NSO 4.6, but the application you're building is compiled with NSO 4.7. Make sure your build toolchain is from the same NSO release as the running NSO server.

View solution in original post