cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1685
Views
0
Helpful
10
Replies

CMS WebRTC Branding of Landing Page

Do any have experience with the Branding part of the CMS?

We are facing some problems to set a new background and logo on the WebRTC landing page.
According to documentation you must use a web server directory and point to the files in that directory from the GUI of the CMS.
However, no change of background and logo appears. Instead the "Cisco Mountain default background" is gone and white background displays along with  an error in the event log, that pushing background image failed.
You should be able to alter the landing page without branding license installed says documentation;


Any of you had some problems with that too?  Could this after all be a license issue?


CMS version 2.1.2

10 REPLIES 10

Do the background and logo images meet the size requirements and have the correct file names?

  • sign_in_background.jpg
    • maximum 1920x1200 pixels
    • less than 500kB
  • sign_in_logo.png
    • recommended 282x68 pixels
    • less than 250kB

Yes, we are sure the background and logo have the right sizes. 

We have tried to change the background for another CMS platform that does contain the branding license (but version 2.1.3). Changing the background via GUI works fine here. That is why I am wondering if the branding license does matter anyways...

How do you have the web bridge configured, using the web interface or API?

I just tested and the custom background did not appear until both the following fields were configured using the web interface:

  • Guest account client URI
  • Guest account JID domain

If you've configured these settings using the API, the custom background and logo will not appear.

We are using the web-interface for the web-bridge configuration.

The Guest account client URI and Guest account JID domain are properly configured via web-interface. Also folder that contains files is not zipped.
But we also tried API and that, as you say, does not work.

Are you specifying the entire URL to the image, for example:

http://server.com/sign_in_background.jpg

Do the images require you to login to access them, since the CMS doesn't support authentication?

Yes, we do specify the entire URL. If inserting the URL to a chrome browser we are able to load the picture into the browser. 

You said earlier you're running CMS 2.1.2, however you tested it on CMS 2.1.3 and it worked with the later version?

Can you upgrade CMS to 2.1.3 or the most recent release and try again?  Maybe there is an issue with CMS 2.1.2.

I tested using CMS 2.1.5 and it worked with just using the client URL, JID domain, and background URL.

Yes, I thought the same. I am searching for a version 2.1.2 in prod or lab.

I will see if I can get an approval for upgrade. But it may take some time before that will be approved by the customer.

It was possible for me to downgrade my own instance of CMS to version 2.1.2. And there are no problems changing the background landing image for webrtc on this version. However, I still have the branding license installed (cannot remove without compromising other functions).   

goranpilat
Participant

HI,

 

If I connect  as the first participant to video conference with webrtc (either from LAN or through expressway TURN), I only get "you are the only participant" message, no CIsco mountains.

 

Same goes for all my deployments and CMS versions.

 

If I connect to the same room with webex room kit, I get the mountains

 

Any ideas?

 

Best regards

 

Goran

Content for Community-Ad

Spotlight Awards 2021