09-02-2002 09:43 AM - edited 03-12-2019 08:35 PM
Anyone knows if QoS may work on PPP links or just works for Multilink PPP, if that it's the case, what it´s the best implementation of QoS for a PPP link
thanks in advance!!!
09-02-2002 03:05 PM
I have used LLQ on ISDN PPP links. Seems to work fine Heres a sample config-
class-map match-all voip
match access-group 150
class-map match-all cmcontrol
match access-group 151
!
!
policy-map voip-64k
class voip
priority 31
class cmcontrol
bandwidth percent 15
class class-default
fair-queue
!
isdn switch-type basic-ni
!
!
!
interface Ethernet0
ip address 192.168.151.1 255.255.255.0
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 41046569020101 4656902
isdn spid2 41046569040101 4656904
isdn incoming-voice modem
fair-queue 64 256 0
ppp authentication chap
!
interface Dialer1
bandwidth 64000
ip address 192.168.101.10 255.255.255.252
encapsulation ppp
dialer pool 1
dialer string 4107303639
dialer-group 1
service-policy output voip-64k
ppp authentication chap
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave
multilink max-links 1
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.101.9
ip route 192.168.100.0 255.255.255.0 192.168.101.9
!
!
map-class dialer BRI-VOIP
access-list 150 permit ip any any dscp ef
access-list 150 permit ip any any precedence critical
access-list 151 permit ip any any dscp af31
access-list 151 permit ip any any precedence flash
dialer-list 1 protocol ip permit
09-02-2002 04:18 PM
Thanks GREG
I´ll try the configuration, on my serial
I hope it works
11-13-2002 06:36 AM
Hi Mario,
we are an ISP and our POP are connected on FR using Nortel passport 7480.One of our clients wants Voice priortization solution on Isdn dialup.Will the configuration given by you work in this scenario. Is this configuration needed on client router only or Do i need to do anything on POP end router also.waiting for your reply.
Thanks in advance.
kanwal
11-13-2002 01:43 PM
Mario,
Here is an example for a frac-T1. You just need to assign the single interface to a multilink group. You have to use multilink for the fragmentation to work properly.
class-map match-all control
description voice control
match ip precedence 3
!
class-map match-all voice
description RTP voice
match ip precedence 5
!
policy-map QueueOut
class voice
priority 448
class control
bandwidth 32
class hidata
bandwidth 32
class lodata
bandwidth 24
class class-default
fair-queue
interface Multilink1
bandwidth 768
ip address 10.235.254.1 255.255.255.252
ip directed-broadcast
ip tcp header-compression iphc-format
service-policy output QueueOut
no cdp enable
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave
multilink-group 1
ip rtp header-compression iphc-format
!
interface Serial0/0
bandwidth 768
no ip address
ip directed-broadcast
ip nbar protocol-discovery
encapsulation ppp
no ip mroute-cache
fair-queue
service-module t1 timeslots 1-12
ppp multilink
multilink-group 1
!
11-14-2002 03:26 AM
Hi,
The setup is like this
Client H.O--------- POP1------------POP2--------Client B.O
POP1 and POP2 are running FR and are point of presence of an ISP setup.
Client will dial thru ISDN from his Head office as well as Branch office and get connected to ISP. My question is "Is ISDN configuration for voice priortization needed on client end routers only?". Is there anything that needs to be done on ISP end routers. Pls advise.
Regards
kanwal
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide