cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
261
Views
0
Helpful
1
Replies

Qos support for Softphone that connect to Catalyst 3550

LIMTT
Level 1
Level 1

Hi, I had a PC Softphone that connect directly to Catalyst 3550 EMI switch version 12.1(20)EA2. I would like configure qos, Knowing that IP Precedence 5 was default marking by Softphone appication, Can I configure the Cat 3550 to support this ?

Can achieve end to edn Qos support ?

My end to end IP Tel Network :-

Softphone -> Cat 3550 -> Cat6506/Cat 3750 -> Call Manager.

Thanks

1 Reply 1

Aaron Harrison
VIP Alumni
VIP Alumni

You can just trust the IP precedence markings from the PC but a better solution is to remark packets as they enter the switch... this guarantees you get the right settings, and also blocks the possibility of other traffic marked with precedence getting into your priority queues in the network.... steps are basically:

Create some ACLs to mark Voice bearer and control traffic:

ip access-list extended VOICE

permit udp any any eq 1

permit udp any any range 16384 32767

ip access-list extended VOICE_CONTROL

remark Match voice control traffic

permit tcp any any range 2000 2002

permit tcp any range 2000 2002 any

permit udp any any eq 2427

permit udp any eq 2427 any

permit tcp any any eq 1720

permit tcp any eq 1720 any

permit tcp any any range 11000 11999

permit tcp any range 11000 11999 any

Configure some class-maps and policy maps

class-map match-all VOICE_CONTROL

match access-group name VOICE_CONTROL

class-map match-all VOICE

match access-group name VOICE

policy-map CLASSIFY_VOICE

class VOICE

set ip dscp 46

class VOICE_CONTROL

set ip dscp 26

Then apply this to the interfaces that Softphone is sat on:

int fa 0/33

service-policy input CLASSIFY_VOICE

This policy covers H323, SCCP, MGCP and all UDP ports used by CM systems, so you can use this on any gateway/phone... The normal IP phone ports can be configured simpler of course.

Aaron

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!