Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

Vista compatible softPhone

i need to know there is vista compatible soft phone

Rob Huffman
Hall of Fame Community Legend

To add to Rob's notes, CIPC 2.1 would be available before the end of this month (Hopefully the next couple of weeks)

Is anyone running 2.1 on Vista yet? I tried on 2 different Vista laptops. The same softphone device works on non-Vista builds fine. The Vista clients will register and the phone functions work, but they cannot access web services such as directories and IP Phone Services URL.


Have the exact same problem. The phone works fine but unable to get any http based services (directories, extension mobility, etc.).

Am running Vista Business x64?

Anyone found a solution to this?

You should open a TAC incident. I've been working with them on one since Friday. I have verified that the configs are getting to the phone correctly. Ethereal shows that the app is not even attempting an HTTP request, so something in the app or OS is blocking it. I found some errors relating to HTTPService.dll which sounds like it would be a major player.

I also disable Windows FW with the same result.

They were trying to find a Vista machine to test on this afternoon, haven't heard back yet.

Did anyone every get a resolution on this? I'm running into the exact same problem.

I gave up since TAC couldn't reproduce the problem. It sounded like they had to build a Vista machine since they didn't have any for testing. I tried two clean builds as VMs and Communicator worked fine. I haven't been able to identify what breaks it or when. For physical builds I've only tried 2 different IBM T60 laptops, both are having the problem.

I think I figured out the problem. I turned off IIS which was running on my Vista laptop, then restarted IP Communicator and all my services and other http functions now work. IPC must have a problem with port 80 being open on the local machine.

Great find. I verified that Communicator does initiate a listener on port 80 on startup. As long as you don't have a conflict everything is happy.

Content for Community-Ad

Spotlight Awards 2021