10-08-2021 04:40 PM
I am using a Cisco 1921 with Gig0/0 and Gig0/1 interfaces on it. I'm trying to do something really simple, however it isn't working at all and I feel I must be overlooking something very basic.
ip cef
no ip source-route
ip classless
!
interface GigabitEthernet0/0
desc private internet
ip address 192.168.116.1 255.255.255.0
ip nat inside
no ip virtual-reassembly
speed 1000
duplex full
no mop enabled
!
interface GigabitEthernet0/1
desc public internet
ip address x.x.x.244 255.255.255.240
ip nat outside
no ip virtual-reassembly
speed 1000
duplex full
!
ip nat inside source list 2 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 x.x.x.241
!
access-list 2 permit 192.168.0.0 0.0.255.255
Packets in 192.168.116.0/24 get to Gig0/0 but don't get translated to go out onto the internet, so a ping to an address on the open internet fails but I can ping the .241 gateway. I turned on debug ip nat but it isn't showing anything useful. Any ideas on what I am overlooking?
Thanks,
CJ
Solved! Go to Solution.
10-08-2021 04:59 PM
try this
config t
!
no ip nat inside source list 2 interface GigabitEthernet0/0 overload
ip nat inside source list 2 interface GigabitEthernet0/1 overload
!
end
10-08-2021 04:41 PM
To clarify, I should have said:
"Packets in 192.168.116.0/24 get to Gig0/0 but don't get translated to go out onto the internet, so a ping to an address on the open internet fails. From the router, I can ping the .241 gateway."
CJ
10-08-2021 04:59 PM
try this
config t
!
no ip nat inside source list 2 interface GigabitEthernet0/0 overload
ip nat inside source list 2 interface GigabitEthernet0/1 overload
!
end
10-08-2021 05:49 PM
Hi, maybe you could change the command "ip nat inside source list 2 interface GigabitEthernet0/0 overload" to use GigabitEthernet0/1 (the one pointing to the outside network) instead.
10-08-2021 05:54 PM
Thanks, I could swear I tried that! I can't believe I made sych a simple mistake. Thanks for the assistance.
CJ
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide