cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
739
Views
0
Helpful
10
Replies

Probably the most basic setup ever. (Beginner)

a_jam_sandwich
Level 1
Level 1

Having trouble setting up, probably the most basic setup ever. (Beginner)

We have a lease line and two 2600 routers each fitted with a WIC-1T. I’m trying to setup our routers for network traffic can go between each network, the setup is as below

Network A 10.0.0.0 255.255.0.0 => Router: rugeley

Network B 11.0.0.0 255.255.0.0 => Router: scotland

f0/0 10.0.0.150 s0/0 192.168.1.2 <-----> s0/0 192.168.1.3 f0/0 11.0.0.150

The config is as below (I can ping each of the f0/0 interfaces from either router but can’t see the network behind them)

hostname rugeley

!

enable secret xxxxx.

!

ip subnet-zero

!

!

interface FastEthernet0/0

ip address 10.0.0.150 255.0.0.0

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.1.2 255.255.0.0

encapsulation ppp

!

router rip

network 10.0.0.0

network 11.0.0.0

network 192.168.1.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.3

ip route 11.0.0.0 255.255.0.0 192.168.1.3

ip http server

ip pim bidir-enable

!

!

access-list 101 permit ip any any

!

line con 0

password cisco

login

line aux 0

password cisco

login

line vty 0 4

password cisco

login

!

!

end

hostname scotland

!

enable secret xxxx.

!

ip subnet-zero

!

!

interface FastEthernet0/0

ip address 11.0.0.150 255.0.0.0

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.1.3 255.255.0.0

encapsulation ppp

!

router rip

network 10.0.0.0

network 11.0.0.0

network 192.168.1.0

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.3

ip route 10.0.0.0 255.255.0.0 192.168.1.2

ip http server

ip pim bidir-enable

!

!

access-list 101 permit ip any any

!

line con 0

password cisco

login

line aux 0

password cisco

login

line vty 0 4

password cisco

login

!

!

End

Thanks in advance for you help

(Btw) this is my first attempt ever at setting up a Cisco router so I’m probably well off

Andy

10 Replies 10

e.systems
Level 1
Level 1

You are using RIP which is a classful protocol. The easiest solution is to convert it to RIP v2 by

ROuter Rugely: router rip

ROuter Rugely: rip version 2

Do this for both routers. You should then be able to see out.

Also, from Rugely, you need to remove the Network 11.x.x.x. statement, because you are not advertising that network as originating in Rugely.

And similar from Scotland, remove the network 10.x.x.x statement from your RIP config.

You do not need the route statements either because this is the job of the routing protocol. So you can remove all the statements of the form IP route x.x.x.x

Also, disable ip http server. This is a known vulnerability in Cisco IOS.

You may also want to secure your telnet/console login with secure passwords. And when posting, remove the passwords from the text file before you post, even if they are encrypted.

You can also remove the access-list xxxxxx stateements. They aren't performing anything here.

Hope that helps.

Thanks for your reply I have now setup the routers as you have explained above the problem now is that the rugeley router is receiving the scotlands network

C 10.0.0.0/8 is directly connected, FastEthernet0/0

R 11.0.0.0/8 [120/1] via 192.168.1.3, 00:00:04, Serial0/0

192.168.1.0/32 is subnetted, 1 subnets

C 192.168.1.3 is directly connected, Serial0/0

C 192.168.0.0/16 is directly connected, Serial0/0

But the rugeley is not broadcasting its network to the scotland router I am completely lost as the setup are the same any ideas ?

Many Thanks

Andy

Can you post the two configs.

Thanks again for replying my configs are as follows

<=== Rugeley ===>

rugeley#sh run

Building configuration...

Current configuration : 604 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname rugeley

!

enable secret xxxxx

!

ip subnet-zero

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.0.0.250 255.0.0.0

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.1.2 255.255.0.0

encapsulation ppp

!

router rip

version 2

network 10.0.0.0

network 192.168.1.0

!

ip classless

no ip http server

no ip pim bidir-enable

!

!

!

line con 0

password cisco

login

line aux 0

password cisco

login

line vty 0 4

password cisco

login

!

!

end

<=== Scotland ===>

scotland#sh run

Building configuration...

Current configuration : 680 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname scotland

!

boot-start-marker

boot-end-marker

!

enable secret xxxx.

!

no aaa new-model

ip subnet-zero

!

!

!

no ftp-server write-enable

!

!

!

!

interface FastEthernet0/0

ip address 11.0.0.250 255.255.0.0

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.1.3 255.255.0.0

encapsulation ppp

!

router rip

version 2

network 11.0.0.0

network 192.168.1.0

!

ip classless

no ip http server

!

!

line con 0

password cisco

login

line aux 0

password cisco

login

line vty 0 4

password cisco

login

!

!

!

end

The only difference I can see is that you are using /16 mask for Scotland's FastEthernet IP address and /8 for Rugeley's FastEthernet IP address.

Please change Rugeley's to /16 (255.255.0.0) and try.

HTH

I have changed the setup as you explained above still nothing

Rugeley see scotlands network

Scotland doesn't see rugeleys network

Jolmos right, you are advertising a /8 network, but your internal network is currently set to /16.

If changing subnet mask doesn't work, also try the following command on both routers

"no auto-summary"

If that doesn't work, can you post show ip route from both routers.

After making the change to the subnet the ip routes look like

<=== Rugeley ===>

rugeley#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/16 is subnetted, 1 subnets

C 10.0.0.0 is directly connected, FastEthernet0/0

11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

R 11.0.0.0/16 [120/1] via 192.168.1.3, 00:00:08, Serial0/0

R 11.0.0.0/8 [120/1] via 192.168.1.3, 00:01:31, Serial0/0

192.168.1.0/32 is subnetted, 1 subnets

C 192.168.1.3 is directly connected, Serial0/0

C 192.168.0.0/16 is directly connected, Serial0/0

<=== Scotland ===>

scotland#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

11.0.0.0/16 is subnetted, 1 subnets

C 11.0.0.0 is directly connected, FastEthernet0/0

192.168.1.0/32 is subnetted, 1 subnets

C 192.168.1.2 is directly connected, Serial0/0

C 192.168.0.0/16 is directly connected, Serial0/0

have you assigned any interfaces as passive?

Right I have no used cisco configmaker now to create the configs for each router as below

<=== Rugeley ===>

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname rugeley

!

enable password cisco

!

no ip name-server

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface f0/0

no shutdown

description connected to Rugeley LAN

ip address 10.0.0.250 255.0.0.0

keepalive 10

!

interface s0/0

no shutdown

description connected to scotland

ip address 192.168.1.2 255.255.255.0

encapsulation ppp

!

router rip

version 2

network 10.0.0.0

network 192.168.1.0

no auto-summary

!

!

ip classless

no ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

line console 0

exec-timeout 0 0

password cisco

login

!

line vty 0 4

password cisco

login

!

end

<=== Scotland ===>

!

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname scotland

!

enable password cisco

!

no ip name-server

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface f0/0

no shutdown

description connected to Scotland LAN

ip address 11.0.0.250 255.0.0.0

keepalive 10

!

interface s0/0

no shutdown

description connected to rugeley

ip address 192.168.1.3 255.255.255.0

encapsulation ppp

!

router rip

version 2

network 11.0.0.0

network 192.168.1.0

no auto-summary

!

!

ip classless

no ip http server

snmp-server community public RO

no snmp-server location

no snmp-server contact

!

line console 0

exec-timeout 0 0

password cisco

login

!

line vty 0 4

password cisco

login

!

end

And the route table shows the opp's network at both routers now. I can ping either router no problem.

===================================================

Just configured the gateways and ip on both networks and success

Thank you all very much for your help

Andy