cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
262
Views
0
Helpful
14
Replies
zillah2004
Beginner

IP Address problem

I have got this scenario:

two routers (1 &2) connect with each other via serial cable, and two LANs, each LAN belong to one of these two routers.say LAN1 and LAN2

Network address for serial cable was :192.168.1.0

Netwwork address for LAN1 is 172.16.5.0/24

Network address for LAN2 is 172.16.8.0/24.

I configured routers (I do not thing I missed something),,,it did not worked unless I changed ip address for one of these LAN to 160.15.0.0/16,,,,Is ther any clue about this issue?

14 REPLIES 14
hando
Beginner

I would like to verify what routing protocol that you are configured to. It depends on your routing protocol is classful or classless. It may be your problem.

It is rip version one

zillah2004
Beginner

It is rip version one

Harold Ritter
Cisco Employee

Try changing the ip address of the wan link to 172.16.x.0/24 or use ripv2 with "no auto-summary". It should take care of it.

ripv1 doesn't cope well with discontiguous networks. ripv2 does.

Hope this helps,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Thanks hritter

At the begining I have got both LANs with these IP addresses:

LAN1 was : 172.16.5.0/24

LAN2 was :172.16.8.0/24

Do you mean it did not work because they are discontiguous?

If I used the IP that you pointed,,do you mean I have to keep my IPs (172.16.5.0, 172.16.8.0) for LANs and use your IP for WAN?

Yes I guess RIPv2 it will work.

Your LAN1 address of 172.16.5.0/24 is a subnet of class B network 172.16.0.0/16. And your LAN2 address of 172.16.8.0/24 is also a subnet of the same class B network 172.16.0.0/16. So when you put an address from a different network 192.168.1.0 on the serial you have made the 172.16 network discontiguous. RIPv1 can not deal with this. RIPv2 can deal with this via the no auto-summary feature. Other protocols such as EIGRP or OSPF can also deal with this.

To solve your issue you must either make the network contiguous by making the address on the serial also a subnet of the class B network. Or you must use a routing protocol that can deal with discontiguous networks.

HTH

Rick

HTH

Rick

Thanks rburts

I changed the IP addresses that I mentioned in my first scenario,I used:

LAN1: 200.100.50.0/24 belong to Router1

LAN2 I used 172.168.0.0/16 belong to Router2

serial:200.200.100.0/24

Routing protocol:rip V1

I

It was fine both routers (router1 and router2) with the command: show ip route ,,can see all networks.

My query,,,I changed RIP V1 to RIP V2,,,I could not see all networks??????

I chandeg from RIP V2 to RIP V1 , I was able to see all networks!!!!.

Second query,,,I have in the Lab PCs all of them are same IBM NetVista P4 ,,when I connected one PC to LAN1(belong to Router1), I could not ping that PC from Router2,,,when I used my laptop instead of that PC,,I was able to ping,,,I expiernced the same problem before,,Is there any tricky thing I ma not aware of it?

First query: thats odd. Perhaps let us see your running-config?

Second query, I doubt there is anything tricky, it seems there may be an issue with your PC, rather, your PC's NIC - is it up? Check your NIC address.

Happy New Year,

Josef.

i will post the configuration

I cannot think why RIP version 1 should work, while RIP version 2 does not. Were you running version 2 on both routers? Which routes could you not see, and on which router? Could you post the show ip route on both routers, each with both RIP version?

If you cannot ping from PC to PC, check that each PC can ping its local default gateway, especially the Netvista P4. It sound like the default gateway may have been incorrect in the Netvista P4, or the gatway address was outside the subnet as configured on the Netvista.

Kevin Dorrell

Luxembourg

Thanks Josef and Kevin>Dorrell

Yes with RIP V2 it worked today ,,,I do not why!!!

With probelm of PC that I mentioned in my previous scenario,,,by they way the PCs are IBM type IntelliStation P4 , not NetVista,(Sorry I mixed with other Lab).

Today I tried to use another PC to see if the ping is working or not,,it did not work,,also I used my laptop instead and it worked!!!!!

In our Lab we have dual boot (XP and Advanced 2000 server),, the problem occured only with 2000 advanced server!!!!!with XP it worked fine.

Now the question,,,Does the NIC has been recognized by 2000 Advanced server? Yes it does,, and the name is:

D-Link DEF-528TX PCI Adater,,same name for XP,,,.

By the way from the 2000 server PC I can ping gateway and next router serial interface,, but I can not ping the fastethernet interface of other router ).....any clue about this issue?

Another strange think I have got 2 NICs for each PC,,,it gave same problem,,,I can post the result of ping for both NICs if necessary.

Second NIC is :Intel(R) PRO/100 VE Desktop Connection

In case if I want to post any thing,Can I post it as attachment to this forum or it should be copy and paste?

Thanks

I'm going to take a long-shot as to what was wrong in the RIPv2 scenario ... Did you test with one PC, change to the other PC (with the same IP), then test again immediately? If so, how long between the tests? I am guessing that the ARP cache in the router still had the MAC address of the old PC. By default, the ARP timeout is 4 hours. There is a command to clear it: clear arp-cache

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipras_r/1rfipadr.htm#wp1017562

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipras_r/1rfipadr.htm#wp1017517

Not sure why it worked with XP and not with 2000, but I am guessing (again!) that XP generates a gratuitous ARP on booting and 2000 does not. Try waiting 4 hours (!), or clearing the arp cache, and try agin.

But that does not explain why you can ping the local gateway and the next router serial interface (do you mean the serial interface of the remote router?), but not beyond. That sounds more like not having a proper route back to the other router. Is this still using RIPv1, with two subnets of 172.16.0.0 on different sides of the serial link? If so, that is the discontiguous-network problem. Could we see the show ip route on each router during the problem scenario?

If you have two NICs, that also could be interfering, depending on how each one is configured. I think we need to see more detail of each element in your network. If it has 2 NICs, is it configured to behave as a router itself? Is it running RIP? Is the other interface connected to anything?

About posting attachments: you can do either a cut-and-paste up to 4000 characters, or a file attachment.

Kevin Dorrell

Luxembourg

Thanks kevin

Yes boss, I enabled long time ago ip routing in registry of windows 2000 server.I like your prescription,, I will test one by one what you said and I will let you know.

Many thanks

asd_asd_22
Beginner

I think you should a classless routing protocol as OSPF, ISIS, EIGRP,or RIP v2. but with EIGRP and RIP v2. you have to use "no auto-summary" command from the router configuration mode.

Content for Community-Ad