cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
16283
Views
10
Helpful
18
Replies

OSPF not advertising network associated with Loopback interface

m.tapping
Level 1
Level 1

Following router/IOS/WAN upgrade OSPF is not advertising the subnet associated with the Loopback interface. It does however advertise the actual Loopback interface address. The subnet associated with the Loopback interface is used for NAT translations.

System image file is "flash:c2600-is-mz.122-23.bin"

interface Loopback0

ip address 172.18.33.1 255.255.255.0

!

interface FastEthernet0/0

ip address 192.168.3.2 255.255.255.0 secondary

ip address 172.16.10.101 255.255.248.0

ip access-group 110 in

no ip redirects

ip nat inside

speed 10

half-duplex

no cdp enable

!

interface BRI0/0

no ip address

ip nat outside

encapsulation ppp

no ip mroute-cache

dialer rotary-group 1

isdn switch-type basic-net3

no fair-queue

no cdp enable

!

interface ATM1/0

description *** 2Mbps CellStream ***

bandwidth 2048

no ip address

no ip mroute-cache

logging event subif-link-status

no atm ilmi-keepalive

scrambling-payload

impedance 120-ohm

!

interface ATM1/0.1 point-to-point

bandwidth 1024

ip address 172.31.5.70 255.255.255.252

ip nat outside

pvc Risley 1/32

vbr-nrt 1024 1024 64000

oam-pvc manage

encapsulation aal5snap

!

!

interface ATM1/0.2 point-to-point

bandwidth 1024

ip address 172.29.1.58 255.255.255.252

ip nat outside

pvc SunGard 1/34

vbr-nrt 1024 1024 64000

oam-pvc manage

encapsulation aal5snap

!

!

interface ATM1/1

no ip address

shutdown

no atm ilmi-keepalive

scrambling-payload

impedance 120-ohm

!

interface ATM1/2

no ip address

shutdown

no atm ilmi-keepalive

scrambling-payload

impedance 120-ohm

!

interface ATM1/3

no ip address

shutdown

no atm ilmi-keepalive

scrambling-payload

impedance 120-ohm

!

interface Dialer1

bandwidth 1

ip address 172.18.48.17 255.255.255.0

ip nat outside

encapsulation ppp

dialer in-band

dialer idle-timeout 300

dialer map ip 172.18.48.1 name foxrtr-ris03 broadcast *****830874

dialer hold-queue 10

dialer-group 1

no fair-queue

no cdp enable

ppp authentication chap

!

router ospf 100

log-adjacency-changes

redistribute connected metric-type 1 subnets

redistribute static

passive-interface FastEthernet0/0

network 172.18.33.0 0.0.0.255 area 0

network 172.18.48.0 0.0.0.255 area 0

network 172.29.1.0 0.0.0.255 area 0

network 172.31.5.0 0.0.0.255 area 0

distribute-list 2 out

!

ip nat pool pj 172.18.33.20 172.18.33.254 netmask 255.255.255.0

ip nat inside source list 1 pool pj

ip nat inside source static 172.16.9.86 172.18.33.14

ip nat inside source static 172.16.8.247 172.18.33.13

ip nat inside source static 172.16.9.97 172.18.33.5

ip nat inside source static 172.16.9.28 172.18.33.4

ip nat inside source static 172.16.9.132 172.18.33.11

ip nat inside source static 172.16.13.24 172.18.33.2

ip nat inside source static 172.16.9.77 172.18.33.7

ip nat inside source static 172.16.9.53 172.18.33.3

ip nat inside source static 172.16.8.75 172.18.33.9

ip nat inside source static 172.16.18.3 172.18.33.12

ip nat inside source static 172.16.9.71 172.18.33.6

ip classless

ip route 0.0.0.0 0.0.0.0 172.18.48.1 150

ip http server

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 permit 192.168.2.0 0.0.0.255

access-list 1 permit 192.168.3.0 0.0.0.255

access-list 1 permit 192.168.5.0 0.0.0.255

access-list 1 permit 172.16.0.0 0.0.255.255

access-list 2 deny 192.168.3.0

access-list 2 deny 172.16.8.0

access-list 2 deny 172.16.0.0

access-list 2 permit any

18 Replies 18

ruwhite
Level 7
Level 7

Under the loopback interface, do this:

ip ospf interface-type point-to-point

And see if that helps. OSPF treats loopback interfaces as virtual interfaces by default, and only advertises the interface address as a /32. Putting this command in tells OSPF to treat the loopback as a point-to-point, and advertise the network address instead.

:-)

Russ.W

Unfortunately it didn't have the desired effect.

Although the interface type had changed when viewed using "show ip ospf int" the router is still not generating any Network Link-State advertisements.

Upon further investigation using "show ip ospf database self-originate" only the router Link-State advertisement is being generated.

This smells of an IOS bug but i'm not sure yet.

Marc.T

Hi Guys,

 

Just a quick updates, I encountered the same thing as m.tapping. 

Put "ip ospf network point-to-point" as suggested, then "clear ip ospf process".

It works!!! By the way I am using 15.0(1)M8. Hope can help.

 

Regrads,

ZX

ccnpccnp
Level 1
Level 1

Hello, I am currently studying for the CCNP BSCI and i am probably wrong. You are using A NAT inside address of 172.18.33.0 specified in the network command in OSPF and that may be using fast ethernet 0/0 which has a passive interface command assigned to it and passive interfaces do not listen or send updates because the neighbor relationship will not form. I assume that you are using Fast ethernet 0/0 because it has the ip nat inside command on it.The inside subnet is being used for nat translations.

continued from above, maybe the subnet is not listed in the nat pool range 20 to 254. I tried. Take care

If you can , try to put:

interface Loopback0

ip address 172.18.33.1 255.255.255.255

Use the host address, don't use /24.

Did you try issuing the command:

clear ip ospf processes

Sometimes this is necessary to reset OSPF.

Thanks, I did try that and it certainly helps to tidy the OSPF protocol after you've been messing with parameters. It did not solve the problem though, it is looking increasingly like an IOS problem.

I even resorted to using "redistribute connected metric-type 1 subnets" and still the loopback stub network is not advertised.

Thanks, I did try that and it certainly helps to tidy the OSPF protocol after you've been messing with parameters. It did not solve the problem though, it is looking increasingly like an IOS problem.

I even resorted to using "redistribute connected metric-type 1 subnets" and still the loopback stub network is not advertised.

Hi there,

I know you may think this is strange, but have you tried getting rid of the ospf process altogether and then reconfiguring it?

Copy the OPSF config to notepad, and then in global config, use "no router ospf xxx". Then copy it back in. I have had no problem uusing the ip ospf net point-to-p copmmand in order to get a loopback advertised as a network and not a host.

Regards,

Joe

Yep, did that too.

I seem to have exhausted most things which is why I think it's IOS.

Difficulty now is finding a different version of IOS for a 2610XM that supports a 'NM-4E1-IMA' module because the online h/w s/w matrix tool does not yet support 2610XM.

Thanks.

Have you tried a different loopback number to see if you can get that advertised?

I see what you are trying to do with your NAT, but couldn't you do the same thing with overload, andthe IP address of the FA port?

Joe

Just another couple of thoughts. What/where are your OSPF neighbors and how do you know that you are not advertising the loopback correctly? I think you alread did this, but could you post the output from the show ip ospf int command?

I would think that most IOS would automatically support ATM, especially any plus versions.

Joe

I ask because the broadast keyword is suspiciously missing from your ATM subinterface config (since like FR ATM is NBMA). Although I can't remember for sure if a point-to-point ospf interface needs this.

Joe

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: