Showing results for 
Search instead for 
Did you mean: 



Currently our company is testing two Cisco's cameras.

First one, CIVS-IPC-2500, is fine. Second, CIVS-IPC-4500, is not.

First of all, only IE and FF can get trough login page, but Chrome can't -- after click to Login button, Chrome goes to login page, again and again.

I don't believe that anything is wrong with Chrome.

Secondly, if click to View Video on the web client, error arise about wrong version of .NET SDK (, however IE8 shows something else (

I do believe that issue is firmware. Current version of it is 1.0.1 ( Attempt to download it from Support just failed.

Could anyone be so kind to help with it, please?



After million emails I've got firmware 1.0.3 from local Cisco office.

But it doesn't help. Not at all.

On the try to upgrade firmware all my browsers say same thing: ActiveX initialization failed.

Any advise?!

Tried IE6 -- same error.


The solution for mentioned issue is to install oldest IE6 what you can find, and oldest .NET SDK, but newer than version 2.0

The second step, what you must do, is to turn off all security things in IE6, even if you pretty sure that this buggy browser already has all them turned off.

Don't even hope -- you must turn them off further.

Third -- update firmware to latest 1.0.3. Where you will find it is a big mystery, since on it is not available for download.

Should I not mention that upgrade can be done only in IE6.

Fourth step is to check how IE6 is trying to show HDTV video and hung. And hung. Period.

Thus, obviously, last step came -- return CIVS-IPC-4500 to Cisco' office and never ever try this crаp again. Sic!

Hi Sergei

Sorry for the trouble you've been having. I do see 1.0.3 firmware on CCO and am

checking if we have something later, even if it isn't released yet. If you want to try

again let me know and I'll work on getting a lab setup to work on your problem.


Sure I want!

Ok, cool, I thought you might have already taken the camera back.

I found a 4300 camera running 1.0.3, and I get an error trying

to view with FF.

.NET SDK/Runtime 2.0 or above is not available

which is expected since IE/ActiveX are required to view video.

Now I need to get Windows going so I can test with IE

So, I have a windows virtual machine running on my Mac and was able to pull up IE.

At first I didn't see any video, but when I had my mouse in the video pane it displayed

a little popup asking me to download, I'm not sure what

exactly that is, some sort of ActiveX control I guess. Now I'm able to see SD video.

The user guide does say IE 6.X is required, so I think that explains why later

versions didn't work for you.

Are you able to see SD video ? or nothing at all ?

When I try to View Video the only thing popups for download is [1]DxPlay[2].cab, nothing like

What do you mean by SD? There is nothing like that.

I discovered that message was from a 2500 camera, which worked fine

after I realized I needed to click to install the ActiveX control.

The "does not support object or method" error seems to be a way of

saying "download an ActiveX control". The actual error about ActiveX was

quite small, and in the background.

Now I'm trying on a 4500

I've tested CIVS-IPC-2500 too, and after short shaman's dance it works just fine. So, I would say that there is no issues with 2500 camera.

Hello Sergei,

What appears to be happening is that your browser is blocking ActiveX initialization because of the default security settings of the Internet Zone. The browser sees the script as not safe so it disables its initialization. The solution, and this should work for IE7 and IE8 as well, is to add the camera as a trusted site in the trusted zone and enable all ActiveX settings under Tools > Internet Options > Security > Trusted Sites > Custom level. After initialization of the ActiveX controls is complete, reset the settings to the default and the script should now run ok allowing viewing live video under default medium Internet zone settings.

Note that v1.0.3 firmware for the 4000 series HD cameras is available on CCO at:

If you restart your browser and log in to view the live feed - what is the result? What are your stream settings for the active channel?



Here is settings what I made in IE8:

Sorry for Russian, there is no way to switch IE8 to English interface. is camera's address.

Only for testing I set all settings to the lowest level:

When click View Video in web, next error arise:

Can't say how this error sounds in English, but if translate it says "Object does not support property or method".

Even more, may be it help, when press any control button on the interface above, nothing works, and next error indicates on the corner of IE8:

I think that it might be a issue not with ActiveX only, but with Java too.

I've checked installed Java's version:

Version 6 Update 20.

I doubt that camera needs newer version.

Hi Sergei,

It sounds like the active X controller could not install properly.

Can you please try the following:
ensure that you are logged in as an Administrator of that machine
Un-install DxPlayInstaller from Control Panel -> Add/Remove Programs
Then connect to the camera web interface and allow Active X to install which will re-install DxPlayInstaller


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: