Showing results for 
Search instead for 
Did you mean: 

RV340 Cannot Create PPTP server within subnet

Chet Prokop
Level 1
Level 1

Setting up customer RV340 - needs to use PPTP VPN with Win10 VPN service. 

When configuring PPTP Server tab, set start and end IP addresses to a small range within an unused group of IPs in the scope of the working subnet.  Regardless of where I try to set in 8 IPs, I get a subnet range error!  See jpg

We've set up PPTP in RV320's with ease.  Not sure what I'm missing here, but not able to set the IP range in the working LAN range used.  

What am i missing?


Chet Prokop, PE, PhD
Cisco Select Partner
SMB - IT and Telecom Services
Houston, TX
28 Replies 28

Jorge Obregon
Cisco Employee
Cisco Employee


I have test this range on a Lab router and it was working fine for PPTP,  please see screenshot. thing I would advise you is to make sure you are not using that same subnet on another VPN settings or vlan settings

2. I will also advise you to upgrade to the latest firmware version

3. if you are still having the same issue I would advise you to call 1 866-606-1866 so we can open a case for you and help you troubleshooting this. 

if you have more questions please let me know. 

thank you for contact cisco support community. 


Please offer some reference or example to correctly set this up then?

You see my pix and it's the same range set by yours?   The primary RV340 LAN subnet is  We do this same PPTP VPN set up on RV320's all the time to access network devices at customers remotely ... on their primary subnet LAN.   

WHy is this not working here?

It's clear the RV340 version of the admin guide is ... lacking.. to be kind.  If you have a resource to detail the setup for PPTP I'd appreciate it.  There's something we're obviously missing with the 340 setup that is not consistent with other RV routers for PPTP.


Chet Prokop, PE, PhD
Cisco Select Partner
SMB - IT and Telecom Services
Houston, TX

Hi, I have exactly the same issue with the same error messages on this router trying to configure pptp. I'm using IP range So i'm interested to know what i'm doing wrong (if anything) to get the vpn setup on it


Same here. I have multiple RV340s in the field all using different subnets ranging from to all VLAN 1 all with a DHCP of 99-199, and I have yet to successfully have a PPTP set up on any of these routers because of the subnet range error. All on the latest firmware, but this also didn't work on the previous firmware either.

Wow. Great to hear I'm not going crazy--- that setup should work as it does on the RV320's... which we've used now for years with PPTP under the active LAN subnet.  That is the way I'd (and you'd) expect to access remotely the primary LAN the RV340 is on!!

Hopefully our Cisco router team will recognize this and "solve" the same subnet issue... and quickly.

The customers with RV340's we've installed cannot make use of the PPTP access to their primary subnet ... at all... because of this.  makes zero sense!  We cant get to their devices using this to make changes either.

Please fix!

Chet Prokop, PE, PhD
Cisco Select Partner
SMB - IT and Telecom Services
Houston, TX

Can anyone advise, on how his or her need for PPTP was filled?     Obviously, some other pathway, some other equipment, must have been employed.   As of Feb 25, 2019, with the latest firmware ( the "range error" bug remains in the RV340 design.

Any sites that I manage where this is important / required, I have migrated them to Ubiquiti Edgerouter Lite (same Cavium dual core architecture as the RV320) or even an Ubiquiti Edgerouter X (slower CPU).  Programming them is an annoying mix of GUI, config tree and command line operations but once configured their PPTP performance blows away the RV320 (RV180 was vastly superior for PPTP) and are extremely reliable just like the Cisco RV routers I have programmed and used for years at these sites.


This isn't a "bug", it's an intentional restriction on the design of the RV34x Cisco is writing their own ticket on eliminating its use in the field for this type of application.  The fact that they won't even process a PPTP login without using unencrypted PAP is basically an admission that the PPTP server capability is nothing more than a token gesture for the spec sheet.


It would be a lot more honest if they would just remove its support from the firmware as it is basically a deceptive waste of time and effort.  The way it is implemented now, it is essentially their marketing department flipping you the bird while padding the product's spec sheet.

Well, I say it's a bug, not an intentional malfunction.

I'm angry with Cisco's Small Business Line, for its waste of my time, and for wasting the time of so many others, silent and vocal, who obviously exist.


By the way, L2TP server suffers from the same BUG as PPTP server, in the latest RV340 incarnation (f/w very recent. That is, there occurs an immediate "range error" upon attempt by user to establish client IP addresses, in the RV340's L2TP server set up.  STILL, AFTER ALL THESE YEARS.

Hey, I sent my RV340 back for a refund.   For reason of "defective design, in matters critical to me."

I still manage others.

on the RV340/RV345, the PPTP nor other VPN solutions (e.g. Cisco Anyconnect) cannot use any of the existing networks (vlans) because already used for another LAN.


this is a better examples:RV340 - existing networks.pngRV340 - PPTP error because the range is already used.pngRV340 - PPTP works because that network is not used.png


on the first image, you can see the currents networks on the devices.

then, I tried to use one of those networks on the PPTP VPN but displayed same error that you got.


If I use another network, no listed on the currents ones, is success.





Mario Espinoza
.:|:.:|:. Cisco Small Business TAC
Shift Hours: Monday - Friday from 9:30 AM – 7:00 PM (EST)

Most of our Product documentation and Solutions to commonly asked questions can be found at

Cisco Support Frontline Phone Number: +1 866-606-1866
Cisco Support Worldwide Contacts:

Doesn't this defeat the purpose of what is trying to be accomplish? Where can we get a step by step instruction on how to setup a pptp vpn using a cisco small buisness (RV345 preferably) router.

They have step by step instructions out there, but this is an intentional addressing restriction--and the instructions also divulge that only unencrypted PAP authentication works on it. So the PPTP server is basically a token gesture feature to pad the spec sheet, and this is still true as of firmware 2.16.

It's essentially marketing deception / trickery to get those looking for legacy features to buy the product (only to realize it is unusable for the intended purpose of any useful PPTP support) in the hopes that they will migrate to a different VPN architecture vs returning the product. Cisco needs to be honest about this "feature" and either make the PPTP server work decently or just remove it from the firmware interface and the spec sheet. Doing that for version 2.xx firmware with its radical GUI redesign would have been the perfect time. I prefer configuring Cisco routers, but I have moved on to Ubiquiti Edgerouter Lite or even the Edgerouter X model routers for any sites requiring a PPTP server.