04-23-2011 01:40 AM - edited 03-04-2019 12:09 PM
Hi,
We have some point-to-point sites linked with our HO with 10-30mbps speed. We have provided DID telephone lines to these sites as well.
We want to limit the bandwidth with 1mb bandwidth only and also make sure that the voice traffic (DID telephone lines) gets the priority over all other traffic even if they are utilitizing the 1mb link completely. We have some Cisco 1841 routers that we are planning to configure on the main uplink on each of these sites.
Can someone guide on the configuration part about how to give the priority to the voice traffic yet limiting the bandwidth to 1mb.
Thanks in advance.
K
Solved! Go to Solution.
04-24-2011 11:50 PM
Hi,
If you have a seperate Vlan for Voice then it would be possible to allocate bandwidth under the vlan's
See the below two individual steps may help in your scenario.
STEP-1:
Apply rate-limit on each L3 vlan interface in your 2851
Example (for 1024kbits for vlan 2):
Router# conf t
Router(config)# int vlan 2
Router(config-if)#rate-limit input 1000000 187500 375000 conform-action transmit exceed-action drop
Router(config-if)#rate-limit output 1000000 187500 375000 conform-action transmit exceed-action drop
STEP-2:
Policy a specific VLAN number on VLAN interface.
class-map vlan5
match vlan 5
match class-map class-default
policy-map vlan5-limit
class vlan5
police 2000000 250000 exceed-action drop
int vlan5
service-policy input vlan5-limit
After you apply this configuration, the traffic with VLAN 5 coming from any will be policed at 2Mbps.
Hope this will help you.
Please rate the helpfull posts.
Regards,
Naidu.
04-24-2011 02:26 PM
HI,
This link should help: http://www.cisco.com/en/US/partner/docs/ios/qos/configuration/guide/congstion_mgmt_oview_ps6350_TSD_Products_Configuration_Guide_Chapter.html
Thanks,
Laurent.
04-24-2011 11:50 PM
Hi,
If you have a seperate Vlan for Voice then it would be possible to allocate bandwidth under the vlan's
See the below two individual steps may help in your scenario.
STEP-1:
Apply rate-limit on each L3 vlan interface in your 2851
Example (for 1024kbits for vlan 2):
Router# conf t
Router(config)# int vlan 2
Router(config-if)#rate-limit input 1000000 187500 375000 conform-action transmit exceed-action drop
Router(config-if)#rate-limit output 1000000 187500 375000 conform-action transmit exceed-action drop
STEP-2:
Policy a specific VLAN number on VLAN interface.
class-map vlan5
match vlan 5
match class-map class-default
policy-map vlan5-limit
class vlan5
police 2000000 250000 exceed-action drop
int vlan5
service-policy input vlan5-limit
After you apply this configuration, the traffic with VLAN 5 coming from any will be policed at 2Mbps.
Hope this will help you.
Please rate the helpfull posts.
Regards,
Naidu.
04-25-2011 01:27 AM
Hi,
Thanks for reply.
We do not have VLAN configured for our network. It is FLAT with VLAN1.
STEP 1:
This will only fix the bandwidth upto 1mb. What if i add access-list to it and try to give priority to the desired traffic ? I want to assign 512kbps for desired traffic (as per access-list) and rest to be using 1mb. The total bandwidth allocated to them will be 1mb out of which the desired traffic should get 512 always. Example -
ip access-list extended 100
permit udp 10.1.253.0 0.0.0.240 any
permit udp any 10.1.253.0 0.0.0.240
permit tcp host 192.168.168.48 any eq 1494
permit tcp any host 192.168.168.48 eq 1494
interface FastEthernet0/0
description ETH-LAN
ip address 192.168.168.199 255.255.255.0
rate-limit input access-group 100 512000 512000 512000 conform-action set-prec-transmit 5 exceed-action set-prec-continue 0
rate-limit output access-group 100 512000 512000 512000 conform-action set-prec-transmit 5 exceed-action set-prec-continue 0
rate-limit input 1024000 8000 8000 conform-action transmit exceed-action drop
rate-limit output 1024000 8000 8000 conform-action transmit exceed-action drop
duplex auto
speed auto
Please guide.
Thanks again,
K
04-25-2011 02:33 AM
Hi,
Thats even good idea. The only thing now is that your router need to support rate-limit commands.
And that Vlans based rate limit is what I brought from the best practices.
Please click on the correct answer if this answered your question.
Regards,
Naidu.
04-25-2011 03:26 AM
Hi,
The router 1841 does support rate-limt command.
Also ip nbar is good option to check the traffic and police accordingly.
Thanks for the guidance.
K
04-25-2011 03:31 AM
YES,
NBAR can be used to monitor both input and output traffic also and may be applied with or without a service policy enabled.
Below is the sample config for your reference...
interface ethernet 1/3
ip nbar protocol-discovery
#sh ip nbar protocol-discovery
Please rate the helpfull posts.
Regards,
Naidu.
04-25-2011 04:39 AM
Hi,
My doubts are mostly clear, except below !
In the "rate-limit" command, if i want to limit to 512k, we get 3 options,
1) Bits per seconds (Here i will mention 512000 for 512kbps bandwidth)
2) Normal burst bytes (What this should be ? Same 512000 ?)
3) Maximum burst bytes (What this should be ?)
Please guide.
Thanks in advance.
K
04-25-2011 11:18 PM
Hi,
See the below link will clear all your doubts.
http://slaptijack.com/networking/inbound-rate-limiting-on-cisco-catalyst-switches/
Please rate the helpfull posts.
Regards,
Naidu.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide