cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2933
Views
10
Helpful
7
Replies

877w/ADSL2+ default gateway not set, tried all the obvious solutions

pomfmaster
Level 1
Level 1

Hello!

I have a fairly simple config running on my 877w and it looks alright, but somehow 'show ip route' returns 'default gateway is not set'.

I tried both 'ip route 0.0.0.0 0.0.0.0 Dialer1' and 'ppp ipcp route default', the 'default gateway is not set' problem persists either way.

It could have been a firmware issue but the previous owner had the same ISP and I did nothing but reset the router's config.

IP addresses are distributed as they should, I can access the router's server, it's just there's no WAN connection.


There's one more problem in case they may be connected: when a client is connected to the router I keep getting the 'not ecnrypted dot1x packet' error, though it doesn't terminate the connection and doesn't really do anything visible.

I'm really sorry to bother you all, but at this point I'm lost without assistance and none of my friends worked with ADSL. I would really appreciate any bit of help.

Thanks in advance,

Sincerely yours,

Eugene.

Here's the config (no NAT):

Building configuration...

Current configuration : 4127 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname %HOSTNAME%

!

boot-start-marker

boot-end-marker

!

logging queue-limit 1000

logging buffered 100000

logging reload alerts

logging rate-limit console 20

enable password ****

!

no aaa new-model

!

crypto pki trustpoint TP-self-signed-36895898

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-36895898

revocation-check none

rsakeypair TP-self-signed-36895898

!

!

crypto pki certificate chain TP-self-signed-36895898

certificate self-signed 0 []

       quit

dot11 syslog

!

dot11 ssid pppoverthecuckoosnest

  vlan 1

  authentication open

  authentication key-management wpa

  mbssid guest-mode

  wpa-psk ascii 0 y8AuM8RUsQc7w

!

no ip routing

no ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.0.1 192.168.0.10

!

ip dhcp pool vlan1

  network 192.168.0.0 255.255.255.0

  default-router 192.168.0.1

!

!

!

!

!

username eugene privilege 15 password 0 taurus11

!

!

archive

log config

hidekeys

!

!

!

bridge irb

!

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode adsl2+

!

interface ATM0.1 point-to-point

description avangarddsl

no ip route-cache

pvc 0/35

pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

shutdown

!

interface FastEthernet1

shutdown

!

interface FastEthernet2

shutdown

!

interface FastEthernet3

shutdown

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 1 mode ciphers tkip

!

broadcast-key vlan 1 change 30

!

!

ssid pppoverthecuckoosnest

!

mbssid

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.

0

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

no ip route-cache

bridge-group 1

!

interface Dialer1

ip address negotiated

no ip redirects

no ip unreachables

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no keepalive

no cdp enable

ppp authentication pap callin

ppp pap sent-username ptn password 0 ptn

!

interface Dialer0

no ip address

ip mtu 1452

ip tcp adjust-mss 1452

!

interface BVI1

ip address 192.168.0.1 255.255.255.0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip http server

ip http secure-server

!

snmp-server community public RO

!

!

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

no modem enable

line aux 0

line vty 0 4

login local

!

scheduler max-task-time 5000

end

1 Accepted Solution

Accepted Solutions

Hi,

interface Dialer0

ip nat outside

interface BVI1

ip nat inside

access-list 99 permit 192.168.0.0 0.0.0.255

ip nat inside source list 99 interface Dialer0

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

7 Replies 7

paolo bevilacqua
Hall of Fame
Hall of Fame

With IP routing enabled,  "default gateway" will never be set, because that applies to hosts, not routers.

That is not a problem at all, andevertying works fine using "default route" instead of "default gateway".

Then if no Internet connection, shart checking "shjow dls interface" and then various other show commands.

Oh, I see.

Thanks a lot! That does mean that there's more digging to go through, though, because there's still no internet connection!

show dsl interface:

ATM0

Alcatel 20190 chipset information

                ATU-R (DS)                      ATU-C (US)

Modem Status:    Showtime (DMTDSL_SHOWTIME)

DSL Mode:        ITU G.992.5 (ADSL2+) Annex A

ITU STD NUM:     0x03                            0x2

Chip Vendor ID:  'STMI'                          'IFTN'

Chip Vendor Specific:  0x0000                    0x71C4

Chip Vendor Country:   0x0F                      0xB5

Modem Vendor ID: 'CSCO'                          '    '

Modem Vendor Specific: 0x0000                    0x0000

Modem Vendor Country:  0xB5                      0x00

Serial Number Near:    FCZ131412EB

Serial Number Far:

Modem VerChip ID:        C196 (0)

DFE BOM:         DFE3.0 Annex A (1)

Capacity Used:   45%                             100%

Noise Margin:    21.0 dB                         19.5 dB

Output Power:    18.5 dBm                        12.5 dBm

Attenuation:     28.0 dB                         13.0 dB

Defect Status:   None                            None

Last Fail Code:  None

Watchdog Counter: 0x22

Watchdog Resets: 0

Selftest Result: 0x00

Subfunction:     0x00

Interrupts:      230961 (0 spurious)

PHY Access Err:  0

Activations:     1

LED Status:      ON

LED On Time:     100

LED Off Time:    100

Init FW:         init_AMR-3.0.014_no_bist.bin

Operation FW:    AMR-3.0.014.bin

FW Source:       embedded

FW Version:      3.0.14

                 DS Channel1      DS Channel0   US Channel1       US Channel0

Speed (kbps):             0             5472             0               764

Cells:                    0               37             0            382656

Reed-Solomon EC:          0                7             0                 0

CRC Errors:               0                0             0                 0

Header Errors:            0                0             0                 0

Total BER:                0E-0           0E-0

Leakage Average BER:      0E-0           0E-0

Interleave Delay:         0               12             0                48

                        ATU-R (DS)      ATU-C (US)

Bitswap:               enabled            enabled

Bitswap success:          0                   0

Bitswap failure:          0                   0

LOM Monitoring : Disabled

DMT Bits Per Bin

000: 0 0 0 0 0 0 4 5 6 7 8 8 9 9 9 9

010: 9 8 8 8 9 9 9 9 9 9 9 8 8 8 8 8

020: 0 0 2 2 2 3 4 5 5 6 6 7 7 7 7 8

030: 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8 8

040: 8 8 7 8 8 2 8 8 8 8 7 7 7 7 7 7

050: 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7

060: 7 7 7 7 7 7 7 7 7 7 7 7 7 7 0 7

070: 7 7 7 7 7 7 7 7 7 7 7 6 6 2 0 0

080: 2 2 6 6 6 6 6 6 6 6 6 6 6 6 6 6

090: 5 6 5 5 5 6 6 6 6 6 5 5 5 5 5 6

0A0: 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5 5

0B0: 5 5 5 5 5 5 5 5 5 5 5 5 0 5 5 0

0C0: 5 5 5 5 5 5 5 5 5 5 5 4 5 4 4 4

0D0: 4 5 4 4 4 5 4 4 4 5 4 5 4 4 5 4

0E0: 5 4 4 4 4 4 4 4 5 4 4 4 4 4 4 4

0F0: 4 4 4 0 4 4 4 4 4 4 4 4 4 4 4 4

100: 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4

110: 4 4 4 4 4 4 4 4 4 4 4 4 4 4 3 3

120: 4 4 3 0 4 4 4 3 3 3 4 3 3 4 3 4

130: 3 4 3 4 3 4 3 3 4 3 3 3 3 3 3 4

140: 3 4 4 3 3 3 3 4 4 3 4 3 3 3 3 4

150: 3 3 3 3 3 3 3 3 3 3 3 3 0 3 3 2

160: 3 3 3 3 2 2 2 3 2 2 2 2 2 2 2 2

170: 3 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

180: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

190: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

1A0: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 1

1B0: 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

1C0: 2 2 2 2 2 2 2 2 2 2 0 1 2 2 2 2

1D0: 2 2 2 2 2 2 2 2 1 2 2 2 2 2 2 1

1E0: 1 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0

1F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

DSL: Training log buffer capability is not enabled

show dialer1:

Di1 - dialer type = DIALER PROFILE

Idle timer (120 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is data link layer up

Number of active calls = 0

I assume, the number of active calls being zero is a bad thing

cadet alain
VIP Alumni
VIP Alumni

you turned off ip routing: 

no ip routing

but you didn't set any ip default-gateway x.x.x.x  ---> reenable ip routing:

config t

ip routing

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Oh, silly me. Of course, this may be the case :c I'll try that and report back in a second.

Thank you once again! That got rid of the gateway problem, but it seems like there's still no internet connection on the connected laptops

ip route shows:

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     7X.0.0.0/32 is subnetted, 1 subnets

C       7X.XX.192.1 is directly connected, Dialer1

     9X.0.0.0/32 is subnetted, 1 subnets

C       9X.XX.XX.29 is directly connected, Dialer1

C    192.168.0.0/24 is directly connected, BVI1

S*   0.0.0.0/0 is directly connected, Dialer1

Hi,

interface Dialer0

ip nat outside

interface BVI1

ip nat inside

access-list 99 permit 192.168.0.0 0.0.0.255

ip nat inside source list 99 interface Dialer0

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Thank you once again!

I thought I could get away without setting up NAT and access list and use them to define exclusions, but unfortunately it seems like I need it. That's really embarrasing.

I set it up just like that and added the name servers and now everything's working.

Thank you so very much, your input was more than valuable.

Review Cisco Networking for a $25 gift card