cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

611
Views
0
Helpful
1
Replies
Highlighted
Contributor

887 router - two outbound NAT on dynamic IP's

Hi.

I've got an 887M router which will be configured with two linke - one ADSL, one 3G - both of which will have (obviously) a separately suppplied IP address from the different ISP's being used. The 3G is a backup - plain and simple - for use only when the DSL service flakes out (which it does often)

Routing is pretty simple - I'll either do soemthing with a bit of PBR, or a simple weighted static, but the NAT has me scratching my head a little.

Can I have two outbound NAT pools (ip nat outside) for each interface which will be used ONLY for traffic going out the interface concerned?

For example, I have one for the primary link

ip nat inside source list 2 interface Dialer1 overload

Can I do the same for the second dialer interface like this

ip nat inside source list 2 interface Dialer2 overload

and have them automatically switch to using the dialer 2 IP for the outbound NAT if the dialer 1 link fails?

I don't think I've ever come across this before, so I'm not sure if it can even be done.

Thanks for any input.

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advisor

887 router - two outbound NAT on dynamic IP's

darren:

Just go:

interface Dialer 1

Description Primary link ISP1

ip address 78.x.x.x 255.255.255.0

ip nat outside


interface Dialer 2

Description Secondary link ISP2  (3G)

ip address 79.x.x.x. 255.255.255.0

ip nat outside


interface FastEthernet1/1

Description Inside LAN segment

ip address 172.168.60.1 255.255.255.0

ip nat inside


access-list 100 permit ip 172.168.60.0 0.0.0.255 any

access-list 100 permit ip 172.168.60.0 0.0.0.255 any


route-map isp1 permit 10

match ip address 100

match interface Dialer 1


route-map isp2 permit 10

match ip address 100

match interface Dialer 2


ip nat inside source route-map isp1 interface Dialer 1 overload

ip nat inside source route-map isp2 interface Dialer 2 overload


ip route 0.0.0.0 0.0.0.0 79.y.y.y   -----> Primary Default route pointing towards Next hop ip of ISP1

ip route 0.0.0.0 0.0.0.0 78.y.y.y 10  -----> Backup Default route with higher AD (10) pointing towards Next hop ip of ISP2 (3G)

let me know if it works


=============================
Please remember to rate useful posts, by clicking on the stars below. 

=============================

Please remember to rate useful posts, by clicking on the stars below.

View solution in original post

1 REPLY 1
VIP Advisor

887 router - two outbound NAT on dynamic IP's

darren:

Just go:

interface Dialer 1

Description Primary link ISP1

ip address 78.x.x.x 255.255.255.0

ip nat outside


interface Dialer 2

Description Secondary link ISP2  (3G)

ip address 79.x.x.x. 255.255.255.0

ip nat outside


interface FastEthernet1/1

Description Inside LAN segment

ip address 172.168.60.1 255.255.255.0

ip nat inside


access-list 100 permit ip 172.168.60.0 0.0.0.255 any

access-list 100 permit ip 172.168.60.0 0.0.0.255 any


route-map isp1 permit 10

match ip address 100

match interface Dialer 1


route-map isp2 permit 10

match ip address 100

match interface Dialer 2


ip nat inside source route-map isp1 interface Dialer 1 overload

ip nat inside source route-map isp2 interface Dialer 2 overload


ip route 0.0.0.0 0.0.0.0 79.y.y.y   -----> Primary Default route pointing towards Next hop ip of ISP1

ip route 0.0.0.0 0.0.0.0 78.y.y.y 10  -----> Backup Default route with higher AD (10) pointing towards Next hop ip of ISP2 (3G)

let me know if it works


=============================
Please remember to rate useful posts, by clicking on the stars below. 

=============================

Please remember to rate useful posts, by clicking on the stars below.

View solution in original post

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here