cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
332
Views
0
Helpful
2
Replies

Another Bonding, Load Balancing Question?

ccsmith705
Level 1
Level 1

I have seen several similar questions posted, but none of them really answered my question. Here’s my situation. I have a 7200 router at my core and a 2621 at a remote site. They are connected by a point-to-point T1. This T1 terminates into a Kentrox Add/Drop CSU/DSU. The Kentrox box handles the line configuration with the local telco. It also splits-up the T1, 12 channels for voice and 12 channels for data. The data portion is handed off to the router on a V.35 interface. I need to add a second T1 strictly for data. I will need to add another Kentrox box at both ends to terminate the new T1 and install a second T1-WIC in the 2621. The 7200 has a spare serial interface. What I will end up with is, two separate T1’s, one full T1 and one half of a T1, connecting the remote site My question is what is the best way to load balance the data across these two separate and unequal links? Can I bond them together? Any help provided is much appreciated.

Following is a sample of my routers as they are configured now.

!PARTIAL CONFIG FROM THE 7200

interface Serial5/1

ip unnumbered GigabitEthernet6/0

!

interface Serial5/2

no ip address

shutdown

!

interface GigabitEthernet6/0

ip address 192.168.1.1 255.255.255.0

!

!PARTIAL CONFIG FROM THE 2621

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.0

no ip redirects

no ip directed-broadcast

!

interface Serial0/0

ip unnumbered FastEthernet0/0

no ip directed-broadcast

no ip mroute-cache

no fair-queue

1 Accepted Solution

Accepted Solutions

wkumari
Level 1
Level 1

If you can live wuth statics, there is a fiarly cool trick that lets to do ratio based unequal cost LB.

On each device make 3 loopback addresses, and then point statics at those loopback addresses, 1 up your small link and 2 up your larger link. Now create 3 staitcs and point each at one of the 3 IPs. This will give you a 2:1 ratio.

Eg:

On 7200:

int lo 1

ip addr 10.0.72.1 255.255.255.255

int lo2

ip addr 10.0.72.2 255.255.255.255

int lo3

ip addr 10.0.72.3 255.255.255.255

On 2621:

ip route 10.0.72.1 255.255.255.255

ip route 10.0.72.2 255.255.255.255

ip route 10.0.72.3 255.255.255.255

ip route 0.0.0.0 0.0.0.0 10.0.72.1

ip route 0.0.0.0 0.0.0.0 10.0.72.2

ip route 0.0.0.0 0.0.0.0 10.0.72.3

Depending on your traffic flows you are probably doing to have to do some form of per-packet loadbalancing too.

You *may* want to just use the full T1 as a primary and the Frac as a backup. Much simpler....

You could also do EIGRP which will do unequal LB by itself, but....

View solution in original post

2 Replies 2

wkumari
Level 1
Level 1

If you can live wuth statics, there is a fiarly cool trick that lets to do ratio based unequal cost LB.

On each device make 3 loopback addresses, and then point statics at those loopback addresses, 1 up your small link and 2 up your larger link. Now create 3 staitcs and point each at one of the 3 IPs. This will give you a 2:1 ratio.

Eg:

On 7200:

int lo 1

ip addr 10.0.72.1 255.255.255.255

int lo2

ip addr 10.0.72.2 255.255.255.255

int lo3

ip addr 10.0.72.3 255.255.255.255

On 2621:

ip route 10.0.72.1 255.255.255.255

ip route 10.0.72.2 255.255.255.255

ip route 10.0.72.3 255.255.255.255

ip route 0.0.0.0 0.0.0.0 10.0.72.1

ip route 0.0.0.0 0.0.0.0 10.0.72.2

ip route 0.0.0.0 0.0.0.0 10.0.72.3

Depending on your traffic flows you are probably doing to have to do some form of per-packet loadbalancing too.

You *may* want to just use the full T1 as a primary and the Frac as a backup. Much simpler....

You could also do EIGRP which will do unequal LB by itself, but....

Thank you Warren. I was looking for a temporary solution and this looks like a simple way to do what I need. I really do appreciate your help with this.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Innovations in Cisco Full Stack Observability - A new webinar from Cisco