cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
191
Views
10
Helpful
4
Replies
Highlighted
Participant

BGP and Static Route error

Hi all ,

I have two private networks.Each network use eBGP to peer with ISP PE router.

I got the below error.

if i  advertise my LAN network in bgp table , the LAN network can reach the each others.

Branch1

router bgp 65200
bgp log-neighbor-changes
network 1.1.1.0 mask 255.255.255.0 <= LAN
neighbor 1.1.12.2 remote-as 200

 

Branch2

router bgp 65300
bgp log-neighbor-changes
network 2.2.2.0 mask 255.255.255.0 <= LAN
neighbor 1.1.2.1 remote-as 200

 

If i didn't advertise LAN network and i use static route ,LAN networks cannot reach each other.Let me know it is my error or ISP block my network ? because i have less knowledge in BGP.So i don't know BGP can carry static route. 

Branch1

router bgp 65200
bgp log-neighbor-changes
neighbor 1.1.12.2 remote-as 200

ip route 2.2.2.0 255.255.255.0 1.1.12.2 

 

Branch2

router bgp 65300
bgp log-neighbor-changes
neighbor 1.1.2.1 remote-as 200

ip route 1.1.1.0 255.255.255.0 1.1.2.1

 

 

 

Everyone's tags (1)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Guru

Re: BGP and Static Route error

 

When you advertise with BGP you are exchanging routing information with your ISP so they know how to reach your subnets. 

 

When you use static routes your ISP has no idea how to reach those subnets unless you redistribute your static routes into BGP. 

 

Note the above assumes your branch routers peer with ISP and not directly to each other. 

 

Jon

Participant

Re: BGP and Static Route error

Hi All,

Thank for your help. Now i can solve my issue.I am using tunnel and source is lookback interface.

Everyone's tags (1)
4 REPLIES 4
Hall of Fame Guru

Re: BGP and Static Route error

 

When you advertise with BGP you are exchanging routing information with your ISP so they know how to reach your subnets. 

 

When you use static routes your ISP has no idea how to reach those subnets unless you redistribute your static routes into BGP. 

 

Note the above assumes your branch routers peer with ISP and not directly to each other. 

 

Jon

VIP Advisor

Re: BGP and Static Route error

what is the need for the Static route ? when you have Dynamic eBGP available ? what is the use case.

 

dynamic routing protocol used by your provider, it expect to be dynamic anouncements.

 

BB
*** Rate All Helpful Responses ***
Participant

Re: BGP and Static Route error

Hi,

Thank for your help . 

I need static route for branches 2 site only because this site run DMVPN (verlay is EIGRP) with the rest branches 3,4,5....So i cannot advertise LAN network in bgp table. Branch1 cannot support DMVPN so i use bgp only. Those are my problem.if i use GRE tunnel ,it can be overcome ? 

 

Everyone's tags (1)
Participant

Re: BGP and Static Route error

Hi All,

Thank for your help. Now i can solve my issue.I am using tunnel and source is lookback interface.

Everyone's tags (1)
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards