07-06-2018 08:51 AM - edited 03-05-2019 10:43 AM
Hi we have a multihome BGP scenario with the following config:
Local router:
interface to Primary ISP A 1.1.1.2 mask 255.255.255.248
interface to Backup ISP B 2.2.2.2 mask 255.255.255.252
ISP A 1.1.1.1 mask 255.255.255.248
ISP B 2.2.2.1 mask 255.255.255.252
BGP Config local router:
router bgp 2222
network 1.1.1.0 mask 255.255.255.248
network 3.3.3.0 mask 255.255.255.0
network 2.2.2.0 mask 255.255.255.252
neighbor 1.1.1.1 remote-as 1111
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 weight 100
neighbor 2.2.2.1 remote-as 4444
neighbor 2.2.2.1 route-map prepend out
ip prefix-list MATCHALL seq 10 permit 0.0.0.0/0 le 32
!
route-map prepend permit 10
match ip address prefix-list MATCHALL
set as-path prepend 2222 2222
!
route-map prepend permit 20
My questions:
- Do ISP's filter advertised networks that are smaller then /24? Is there a risk becoming a transit AS?
- Should the above config be enough to allow outgoing (Weight 100) and returning traffic (AS prepend) to come in through ISP A? If not what can be done to have all traffic pass through ISP A only (ISP B should be backup)?
Solved! Go to Solution.
07-07-2018 09:07 AM
>The weight attribute is sufficient...
is't not correct
weight or local reference we use for outgoing traffic
as-prepend for incoming
But you cannot grantie what all incoming traffic will only go through R1 or R2.
You can only increase probability of that.
07-06-2018 08:08 PM
07-07-2018 04:58 AM
Hello,
if you don't want your AS to become a transit AS, ypu can use an as-path filter or the no-export community:
ip as-path access-list 1 permit ^$
!
neighbor 1.1.1.1 filter-list 1 out
neighbor 2.2.2.1 filter-list 1 out
route-map NO-EXPORT
set community no-export
!
neighbor 1.1.1.1 route-map NO-EXPORT in
neighbor 2.2.2.1 route-map NO-EXPORT in
Also, you don't need the as-path prepending to make the link to neighbor 1.1.1.1 the preferred one. The weight attribute is sufficient...
07-07-2018 09:07 AM
>The weight attribute is sufficient...
is't not correct
weight or local reference we use for outgoing traffic
as-prepend for incoming
But you cannot grantie what all incoming traffic will only go through R1 or R2.
You can only increase probability of that.
07-07-2018 09:17 AM
You are very right...I missed the inbound part...:(
Thinking about it again, since you are paying for your second ISP link, why leave it idle and for backup only ? Unless that is a hard requirement, why not implement load balancing ?
07-11-2018 08:48 AM
Thanks all. Is there a way to verify if your AS has become a transit AS?
07-13-2018 07:42 AM
07-14-2018 10:39 AM
Thanks but i meant how can you verify live traffic that's transiting through your AS. I've been told in some cases the ISP does block AS advertisements that are not coming locally from the customers router. I think the command you recommend only tells you what is advertised out but I doubt if it will tell you if your ISP blocks it or not.
07-14-2018 12:29 PM
07-15-2018 08:41 AM - edited 07-15-2018 08:43 AM
THank you. Not sure how to give you credit for this since this is not directly related to my original questions but your responses are very helpful.
Does it matter how many times you prepand in as path prepending? If you prepend your AS more times (let's say 5x times) would that inrease the probability of returing through the primary ISP more? And is there a limit as to how many times you could prepend?
Thanks again.
07-15-2018 07:19 PM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide