cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
10879
Views
2
Helpful
6
Replies

BGP on ASR 9001 6.5.3

old&bald
Level 1
Level 1

Good day,

Trying to raise BGP on ASR 9001 config is as follows

 

RP/0/RSP0/CPU0:asr9k-01#show running-config
Thu Aug 15 13:35:04.107 Baku
Building configuration...
!! IOS XR Configuration 6.5.3
!! Last configuration change at Wed Aug 14 18:06:49 2019
!
hostname asr9k-01
logging 192.168.255.240 vrf Mgmt-vrf
domain name asr9k-01
telnet vrf Mgmt-vrf ipv4 server max-servers 5
!
vrf SRVC
address-family ipv4 unicast
!
!
vrf Mgmt-vrf
!
address-family ipv4 unicast
!
line template SSH-Template
exec-timeout 0 0
transport input ssh
!
vty-pool default 0 99 line-template SSH-Template
srlg
!
ntp
server vrf SRVC 9.9.9.3 source Bundle-Ether101.40
!
alias cm commit
alias ct configure terminal
alias sr show running-config
alias srb show running-config | begin
alias sre show running-config | exclude
alias sri show running-config | include
alias srint show running-config interface
interface Bundle-Ether101
description titanium-po-101
!
interface Bundle-Ether101.34
vrf SRVC
ipv4 address 172.16.255.110 255.255.240.0
encapsulation dot1q 34
!
interface Bundle-Ether101.40
vrf SRVC
ipv4 address 9.9.9.11 255.255.255.240
encapsulation dot1q 40
!
interface Loopback4
description bgp-peering
vrf SRVC
ipv4 address 192.168.255.21 255.255.255.0
!
interface MgmtEth0/RSP0/CPU0/0
vrf Mgmt-vrf
ipv4 address 192.168.255.21 255.255.255.0
!
interface MgmtEth0/RSP0/CPU0/1
shutdown
!
interface TenGigE0/0/2/0
description sw-Te1/0/1
bundle id 101 mode on
!
interface TenGigE0/0/2/1
description sw-Te1/0/2
bundle id 101 mode on
shutdown
!
interface TenGigE0/0/2/2
description sw-Te1/0/3
shutdown
!
interface TenGigE0/0/2/3
description sw-Te1/0/4
shutdown
!
router static
vrf SRVC
address-family ipv4 unicast
0.0.0.0/0 172.16.255.254
!
!
vrf Mgmt-vrf
address-family ipv4 unicast
0.0.0.0/0 192.168.255.254
!
!
!
router ospf 12345
vrf SRVC
log adjacency changes
router-id 9.9.9.33
address-family ipv4
area 0
interface Bundle-Ether101.40
network broadcast
!
interface Loopback4
network broadcast
passive enable
!
!
!
!
router bgp 12345
address-family ipv4 unicast
!
vrf SRVC
bgp log neighbor changes disable
bgp redistribute-internal
neighbor 9.9.9.31
remote-as 12345
description Core
update-source Loopback4
!
!
!
ssh server enable cipher aes-cbc
ssh timeout 30
ssh server v2
ssh server vrf SRVC
ssh server vrf Mgmt-vrf
end

 

Now, when I try to commit address-family ipv4 unicast under bgp vrf get the error 'The parent address family has not been initialized'Found here that address-family must be first set on BGP globally but it didn't solve the problem.

 

RP/0/RSP0/CPU0:asr9k-01#configure terminal
Thu Aug 15 14:10:07.442 Baku
RP/0/RSP0/CPU0:asr9k-01(config)#router bgp 12345
RP/0/RSP0/CPU0:asr9k-01(config-bgp)# vrf SRVC
RP/0/RSP0/CPU0:asr9k-01(config-bgp-vrf)# address-family ipv4 unicast
RP/0/RSP0/CPU0:asr9k-01(config-bgp-vrf-af)#commit
Thu Aug 15 14:11:13.818 Baku

% Failed to commit one or more configuration items during a pseudo-atomic operation. All changes made have been reverted. Please issue 'show configuration failed [inheritance]' from this session to view the errors
RP/0/RSP0/CPU0:asr9k-01(config-bgp-vrf-af)#show configuration failed
Thu Aug 15 14:11:21.212 Baku
!! SEMANTIC ERRORS: This configuration was rejected by
!! the system due to semantic errors. The individual
!! errors with each failed configuration command can be
!! found below.


router bgp 12345
vrf SRVC
address-family ipv4 unicast
!!% 'BGP' detected the 'warning' condition 'The parent address family has not been initialized'
!
!
!
end

RP/0/RSP0/CPU0:asr9k-01(config-bgp-vrf-af)#

 

 

Have I missed smth else in config?

1 Accepted Solution

Accepted Solutions

Hello,

if this router is not in production I would suggest two possible actions to see if you can solve the commit error problem.

a) as far as I can see there is no interface in vrf default GRT Global Routing Table . Define a loopback50 with a dummy private IP address in global routing table. This can be used by the router as BGP router-id at router bgp address-family ipv4 unicast level.

 

b) if above is not enough try to move all vrf related configuration to global configuration level.

 

I have only one doubt about licensing.

I remember I have installed  ASR 9001 with L2VPN license only that were not able to support L3 VPN (without adding another license).

Check your licenses to see if you can use VRFs L3VPN on this specific router.

 

Hope to help

Giuseppe

 

View solution in original post

6 Replies 6

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello old&bald,

as mentioned under the thread that you have reported the parent AF for IOS XR is

address-family vpnv4 unicast

 

in the answer it is written that you need to configure it before you are able to commit VRF related configurations.

 

So try the following

router bgp 12345

address-family vpnv4 unicast

 

commit

 

Then try to add again the configuration for vrf SRVC and then try to commit again.

 

By the way, why your Core routing is under a VRF ?

 

Hope to help

Giuseppe

 

Just did it the way as was explained, and even reloaded the router.

So, this is already a part of the config.

 

router bgp 12345

address-family vpnv4 unicast

 

Regarding Core VRF, router is not in production yet, and this model is just playing around.

 

Thanks,

Hello,

if this router is not in production I would suggest two possible actions to see if you can solve the commit error problem.

a) as far as I can see there is no interface in vrf default GRT Global Routing Table . Define a loopback50 with a dummy private IP address in global routing table. This can be used by the router as BGP router-id at router bgp address-family ipv4 unicast level.

 

b) if above is not enough try to move all vrf related configuration to global configuration level.

 

I have only one doubt about licensing.

I remember I have installed  ASR 9001 with L2VPN license only that were not able to support L3 VPN (without adding another license).

Check your licenses to see if you can use VRFs L3VPN on this specific router.

 

Hope to help

Giuseppe

 

Thanks for reply Giuseppe,

 

Creating an additional Loopback didn't help. However moving all config to global did the job. Regarding licensing, this router has only one BNG license installed, so probably you're right and this is a license issue.

 

Thank you very much for your time.

Hello old&bald,

good news that at least moving everything in GRT it works now.

I don't know if the BNG license includes VRF support.

However, the error message is misleading: it should tell you if it is a licensing issue.

It should be in Cisco's interest to make you know you need to buy an additional license.

 

Best Regards

Giuseppe

 

It is really strange as OSPF under same VRF worked fine.

Router is under SNT, so will raise a ticket to ask Cisco themselves.

Review Cisco Networking for a $25 gift card