04-05-2011 01:09 PM - edited 03-04-2019 11:59 AM
Hello,
I’d like to put a bit bucket into the routers. I think i can save bandwidth and security things by dropping any rubbish.
ON ROUTERS WITHOUT STATIC REDISTRIBUTION
int Null0
exit
ip route 0.0.0.0 0.0.0.0 NUll0
ON ROUTERS WITH STATIC REDISTRIBUTION
int Null0
exit
access-list 99 deny 0.0.0.0 255.255.255.255
access-list 99 permit <IP SUBNET> <INVERSE MASK> of route
route-map NULL-ROUTE permit 10
match ip address 99
router ospf 1
redistribute static subnets route-map NULL-ROUTE
ip route 0.0.0.0 0.0.0.0 NUll0
Anyone done this before and have any experience i can draw on.
regards
Kevin
Solved! Go to Solution.
04-05-2011 01:26 PM
On the first example, you don't need to create a Null0 interface in order to drop packets with the static route.
Are you planning to drop the packets that are destined for the internet? I'm assuming you will have more specific subnets in your routing table.
On the second example, the ACL 99 is not going to process the 2nd line since the first line will simply deny any subnets. I'm not sure the intent of this ACL.
If you are looking to block the default from being redistributed into OSPF, do the following:
ip prefix-list Quad0 permit 0.0.0.0/0
route-map NULL0 deny 5
match ip prefix-list Quad0
!
route-map NULL0 permit 10
!
Regards,
04-05-2011 01:26 PM
On the first example, you don't need to create a Null0 interface in order to drop packets with the static route.
Are you planning to drop the packets that are destined for the internet? I'm assuming you will have more specific subnets in your routing table.
On the second example, the ACL 99 is not going to process the 2nd line since the first line will simply deny any subnets. I'm not sure the intent of this ACL.
If you are looking to block the default from being redistributed into OSPF, do the following:
ip prefix-list Quad0 permit 0.0.0.0/0
route-map NULL0 deny 5
match ip prefix-list Quad0
!
route-map NULL0 permit 10
!
Regards,
04-06-2011 04:23 AM
I dont want to drop packets destined for the internet so i'll be careful with that one.
I think i'll give this one a go.
ip prefix-list Quad0 permit 0.0.0.0/0
route-map NULL0 deny 5
match ip prefix-list Quad0
!
route-map NULL0 permit 10
!
thanks,
kevin
04-06-2011 06:16 AM
Reviewing your route-map once again, it really won't do much as you can't redistribute the Quad0 into OSPF.
OSPF will only originate a Quad0 by using the command 'default-information originate' (if the Quad0 is in the RIB) or 'default-information originate always' (if you want to originate the Quad0 when not in RIB).
If this router is being used to take you into the internet, a default static route pointing to Null0 will drop all packets.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide