07-27-2022 12:43 AM - last edited on 07-27-2022 10:31 PM by Translator
Hello,
sorry in advance not good at explaining...
im trying to make Triangle with 3 Nexus and configure the routing with ISIS.
i configured the Interfaces, i put them in the ISIS routing and a
Loopback0
has been configured aswell. Now im trying to figure out how to ping the lo0 from every Nexus, in which i have not been very succsessful.
here is my running config of my Nexus1:
vdc switch id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource vrf minimum 2 maximum 4096
limit-resource port-channel minimum 0 maximum 511
limit-resource u4route-mem minimum 248 maximum 248
limit-resource u6route-mem minimum 96 maximum 96
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
feature isis
feature fabric forwarding
feature interface-vlan
no password strength-check
username admin password 5 $5$GPBDGP$vDNYedLi0c0Mb1xBFHjl058tpKC62aBZg6UDT2kY9c7
role network-admin
ip domain-lookup
snmp-server user admin network-admin auth md5 0x341fed45ad536d993b37a4b9063a9075
priv 0x341fed45ad536d993b37a4b9063a9075 localizedkey
rmon event 1 description FATAL(1) owner PMON@FATAL
rmon event 2 description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 description ERROR(3) owner PMON@ERROR
rmon event 4 description WARNING(4) owner PMON@WARNING
rmon event 5 description INFORMATION(5) owner PMON@INFO
fabric forwarding anycast-gateway-mac 0000.0011.1234
vlan 1,10
vrf context management
interface Vlan1
interface Vlan10
ip address 10.10.1.254/24
fabric forwarding mode anycast-gateway
interface Ethernet1/1
no switchport
ip address 192.168.1.1/24
ip router isis start
no shutdown
interface Ethernet1/2
interface Ethernet1/3
no switchport
ip address 192.168.3.1/24
ip router isis start
no shutdown
interface Ethernet1/4
interface Ethernet1/5
interface Ethernet1/6
interface Ethernet1/127
interface Ethernet1/128
interface mgmt0
vrf member management
interface loopback0
ip address 10.10.1.1/24
ip router isis start
line console
line vty
no feature signature-verification
router isis start
net 11.1111.1111.1111.1111.00
is-type level-2
running conf Nexus2:
vdc switch id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource vrf minimum 2 maximum 4096
limit-resource port-channel minimum 0 maximum 511
limit-resource u4route-mem minimum 248 maximum 248
limit-resource u6route-mem minimum 96 maximum 96
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
feature isis
feature fabric forwarding
feature interface-vlan
no password strength-check
username admin password 5 $5$PMGKJI$DUhhTtdmjzzV.yVbme2dCjMYgDUszWoVsrg8kr/Nr55
role network-admin
ip domain-lookup
snmp-server user admin network-admin auth md5 0x63349cf0c495fb87a54fa406cc72772c
priv 0x63349cf0c495fb87a54fa406cc72772c localizedkey
rmon event 1 description FATAL(1) owner PMON@FATAL
rmon event 2 description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 description ERROR(3) owner PMON@ERROR
rmon event 4 description WARNING(4) owner PMON@WARNING
rmon event 5 description INFORMATION(5) owner PMON@INFO
fabric forwarding anycast-gateway-mac 0000.0011.1234
vlan 1,10
vrf context management
interface Vlan1
interface Vlan10
ip address 10.10.1.254/24
fabric forwarding mode anycast-gateway
interface Ethernet1/1
no switchport
ip address 192.168.1.2/24
ip router isis start
no shutdown
interface Ethernet1/2
no switchport
ip address 192.168.2.2/24
ip router isis start
no shutdown
interface Ethernet1/3
interface Ethernet1/4
interface Ethernet1/5
interface Ethernet1/127
interface Ethernet1/128
interface mgmt0
vrf member management
interface loopback0
ip address 10.10.1.2/24
ip router isis start
line console
line vty
no feature signature-verification
router isis start
net 11.1111.2222.2222.2222.00
is-type level-2
and at last Nexus3:
vdc switch id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource vrf minimum 2 maximum 4096
limit-resource port-channel minimum 0 maximum 511
limit-resource u4route-mem minimum 248 maximum 248
limit-resource u6route-mem minimum 96 maximum 96
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
feature isis
feature fabric forwarding
feature interface-vlan
no password strength-check
username admin password 5 $5$ADNDEK$gXHBz8zOEvc7N4h/21RiAZQEhKliswr1IZzaZWQvw76
role network-admin
ip domain-lookup
snmp-server user admin network-admin auth md5 0x31ce570d62d1af6d55ea6ce7c54c23e4
priv 0x31ce570d62d1af6d55ea6ce7c54c23e4 localizedkey
rmon event 1 description FATAL(1) owner PMON@FATAL
rmon event 2 description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 description ERROR(3) owner PMON@ERROR
rmon event 4 description WARNING(4) owner PMON@WARNING
rmon event 5 description INFORMATION(5) owner PMON@INFO
fabric forwarding anycast-gateway-mac 0000.0011.1234
vlan 1,10
vrf context management
interface Vlan1
interface Vlan10
ip address 10.10.1.254/24
fabric forwarding mode anycast-gateway
interface Ethernet1/1
interface Ethernet1/2
no switchport
ip address 192.168.2.3/24
ip router isis start
no shutdown
interface Ethernet1/3
no switchport
ip address 192.168.3.3/24
ip router isis start
no shutdown
interface Ethernet1/4
interface Ethernet1/5
interface Ethernet1/127
interface Ethernet1/128
interface mgmt0
vrf member management
interface loopback0
ip address 10.10.1.3/24
ip router isis start
line console
line vty
no feature signature-verification
router isis start
net 11.1111.3333.3333.3333.00
is-type level-2
could somebody explain to me what im missing?
thanks in advance
Solved! Go to Solution.
07-27-2022 02:26 AM
Hello,
I think the problem is that all your loopbacks are in the same subnet. I recreated your setup in a lab, and as soon as I used different subnets for the loopbacks (10.10.1.0/24, 10.10.2.0/24, 10.10.3.0/24) everything was reachable...
07-27-2022 02:56 AM - last edited on 07-27-2022 10:29 PM by Translator
Hello,
your configs are fine. Just change the
loopback IP addresses
on the Nexus2 and Nexus3 switches:
Nexus2
interface loopback0
ip address 10.10.2.2/24
ip router isis start
Nexus3
interface loopback0
ip address 10.10.3.3/24
ip router isis start
07-27-2022 01:07 AM - last edited on 07-27-2022 10:23 PM by Translator
Hello,
it used to be that in order to annouce loopback interfaces, all you need was to make them passive under the ISIS process, not sure if that is still the same in NX-OS...
interface loopback0
ip address 10.10.1.1/24
--> no ip router isis start
line console
line vty
no feature signature-verification
router isis start
net 11.1111.1111.1111.1111.00
is-type level-2
--> passive-interface Loopback0
07-27-2022 01:18 AM - last edited on 07-27-2022 10:25 PM by Translator
hey, thank you
unfortunatly im not able to make
Loopback0 as a passive-interface
it just says its an invalid command...
07-27-2022 01:51 AM
Hello,
I am going to lab this up...looks like the NX-OS implementation is different...
07-27-2022 02:26 AM
Hello,
I think the problem is that all your loopbacks are in the same subnet. I recreated your setup in a lab, and as soon as I used different subnets for the loopbacks (10.10.1.0/24, 10.10.2.0/24, 10.10.3.0/24) everything was reachable...
07-27-2022 02:42 AM
hey,
im sorry i think i got a huge messup in my config... could you show me your config?
07-27-2022 02:56 AM - last edited on 07-27-2022 10:29 PM by Translator
Hello,
your configs are fine. Just change the
loopback IP addresses
on the Nexus2 and Nexus3 switches:
Nexus2
interface loopback0
ip address 10.10.2.2/24
ip router isis start
Nexus3
interface loopback0
ip address 10.10.3.3/24
ip router isis start
07-27-2022 03:02 AM
oh my yes thank you i have been trying this since yesterday...
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide