cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
326
Views
0
Helpful
10
Replies
Highlighted
Beginner

Cannot connect from inside interface to the Internet.

Hello,

I have a Cisco ASA5505 with an inside Vlan1 and an outside Vlan2.

The outside interface has the address 10.0.0.2 and my router (an Orange 'LiveBox')

has the address 10.0.0.1 connected with an Ethernet cable.

The inside interface has DHCP from 192.168.1.40 to 192.168.1.80 and the ASA has the static IP 192.168.1.5.

The inside addresses are distributed correctly to my LAN and my laptop receives 192.168.1.40 as his IP.

But I cannot acces the internet from any device that is connected to the inside interface.

I've tried to activate or deactivate PAT with the Wizard, various combinations of settings without luck.

Trying to add routes from inside to outside gives an error, 'Route already exists'.

It might not be a DNS problem as even trying to ssh to a direct Public IP doesn't work either.

I've tried many tutorials but I ran out of ideas.

Anyone?

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Cannot connect from inside interface to the Internet.

I managed to get Internet connectivity by using the DHCP of the Livebox to give an address to the outside interface instead of attributing a static one..

These Livebox are just simple Sagem routers customized and throttled by Orange, so who knows what was going on inside.

Anyway thanks a lot for your time.

10 REPLIES 10
VIP Mentor

Re: Cannot connect from inside interface to the Internet.

Hello,

 

unless the LiveBox is in bridge mode, the NAT is most likely being done on the LiveBox, that is where you will have to add network 192.168.1.0/24 to be included in the networks to be translated...

Beginner

Re: Cannot connect from inside interface to the Internet.

Thank you for your reply.

I have no idea how to achieve this..

The NAT section of the LiveBox looks like the screencap I posted.

Can it be done in the ASA?

Participant

Re: Cannot connect from inside interface to the Internet.

That Screen Cap appears to be static nat for inbound services, try and use the live box without the ASA to see what addresses you are natting to.
It would be best if you can enable bridge mode as Georg said, not sure if it is possible on that box but likley somewhere in the settings.
Beginner

Re: Cannot connect from inside interface to the Internet.

Thank you for your answer.
I am sorry I have no idea about what you mean..

I thought my setup was about the simplest setup you can think of.

I cannot understand how the wizard would not allow this very basic connectivity..

Participant

Re: Cannot connect from inside interface to the Internet.

Looking at the docs around Livebox it doesnt look like it supports bridge mode, if you post your configs of the ASA that will help seeing what you are doing.
Beginner

Re: Cannot connect from inside interface to the Internet.

Sure, thank you.

Result of the command: "show running-config"

: Saved
:
: Serial Number: JMX2128YXXX
: Hardware: ASA5505, 512 MB RAM, CPU Geode 500 MHz
:
ASA Version 9.1(6)
!
hostname ciscoasa
enable password N7FecZuSHxxxVZC2P encrypted
names
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.5 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 10.0.0.2 255.255.255.0
!
ftp mode passive
dns domain-lookup outside
dns domain-lookup inside
dns server-group DefaultDNS
name-server 10.0.0.1
name-server 8.8.8.8
same-security-traffic permit intra-interface
object network obj_any
subnet 0.0.0.0 0.0.0.0
object network LiveBox
host 10.0.0.1
description LiveBox
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
no arp permit-nonconnected
nat (inside,outside) source static any any inactive
!
object network obj_any
nat (inside,outside) dynamic interface
!
nat (inside,outside) after-auto source dynamic any interface
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ipsec security-association pmtu-aging infinite
crypto ca trustpool policy
telnet timeout 5
no ssh stricthostkeycheck
ssh timeout 5
ssh key-exchange group dh-group1-sha1
console timeout 0

dhcpd dns 10.0.0.1 8.8.8.8
dhcpd lease 10800
!
dhcpd dns 8.8.8.8 interface outside
!
dhcpd address 192.168.1.40-192.168.1.80 inside
dhcpd dns 10.0.0.1 interface inside
dhcpd auto_config outside interface inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum client auto
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:2699024f7c371cfc2e4b2164996a375f
: end

Participant

Re: Cannot connect from inside interface to the Internet.

The Nat rule is in place for the inside to outside translation, although you may want to specify the specific subnet in the object to make it clearer for yourself,
i cannot see the default route via the live box, something like will need to be added
route outside 0.0.0.0 0.0.0.0 10.0.0.1
Beginner

Re: Cannot connect from inside interface to the Internet.

I managed to get Internet connectivity by using the DHCP of the Livebox to give an address to the outside interface instead of attributing a static one..

These Livebox are just simple Sagem routers customized and throttled by Orange, so who knows what was going on inside.

Anyway thanks a lot for your time.

VIP Mentor

Re: Cannot connect from inside interface to the Internet.

Hello,

 

just for my understanding, which IP address did the LiveBox assign to the outside interface ? 

Participant

Re: Cannot connect from inside interface to the Internet.

I would also like to know, a GW has been created on the back of DHCP it seems
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards