08-20-2013 10:42 PM - edited 03-04-2019 08:49 PM
Hi,
I have two broadband connections from different internet service providers and I dont have a static ip.
I thought to use cisco 1841 for these connections because Cisco 1841 has two wan ports.
If anyone knows how to configure this with 1841 ( I have username and password for both connection) please help me
just try to give me sample configuration.
thank you
08-21-2013 02:40 AM
interface FastEthernet0/0
no ip address
pppoe enable
pppoe-client dial-pool-number 1
this links to dialer interface
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1414
no ip mroute-cache
dialer pool 1
dialer idle-timeout 0
dialer-group 1
ppp authentication pap callin
ppp chap hostname abc
ppp chap password def
ppp chap refuse
!
ip route 0.0.0.0 0.0.0.0 Dialer0
on internal interface
int f0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
ip nat inside source list 101 interface Dialer0 overload
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
***Do Rate Helpful Posts***
HTH
Jawad
08-21-2013 02:42 AM
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1414
Incorrect, should be 1452.
dialer idle-timeout 0
ppp chap refuse
These commands are not needed.
08-21-2013 08:39 PM
Hi,
Thank you for your answer.
this is only for a single port I need to use the both WAN ports with two different connections is this is possible? I have a HWIC card with my router so I hope to out the both connections via the HWIC is it possible?
If yes please help me
08-22-2013 11:04 AM
track 1 interface Dialer0 ip routing
delay up 30
!
track 2 interface Dialer1 ip routing
delay up 30
!
ip route 0.0.0.0 0.0.0.0 Dialer0 track 1
ip route 0.0.0.0 0.0.0.0 Dialer1 track 2
ip nat inside source list 101 interface Dialer0 overload
ip nat inside source list 101 interface Dialer1 overload
*** Do Rate Helpful Posts ***
Jawad
09-02-2013 04:30 AM
Hi,
thanks for your reply again
I tried use both pppoe connections.
If I use this configuration is the dialer 2 interface works as a failover?
is this configuration is correct?
if any thing wrong please help me.
Router(config)#int vlan 1
Router(config-if)#ip add
Router(config-if)#ip address 192.168.100.5 255.255.255.0
Router(config-if)#int dialer 1
Router(config-if)#mtu
Router(config-if)#mtu 1492
Router(config-if)#ip address negotiated
Router(config-if)#ip nat
Router(config-if)#ip nat ou
Router(config-if)#ip nat outside
Router(config-if)#ip virtual-reassembly
Router(config-if)#encapsulation ppp
Router(config-if)#ip tcp ad
Router(config-if)#ip tcp adjust-mss 1412
Router(config-if)#dialer pool 1
Router(config-if)#dialer-group 1
Router(config-if)#ppp authentication chap callin
Router(config-if)#ppp pap sent-username username1 password 0 123456
Router(config-if)#exit
Router(config)#int dialer 2
Router(config-if)#mtu 1492
Router(config-if)#ip address negotiated
Router(config-if)#ip nat outside
Router(config-if)#ip virtual-reassembly
Router(config-if)#encapsulation ppp
Router(config-if)#ip tcp adjust-mss 1412
Router(config-if)#dialer pool 2
Router(config-if)#dialer-group 2
Router(config-if)#ppp authentication chap callin
Router(config-if)#ppp pap sent-username username2 password 0 123456
Router(config-if)#exit
Router(config)#int fastEthernet 0/1
Router(config-if)#pppoe enable
Router(config-if)#pppoe-client dial-pool-number 1
Router(config)#int fastEthernet 0/0
Router(config-if)#pppoe enable
Router(config-if)#pppoe-client dial-pool-number 2
Router(config)#ip dhcp pool test
Router(dhcp-config)#network 192.168.100.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.100.5
Router(dhcp-config)#dns-server 119.235.0.4 203.81.108.4
Router(config)#ip dhcp excluded-address 192.168.100.0.1 192.168.100.20
Router(config)#ip classless
Router(config)#ip route 0.0.0.0 0.0.0.0 dialer 1
Router(config)#ip route 0.0.0.0 0.0.0.0 dialer 2 100
Router(config)#access-list 101 permit ip 192.168.100.0 0.0.0.255 any
Router(config)#ip nat inside source list 101 interface dialer 1 overload
Router(config)#ip nat inside source list 101 interface dialer 2 overload
09-02-2013 09:11 AM
Hi,
1)
For NAT overload on 2 WAN connections you need to use route-maps :
route-map DIALER1
match ip add 101
match interface dialer 1
route-map DIALER2
match ip add 101
match int dialer 2
ip nat inside source route-map DIALER1 interface dialer 1
ip nat inside source route-map DIALER2 interface dialer 2
2) the the TCP MSS can be up to MTU-40 so here 1452
3) you are doing CHAP authentication but are providing PAP credentials,you should provide CHAP credentials with the ppp chap hostname and ppp chap password commands
Regards
Alain
Don't forget to rate helpful posts.
09-02-2013 11:40 PM
Hi,
Thanks a lot for your reply.
So the remain commands are correct right?
I need only chnge in NAT overload right?
09-16-2013 04:52 AM
Hi thanks for your help,
One more thing I have to ask,
Is failover will work with this configurations? because that's why I placed two different static routes with different AD.
if not help me to config a failover with this 1841 router....
please help me
09-17-2013 01:16 AM
Hi,
yes failover will work.
Regards
Alain
Don't forget to rate helpful posts.
09-18-2013 01:45 AM
Hi,
Thanks for your replay.
I will try this and let you know
Thanks again.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide