cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
700
Views
10
Helpful
4
Replies
Deepak Kumar
VIP Advocate

Cisco CSR1000v router DHCP binding

Dear All, 

Using CSR1000v as DHCP server with version 15.5(3)S2. My DHCP client is not sending Option 61, so I must use the Hardware address command for static binding IP for a client.  But it is strange that a "Hardware-address" command will remove automatically after 24 hrs. from the DHCP pool. 

It is very strange for me. Are you aware of any kind of such bug or issue?

 

ip dhcp pool bac
host x.x.x.x 255.255.255.0
dns-server y.y.y.y
default-router z.z.z.z
hardware-address xxxx.xxxx.xxxx  <<- This command will remove automatically. 

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!
1 ACCEPTED SOLUTION

Accepted Solutions
Deepak Kumar
VIP Advocate

Thanks, everyone, 

Can't use the client-identifier command because my DHCP client is not sending Option 61 so I have some limitations. I changed the lease time to infinite and the issue disappears. I know it is a workaround only.

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!

View solution in original post

4 REPLIES 4
balaji.bandi
VIP Master

is this for Lab or real environment, I do not remember exactly, I do come across some DHCP Options issues.  but going to the latest version CSR1000v fixed the issue of mine, worth trying.

BB

***** Rate All Helpful Responses *****

How to Ask The Community for Help

paul driver
VIP Mentor

Hello

Are you excluding the static host from the dhcp pool?

Also try using client-identifier 01xx:xxxx:xxxx:xx instead!



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Deepak Kumar
VIP Advocate

Thanks, everyone, 

Can't use the client-identifier command because my DHCP client is not sending Option 61 so I have some limitations. I changed the lease time to infinite and the issue disappears. I know it is a workaround only.

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!

View solution in original post

Hello,

 

as far as I recall, 24 hours is the default in all IOS versions...