cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1043
Views
0
Helpful
2
Replies

Cisco ISR 1111-8PLTEEA modem problem.

p.nordlien
Level 1
Level 1

Hi All.

I have a C1111-8PLTEEA running Version 16.10.1b. It doesn't seem to have any info on the LTE modem. When I issue 'show cellular 0/2/0 hardware' i get this output:

Modem Firmware Version =
Device Model ID =
Package Identifier ID =
International Mobile Subscriber Identity (IMSI) =
International Mobile Equipment Identity (IMEI) =
Integrated Circuit Card ID (ICCID) =
Mobile Subscriber Integrated Services
Digital Network-Number (MSISDN) =
Factory Serial Number (FSN) =
Modem Status = Modem Disconnected
Current Modem Temperature = 0 deg C
PRI SKU ID = , PRI version = , Carrier =
OEM PRI version =

It's completely empty and I don't understand why. I have tried to upgrade the Modem Firmware according to Cisco 1100 Series Software Configuration Guide, Cisco IOS XE Fuji 16.7.x - Cisco Fourth-Generation LTE Advanced on Cisco 1000 Series Integrated Services Router [Cisco IOS XE 16] - Cisco, but no success. The process times out.

Router#microcode re cellular 0 2 modem-provision flash:/test2
Reload microcode? [confirm]
Log status of firmware download in router flash?[confirm]
Firmware download status will be logged in bootflash:fwlogfile
Microcode Reload Process launched for cwan slot/bay =0/2; hw type=0x102download option = 0

Router#Success !! send FW Upgrade command to card

*****************************************************
 The interface will be Shut Down for Firmware Upgrade
 This will terminate any active data connections.
*****************************************************
**************************
 Modem will be upgraded!
 Upgrade process will take up to 15 minutes. During
 this time the modem will be unusable.
 Please do not remove power or reload the router during
 the upgrade process.
***************************
*Mar 23 13:26:37.194: ecell_ipc_rx_handler: IPC RX [8]:

<SNIP> *Mar 23 13:26:39.231: %LINK-5-CHANGED: Interface Cellular0/2/0, changed state to administratively down *Mar 23 13:26:39.231: cwan_hwif_state_change: Cellular0/2/0 ---------------------------- FIRMWARE INFO BEFORE UPGRADE: *Mar 23 13:27:05.190: ecell_ipc_rx_handler: IPC RX [263]: *Mar 23 13:27:05.190: IPC (40 bytes): 01 04 01 07 00 00 00 05 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 2D 00 00 00 00
<SNIP> *Mar 23 13:33:14.440: Firmware Upgrade Timed Out FW_UPGRADE: Abort Firmware upgrade and bring modem back to online state

I have tried these 3 modem FW's:

  • 74xx_02.33.03.00.cwe
  • MC7710_Global_03.05.29.02.cwe
  • MC7700_03.05.29.03_00_generic_000.000_001.cwe

Any information on witch firmware to use, modem type or other intel that resolves this issue are grately appreciated.

Regards

 

2 Replies 2

Hello,

 

what is the output of the command:

 

C1111#pwd

 

?

It says:

Router#pwd
bootflash:
Router#

Does that matter? The command I issued was:

Router#microcode reload cellular 0 2 modem-provision flash:/test3

'test3' is a directory containing the firmware. It didn't accept the command when I tried with firmware file directly on flash root.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card