02-18-2022 03:35 AM
Hello,
We have internet connection with our ISP and speed is 40mbps. But I need also provide for our specific clients additional Guaranteed 30mbps speed. ISP can temporary increase our speed up to 70mbps. But how I can configure Router that he can provide guaranteed speed for specific clients?
Solved! Go to Solution.
02-18-2022 04:06 AM - last edited on 02-18-2022 09:23 AM by Translator
Hello,
what you could do is configure a
child-parent policy
. In the example below, your customer in subnert 192.168.1.0/24 would be guaranteed 30Mbps, the rest is assigned to the default class. If more than the guaranteed 30Mbps ia available, the customer can use that bandwidth as well:
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!
class-map match-any CUSTOMER_30_MBPS
match access-group 101
!
policy-map CHILD_SHAPER
class CUSTOMER_30_MBPS
priority 30720
class class-default
fair-queue
!
policy-map PARENT_SHAPER
class class-default
shape average 70000
service-policy CHILD_SHAPER
02-18-2022 03:43 AM
You can create a ACL and make that users IP address to get assured bandwidth :
look at the below example thread :
https://community.cisco.com/t5/routing/guaranteed-bandwidth/td-p/1484778
02-18-2022 04:06 AM - last edited on 02-18-2022 09:23 AM by Translator
Hello,
what you could do is configure a
child-parent policy
. In the example below, your customer in subnert 192.168.1.0/24 would be guaranteed 30Mbps, the rest is assigned to the default class. If more than the guaranteed 30Mbps ia available, the customer can use that bandwidth as well:
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!
class-map match-any CUSTOMER_30_MBPS
match access-group 101
!
policy-map CHILD_SHAPER
class CUSTOMER_30_MBPS
priority 30720
class class-default
fair-queue
!
policy-map PARENT_SHAPER
class class-default
shape average 70000
service-policy CHILD_SHAPER
02-18-2022 04:26 AM - last edited on 02-18-2022 09:22 AM by Translator
On which direction and port do I need to install this
Policy-Map
?
02-18-2022 04:39 AM - last edited on 02-18-2022 09:16 AM by Translator
Hello,
sorry about that. Configure the policy outbound on the WAN interface, e.g.:
interface GigabitEthernet0/0
description Link to ISP
service-policy PARENT_SHAPER out
02-18-2022 06:04 AM - last edited on 02-18-2022 09:17 AM by Translator
If I will do policing?
For example:
ip access-list 101 deny ip 10.0.0.0 0.255.255.255 10.11.0.0 0.0.255.255
ip access-list 101 permit ip any 10.11.10.0 0.0.0.255
ip access-list 101 permit ip any 10.11.20.0 0.0.0.255
ip access-list 101 permit ip any 10.11.30.0 0.0.0.255
ip access-list 102 permit ip any 192.168.1.0 0.0.0.255
Class-map Staff
match access-group 101
!
Class-map Specific_Clients
match access-group 102
!
policy-map Policer
class Staff
police 40000000
class Specific_Clients
police 30000000
class class-default
!
interface gi0/1
description WAN
Service-policy input Policer
02-18-2022 07:04 AM
Hello,
I would not recommend policing, as policing just cuts off traffic when the limit is reached, while shaping smoothes out the traffic. Shaping is usually the better option.
02-18-2022 07:17 AM
Okay, thanks for your advice
03-05-2022 06:44 AM
thanks help
02-18-2022 10:34 AM
First, you'll need to determine what it means by "ISP can temporary increase our speed up to 70mbps." Is the 70 Mbps always guaranteed when you need it? If it is does, whether going beyond 40 Mbps, subjects the "excess" to higher drop probability and/or lower transit priority across ISP infrastructure? Further, you may want to consider if, when you exceed 40 Mbps, whether there's a surcharge, especially a "high rate" surcharge.
Depending on the answers to those questions, you may need to limit your usage to your guaranteed 40 Mbps to insure you'll always have your 30 Mbps and at an expected cost.
Whether you set your overall limit to 40 Mbps, or 70 Mbps, the QoS to accomplish what you want is much like what @Georg Pauwen already posted, but I would recommend a few changes and notes to Georg's recommendation, such as:
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
!
class-map match-any CUSTOMER_30_MBPS
match access-group 101
!
policy-map CHILD_SHAPER
class CUSTOMER_30_MBPSpriority 30720
bandwidth 30000 !I recall (?) bandwidth is in Kbps
fair-queue
class class-default
bandwidth 10000 !or 40 Mbps, i.e. all classes, together, should add up to total available, usable, bandwidth
fair-queue
!
policy-map PARENT_SHAPER
class class-default
shape average 70000000 !(I recall [?] shapers, or policers, use bps) or 40 Mbps, BTW I suspect some shapers don't account for L2 overhead, if not reduce rate by about 15%
service-policy CHILD_SHAPER
03-06-2022 03:43 AM
thanks for the help!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide