cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1165
Views
3
Helpful
7
Replies

CLI/Web Configuration Support for Cisco N540 (N540-12Z20G-SYS-A)

Cisco Support
Level 1
Level 1

Hi Everyone,

I already have fresh Cisco N540(N540-12Z20G-SYS-A) routers. I need to configure below mentioned configuration on that router:

  1. How to enable https web access via MGMTEthernet interface?
  2. If there is any possibility to create Link Aggregation? if yes, how can I configure Link Aggregation on IOS-XR software?
  3. If there is any possibility to configure SVI or VLAN interfaces on IOS-XR software? if yes, how can I configure VLAN interfaces?
  4. How to Configure HSRP/VRRP on IOS-XR software?

Note: I haven't any previous hands-on experience in IOS-XR, that Software, little bit different that other IOS so hope you guys gives your support to me...!

Thanks...!

1 Accepted Solution

Accepted Solutions

M02@rt37
VIP
VIP

Hello @Cisco Support 

1. How to enable https web access via MGMTEthernet interface?

RP/0/RP0/CPU0:ios# configure
RP/0/RP0/CPU0:ios(config)# crypto key generate rsa modulus 2048
RP/0/RP0/CPU0:ios(config)# username admin privilege 15 secret <password>
RP/0/RP0/CPU0:ios(config)# aaa authentication login default local
RP/0/RP0/CPU0:ios(config)# aaa authorization exec default local
RP/0/RP0/CPU0:ios(config)# line default transport input ssh
RP/0/RP0/CPU0:ios(config)# line default transport output ssh
RP/0/RP0/CPU0:ios(config)# line console
RP/0/RP0/CPU0:ios(config-line)# password <password>
RP/0/RP0/CPU0:ios(config-line)# login
RP/0/RP0/CPU0:ios(config-line)# exit
RP/0/RP0/CPU0:ios(config)# ssh server v2
RP/0/RP0/CPU0:ios(config)# ip http secure-server
RP/0/RP0/CPU0:ios(config)# interface mgmtEth0/RP0/CPU0/0
RP/0/RP0/CPU0:ios(config-if)# ip address <mgmt_ip_address>/<subnet_mask>
RP/0/RP0/CPU0:ios(config-if)# no shutdown

-- These commands will generate an RSA key, create an admin user with a password, enable SSH, and enable HTTPS web access via the mgmtEth0/RP0/CPU0/0 interface.

2. If there is any possibility to create Link Aggregation? if yes, how can I configure Link Aggregation on IOS-XR software?

RP/0/RP0/CPU0:ios# configure
RP/0/RP0/CPU0:ios(config-if)# interface Bundle-Ether <bundle_id>
RP/0/RP0/CPU0:ios(config-if)# ipv4 address <ip_address> <subnet_mask>
RP/0/RP0/CPU0:ios(config-if)# no shutdown
RP/0/RP0/CPU0:ios(config)# interface TenGigE0/0/0/1
RP/0/RP0/CPU0:ios(config-if)# bundle id <bundle_id> mode active
RP/0/RP0/CPU0:ios(config-if)# interface TenGigE0/0/0/2
RP/0/RP0/CPU0:ios(config-if)# bundle id <bundle_id> mode active


-- These commands will create link aggregation with TenGigE0/0/0/1 and TenGigE0/0/0/2, and assign an IP address to the Bundle-Ether interface.

3. If there is any possibility to configure SVI or VLAN interfaces on IOS-XR software? if yes, how can I configure VLAN interfaces?

RP/0/RP0/CPU0:ios# configure
RP/0/RP0/CPU0:ios(config)# interface <interface_name>.<vlan id>
RP/0/RP0/CPU0:ios(config-vlan)# ipv4 address <IP> <MASK>
RP/0/RP0/CPU0:ios(config)# encapsulation dot1q <vlan_id>

4. How to Configure HSRP/VRRP on IOS-XR software?

router vrrp
interface XXXXX
address-family ipv4
vrrp <id> version 3
priority 200
preempt delay 15
timer 1
address <Virtual_IP>

If HSRP then router hsrp instead of router vrrp menu

 

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

View solution in original post

7 Replies 7

M02@rt37
VIP
VIP

Hello @Cisco Support 

1. How to enable https web access via MGMTEthernet interface?

RP/0/RP0/CPU0:ios# configure
RP/0/RP0/CPU0:ios(config)# crypto key generate rsa modulus 2048
RP/0/RP0/CPU0:ios(config)# username admin privilege 15 secret <password>
RP/0/RP0/CPU0:ios(config)# aaa authentication login default local
RP/0/RP0/CPU0:ios(config)# aaa authorization exec default local
RP/0/RP0/CPU0:ios(config)# line default transport input ssh
RP/0/RP0/CPU0:ios(config)# line default transport output ssh
RP/0/RP0/CPU0:ios(config)# line console
RP/0/RP0/CPU0:ios(config-line)# password <password>
RP/0/RP0/CPU0:ios(config-line)# login
RP/0/RP0/CPU0:ios(config-line)# exit
RP/0/RP0/CPU0:ios(config)# ssh server v2
RP/0/RP0/CPU0:ios(config)# ip http secure-server
RP/0/RP0/CPU0:ios(config)# interface mgmtEth0/RP0/CPU0/0
RP/0/RP0/CPU0:ios(config-if)# ip address <mgmt_ip_address>/<subnet_mask>
RP/0/RP0/CPU0:ios(config-if)# no shutdown

-- These commands will generate an RSA key, create an admin user with a password, enable SSH, and enable HTTPS web access via the mgmtEth0/RP0/CPU0/0 interface.

2. If there is any possibility to create Link Aggregation? if yes, how can I configure Link Aggregation on IOS-XR software?

RP/0/RP0/CPU0:ios# configure
RP/0/RP0/CPU0:ios(config-if)# interface Bundle-Ether <bundle_id>
RP/0/RP0/CPU0:ios(config-if)# ipv4 address <ip_address> <subnet_mask>
RP/0/RP0/CPU0:ios(config-if)# no shutdown
RP/0/RP0/CPU0:ios(config)# interface TenGigE0/0/0/1
RP/0/RP0/CPU0:ios(config-if)# bundle id <bundle_id> mode active
RP/0/RP0/CPU0:ios(config-if)# interface TenGigE0/0/0/2
RP/0/RP0/CPU0:ios(config-if)# bundle id <bundle_id> mode active


-- These commands will create link aggregation with TenGigE0/0/0/1 and TenGigE0/0/0/2, and assign an IP address to the Bundle-Ether interface.

3. If there is any possibility to configure SVI or VLAN interfaces on IOS-XR software? if yes, how can I configure VLAN interfaces?

RP/0/RP0/CPU0:ios# configure
RP/0/RP0/CPU0:ios(config)# interface <interface_name>.<vlan id>
RP/0/RP0/CPU0:ios(config-vlan)# ipv4 address <IP> <MASK>
RP/0/RP0/CPU0:ios(config)# encapsulation dot1q <vlan_id>

4. How to Configure HSRP/VRRP on IOS-XR software?

router vrrp
interface XXXXX
address-family ipv4
vrrp <id> version 3
priority 200
preempt delay 15
timer 1
address <Virtual_IP>

If HSRP then router hsrp instead of router vrrp menu

 

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

M02@rt37 Thank you very much for your support...........! one more thing M02@rt3737 can I use GiG port as switch ports?

You're welcome @Cisco Support 

IOS XR is typically used in service provider or carrier-grade environments, where the focus is on routing rather than switching. As such, IOS XR does not have the same level of switch functionality as other Cisco operating systems like IOS or IOS XE. If you need more advanced switching capabilities, you may want to consider using a dedicated switch device such as a Cisco Catalyst switch with IOS or IOS XE.

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

Thank you M02@rt37 Please refer to the interface status of the both Routers:

 

Router 01:


RP/0/0/CPU0:ios#show interfaces brief
Tue Apr 11 03:47:08.712 UTC

Intf Intf LineP Encap MTU BW
Name State State Type (byte) (Kbps)
--------------------------------------------------------------------------------
BE1 down down ARPA 1514 0
Nu0 up up Null 1500 0
Mg0/0/CPU0/0 admin-down admin-down ARPA 1514 0
Gi0/0/0/0 up up ARPA 1514 1000000
Gi0/0/0/1 up up ARPA 1514 1000000
Gi0/0/0/2 admin-down admin-down ARPA 1514 1000000

RP/0/0/CPU0:ios#show interfaces gigabitEthernet 0/0/0/0
Tue Apr 11 03:47:31.561 UTC
GigabitEthernet0/0/0/0 is up, line protocol is up
Interface state transitions: 1
Hardware is GigabitEthernet, address is 50ac.7a01.3701 (bia 50ac.7a01.3701)
Internet address is Unknown
MTU 1514 bytes, BW 1000000 Kbit (Max: 1000000 Kbit)
reliability 255/255, txload 0/255, rxload 0/255
Encapsulation ARPA,
Full-duplex, 1000Mb/s, unknown, link type is force-up
output flow control is off, input flow control is off
Carrier delay (up) is 10 msec
loopback not set,
Last link flapped 19:53:07
Last input 01:01:35, output never
Last clearing of "show interface" counters never
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
20 packets input, 1400 bytes, 0 total input drops
0 drops for unrecognized upper-level protocol
Received 0 broadcast packets, 20 multicast packets
0 runts, 0 giants, 0 throttles, 0 parity
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 total output drops
Output 0 broadcast packets, 0 multicast packets
0 output errors, 0 underruns, 0 applique, 0 resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions


RP/0/0/CPU0:ios#show interfaces gigabitEthernet 0/0/0/1
Tue Apr 11 03:47:55.489 UTC
GigabitEthernet0/0/0/1 is up, line protocol is up
Interface state transitions: 1
Hardware is GigabitEthernet, address is 50ac.7a01.3702 (bia 50ac.7a01.3702)
Internet address is Unknown
MTU 1514 bytes, BW 1000000 Kbit (Max: 1000000 Kbit)
reliability 255/255, txload 0/255, rxload 0/255
Encapsulation ARPA,
Full-duplex, 1000Mb/s, unknown, link type is force-up
output flow control is off, input flow control is off
Carrier delay (up) is 10 msec
loopback not set,
Last link flapped 19:53:31
Last input 00:13:53, output never
Last clearing of "show interface" counters never
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
20 packets input, 1400 bytes, 0 total input drops
0 drops for unrecognized upper-level protocol
Received 0 broadcast packets, 20 multicast packets
0 runts, 0 giants, 0 throttles, 0 parity
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 total output drops
Output 0 broadcast packets, 0 multicast packets
0 output errors, 0 underruns, 0 applique, 0 resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions


Router 02:

RP/0/0/CPU0:ios#show interfaces brief
Tue Apr 11 03:48:23.167 UTC

Intf Intf LineP Encap MTU BW
Name State State Type (byte) (Kbps)
--------------------------------------------------------------------------------
BE1 down down ARPA 1514 0
Nu0 up up Null 1500 0
Mg0/0/CPU0/0 admin-down admin-down ARPA 1514 0
Gi0/0/0/0 up up ARPA 1514 1000000
Gi0/0/0/1 up up ARPA 1514 1000000
Gi0/0/0/2 admin-down admin-down ARPA 1514 1000000

RP/0/0/CPU0:ios#show interfaces gigabitEthernet 0/0/0/0
Tue Apr 11 03:48:36.446 UTC
GigabitEthernet0/0/0/0 is up, line protocol is up
Interface state transitions: 1
Hardware is GigabitEthernet, address is 5075.6601.3601 (bia 5075.6601.3601)
Internet address is Unknown
MTU 1514 bytes, BW 1000000 Kbit (Max: 1000000 Kbit)
reliability 255/255, txload 0/255, rxload 0/255
Encapsulation ARPA,
Full-duplex, 1000Mb/s, unknown, link type is force-up
output flow control is off, input flow control is off
Carrier delay (up) is 10 msec
loopback not set,
Last link flapped 19:54:07
Last input 01:02:26, output never
Last clearing of "show interface" counters never
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
20 packets input, 1400 bytes, 0 total input drops
0 drops for unrecognized upper-level protocol
Received 0 broadcast packets, 20 multicast packets
0 runts, 0 giants, 0 throttles, 0 parity
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 total output drops
Output 0 broadcast packets, 0 multicast packets
0 output errors, 0 underruns, 0 applique, 0 resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions


RP/0/0/CPU0:ios#show interfaces gigabitEthernet 0/0/0/1
Tue Apr 11 03:48:45.615 UTC
GigabitEthernet0/0/0/1 is up, line protocol is up
Interface state transitions: 1
Hardware is GigabitEthernet, address is 5075.6601.3602 (bia 5075.6601.3602)
Internet address is Unknown
MTU 1514 bytes, BW 1000000 Kbit (Max: 1000000 Kbit)
reliability 255/255, txload 0/255, rxload 0/255
Encapsulation ARPA,
Full-duplex, 1000Mb/s, unknown, link type is force-up
output flow control is off, input flow control is off
Carrier delay (up) is 10 msec
loopback not set,
Last link flapped 19:54:16
Last input 00:14:29, output never
Last clearing of "show interface" counters never
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
20 packets input, 1400 bytes, 0 total input drops
0 drops for unrecognized upper-level protocol
Received 0 broadcast packets, 20 multicast packets
0 runts, 0 giants, 0 throttles, 0 parity
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 total output drops
Output 0 broadcast packets, 0 multicast packets
0 output errors, 0 underruns, 0 applique, 0 resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions

As per your bundle-ether configuration i configured two IOS XR routers with bundle interface but i noticed bundle ether interface still down. What would be the issue?

Please refer to config files:

Router01:

interface Bundle-Ether1
ipv4 address 10.10.10.1 255.255.255.252
!
interface MgmtEth0/0/CPU0/0
shutdown
!
interface GigabitEthernet0/0/0/0
bundle id 1 mode active
!
interface GigabitEthernet0/0/0/1
bundle id 1 mode active

Bundle-Ether1
Status: Down
Local links <active/standby/configured>: 0 / 0 / 2
Local bandwidth <effective/available>: 0 (0) kbps
MAC address (source): 027c.7e59.a403 (Chassis pool)
Inter-chassis link: No
Minimum active links / bandwidth: 1 / 1 kbps
Maximum active links: 64
Wait while timer: 2000 ms
Load balancing:
Link order signaling: Not configured
Hash type: Default
Locality threshold: None
LACP: Not operational
Flap suppression timer: Off
Cisco extensions: Disabled
Non-revertive: Disabled
mLACP: Not configured
IPv4 BFD: Not configured

Port Device State Port ID B/W, kbps
-------------------- --------------- ----------- -------------- ----------
Gi0/0/0/0 Local Configured 0x8000, 0x0000 1000000
Bundle is in the process of being replicated to this location
Gi0/0/0/1 Local Configured 0x8000, 0x0000 1000000
Bundle is in the process of being replicated to this location

 

Router 02:

interface Bundle-Ether1
ipv4 address 10.10.10.2 255.255.255.252
!
interface MgmtEth0/0/CPU0/0
shutdown
!
interface GigabitEthernet0/0/0/0
bundle id 1 mode active
!
interface GigabitEthernet0/0/0/1
bundle id 1 mode active

Bundle-Ether1
Status: Down
Local links <active/standby/configured>: 0 / 0 / 2
Local bandwidth <effective/available>: 0 (0) kbps
MAC address (source): 022c.e0bd.0c03 (Chassis pool)
Inter-chassis link: No
Minimum active links / bandwidth: 1 / 1 kbps
Maximum active links: 64
Wait while timer: 2000 ms
Load balancing:
Link order signaling: Not configured
Hash type: Default
Locality threshold: None
LACP: Not operational
Flap suppression timer: Off
Cisco extensions: Disabled
Non-revertive: Disabled
mLACP: Not configured
IPv4 BFD: Not configured

Port Device State Port ID B/W, kbps
-------------------- --------------- ----------- -------------- ----------
Gi0/0/0/0 Local Configured 0x8000, 0x0000 1000000
Bundle is in the process of being replicated to this location
Gi0/0/0/1 Local Configured 0x8000, 0x0000 1000000
Bundle is in the process of being replicated to this location

 

 

Hello @Cisco Support 

The Bundle-Ether1 interface is showing as "down" on both routers because none of the member links have been activated. The local links section of the output shows that there are zero active links out of the 2 configured links for the bundle.

Please check the status of the physical interfaces Gig 0/0/0/0 and 0/0/0/1 on the routers.

 

Best regards
.ı|ı.ı|ı. If This Helps, Please Rate .ı|ı.ı|ı.

Dear M02@rt37 

Could you please share the OSPF/EIGRP configuration guide for IOS-XR firmware?

Review Cisco Networking for a $25 gift card