05-03-2021 06:50 AM
Hi All,
I need to find a solution to combine for a single receiver UDP multicast stream's from different VLAN. Details: ISP gave me a service on a RJ45 port. 3 Different UDP stream in 3 different VLAN.
I have a receiver, which can not handle VLANS, so I can connect it only to accesport, but I want to receive all 3 UDP mulicast stream in the same time.
The receiver has only one port. It means I need to untag all 3 VLAN, and combine them to one RJ45 port w/o VLAN's. How to do that ? Which unit's I will need ? Router, switch ?
05-03-2021 08:16 AM
What you desire might be done on a router or switch.
On a router, the ingress port would be configured to accept the tagged VLANs using subinterfaces. The egress port might be configured as a "normal" routed port. The multicast streams would be multicast routed from ingress ports to the egress port.
On a switch, the ingress port would be configured to accept the tagged VLAN using a trunk port. The egress port to the receiving host would be configured as an access port for one of the ingress VLANs. For the other two VLANs, you need two access ports for each of the two VLANs. One access port will be in one of the other VLANs, not being used to directly connect to the receiving host. The other port will be in the same VLAN as the receiving host. These two access port "pair" will be connected.
E.g.:
ingress VLAN 3,4,5
egress access port to host, VLAN 3
access port VLAN 4 connected to access port VLAN3
access port VLAN 5 connected to access port VLAN3
If the switch supports IGMP snooping, it might need to be disabled.
05-03-2021 09:05 AM
Hello Kaponya,
>> The receiver has only one port
>> which can not handle VLANS
Follow option 1 of Joseph's suggestions you need a router or multilayer switch in order to :
a) receive the threee streams on three VLAN based subinterfaces
b) to multicast route the streams to a different IP subnet on a physical interface untagged to accomodate the receiver
If the receiver is able to make IGMP joins it will be able to receive the streams.
Otherwise the router needs to emulate the IGMP joins in order to have an effective mutlicast routing.
check also the TTL of the streams it must be at least 2 to add a router in the middle.
You can use packet capture to verify this.
Hope to help
Giuseppe
05-03-2021 11:33 PM
Hi
I am not Cisco expert at all, better in TV world, so could you share me please a small config of it ? And also a cheap router for it ?
05-03-2021 11:34 PM
May be SG350 could be a solution ? Or L3 switch is not enough ?
05-04-2021 05:56 AM - edited 05-04-2021 05:59 AM
Hello ,
a L3 switch can be used and requires a configuration that is a little different.
You need to know the Vlan-IDs used by the threee streams for commodity I use the following values:
100, 200,300
Another Vlan is needed for the receiver.
You need to create the four VLANs the only one you can choice is the one towards the receiver.
The interface to the provider will be configured as:
an 802.1Q trunk carrying VLANs 100,200,300 tagged
interface giga0/1
desc to provider
switchport
switchport mode trunk
switchport trunk allowed vlan 100,200,300
interface giga0/2
desc to receiver
switchport
switchport mode access
switchport access vlan 400
b) L3 configuration
The provider should have provided you one IP subnet for each VLAN it provides to you
Here I suppose the subnets are 192.168.10.0/24, 192.168.20./24, 192.168.30.0/24
ip multicast-routing
interface Vlan 100
ip address 192.168.10.1 255.255.255.0
no shut
ip pim sparse-dense mode
interface Vlan 200
ip address 192.168.20.1 255.255.255.0
no shut
ip pim sparse-dense mode
interface Vlan 300
ip address 192.168.30.1 255.255.255.0
no shut
ip pim sparse-dense mode
Please note that all the commands are in IOS syntax for your SG350 you can use the GUI or admin guide.
You need to capture each multicast stream and look at the IP source in the packet
You will need appropriate static routes for each source pointing to the appropriate next-hop in the correct VLAN to avoid RPF failure.
ip route <S1> 255.255.255.255 192.168.10.2
ip route <S2> 255.255.255.255 192.168.20.2
ip route <S3> 255.255.255.255 192.168.30.2
download the following guide
https://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbms/350xg/admin_guide/AG_Tesla_350_550.pdf
Edit:
of course you need to configure also interface VLAN 400
interface VLAN 400
desc to the receiver
ip address 192.168.40.1 255.255.255.0
no shut
ip pim sparse-mode
exit
the receiver needs to have an IP address in subnet 192.168.40.0/24 like 192.168.40.25 mask 255.255.255.0 gateway 192.168.40.1
Hope to help
Giuseppe
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide