cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr
325
Views
0
Helpful
2
Replies
Highlighted
Beginner

Configuring GRE VPN Tunnel

Hi,

I've configured a VPN tunnel between two routers via a third, but am having some trouble using the tunnel.

 

In this scenario I have two sites connecting via a VPN through a third router acting as an ISP, however when issuing a traceroute it comes up as having passed through the ISP router. Would I be correct in thinking that a functioning tunnel would not show this middle step in the traceroute? This makes me think the tunnel is not being used and it is just using OSPF which I'd already set up between the three routers. 

If anyone could help fix this, I'd be very grateful! 

 

Here are the configurations for the three routers:

Site1:

interface Tunnel0

ip address 172.16.12.1 255.255.255.252

mtu 1476

tunnel source Serial0/0/0

tunnel destination 10.5.5.1

!

!

interface GigabitEthernet0/0

ip address 10.1.1.2 255.255.255.252

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 10.1.2.2 255.255.255.252

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

ip address 198.222.123.17 255.255.255.240

clock rate 128000

!

interface Serial0/0/1

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 10.1.1.0 0.0.0.3 area 0

network 198.222.123.16 0.0.0.15 area 0

!

ip classless

ip route 0.0.0.0 0.0.0.0 198.222.123.18

!

 

ISP:

interface Loopback0

ip address 209.165.200.225 255.255.255.224

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

ip address 198.222.123.18 255.255.255.240

!

interface Serial0/0/1

ip address 10.5.5.2 255.255.255.252

clock rate 2000000

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 198.222.123.16 0.0.0.15 area 0

network 10.5.5.0 0.0.0.3 area 0

!

ip classless

ip route 0.0.0.0 0.0.0.0 Loopback0

!

 

Site 2:

interface Tunnel0

ip address 172.16.12.2 255.255.255.252

mtu 1476

tunnel source Serial0/0/1

tunnel destination 198.222.123.17

!

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

no ip address

clock rate 2000000

shutdown

!

interface Serial0/0/1

ip address 10.5.5.1 255.255.255.252

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 10.5.5.0 0.0.0.3 area 0

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.5.5.2

!

 

I'm fairly new to this, so I appreciate you taking the time to help.

-Stuart

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Rising star

Re: Configuring GRE VPN Tunnel

Did you ping 172.16.12.2 source 172.16.12.1?

Thanks.

View solution in original post

2 REPLIES 2
Highlighted
Rising star

Re: Configuring GRE VPN Tunnel

Did you ping 172.16.12.2 source 172.16.12.1?

Thanks.

View solution in original post

Highlighted
Beginner

Re: Configuring GRE VPN Tunnel

Ah, that's embarrassing! I was pinging the serial interface. It's working, thanks